Troubleshooting¶
In case you are experiencing issues with using MySQL 8 and MySQL_FDW, below is a list of solutions to some frequently seen issues:
Authentication plugin ‘caching_sha2_password’ Error
ERROR: failed to connect to MySQL: Authentication plugin ‘caching_sha2_password’ cannot be loaded: /usr/lib64/mysql/plugin/caching_sha2_password.so: cannot open shared object file: No such file or directory
Specify the authentication plugin as mysql_native_password and set a cleartext password value. The syntax:
ALTER USER 'username'@'host' IDENTIFIED WITH mysql_native_password BY '<password>';
Note
Refer to MySQL 8 documentation for more details on the above error.