Error Codes¶
MigrationToolkitで問題が発生すると、エラーコードとメッセージのフォームで通知が発行されます。
この章では、エラーコード、メッセージ、およびそれらの解決策について説明します。
各エラーコードは、プレフィックスMTK-で始まり、その後に5桁が続きます。最初の2桁は、エラークラスの一般的な分類であるエラークラスを示します。最後の3桁は特定のエラー状態を表します。
次の表に、エラークラスを示します。
エラークラス |
説明 |
|---|---|
00 |
正常終了 |
01 |
情報 |
02 |
警告 |
03 |
一般的なエラー |
0x |
予約済み |
10 |
無効なユーザー入力 |
11 |
構成エラー |
12 |
不十分な特権 |
13 |
サポートされていない機能 |
14 |
不足しているオブジェクト |
15 |
スキーマの移行 |
16 |
手続き言語の移行 |
17 |
データの読み込み |
特定のデータベースサーバからエラーが報告された場合、このエラーメッセージの先頭には DB- が付きます。テーブルの作成が原因Postgres>データベースサーバ内の既存のテーブルに失敗した場合、エラーコード 42P07 は、データベースサーバによって返されます。MigrationToolkitログの特定のエラーは DB-42P07 として表示されます。
エラーコードの概要¶
次のセクションでは、MigrationToolkitのエラーコードを要約します。次の表の「エラーコード」列には、MigrationToolkitエラーコードがリストされています。[メッセージと解像度]列には、エラーコードとともに表示されるメッセージが含まれます。このメッセージは、エラーの原因とその解決方法を説明しています。
[メッセージと解像度]列の $NAME は、実行時に適切な値に置き換えられる情報のプレースホルダです。
クラス02-警告¶
このクラスはワーニングメッセージを表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-02000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべての警告は、このエラーコードを使用します。 |
MTK-02001 |
「runMTK-ヘルプ」を実行して、使用方法の詳細を確認します。 |
MTK-02002 |
警告!オフライン移行パス*$OFFLINE_PATH* は存在しません。スクリプトはユーザのホームフォルダーの下に作成されます。 |
クラス10-無効なユーザー入力¶
このクラスは、無効なユーザ入力値を表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-10000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-10001 |
information_schema、dbo、sys、またはpg_catalogをターゲットスキーマとして選択することはできません。これらは、メタデータ情報を*$DATABASE* に保存するために使用されます。 |
MTK-10002 |
「-schemaOnly」オプションと「-dataOnly」オプションを同時に指定することはできません。 |
MTK-10003 |
escapeTabDelimiterオプションを使用する場合、copyDelimiterとして''//t''が必要です。 |
MTK-10004 |
-truncLoadオプションは、-dataOnlyオプションでのみ指定できます。 |
MTK-10005 |
'-dataOnly'オプションは、-allTables/-tablesオプションにのみ適用可能です。このオプションが設定されている場合、スキーマDDLはコピーできません。 |
MTK-10006 |
-コンストレイン、-indexesと-triggersオプションは、-allTables/-tablesオプションのコンテキストで適用されます。 |
MTK-10007 |
「-vacuumAnalyze」オプションと「-analyze」オプションを同時に指定することはできません。 |
MTK-10008 |
コンストレイン--skipFKConstオプションはで与えられます。 |
MTK-10009 |
コンストレイン--skipCKConstオプションはで与えられます。 |
MTK-10010 |
-schemaOnlyオプションと一緒に-fastCopyオプションを指定することはできません。 |
MTK-10011 |
-skipColDefaultClauseを-dataOnlyオプションと一緒に指定することはできません。 |
MTK-10012 |
「-customColTypeMapping」オプションと「-customColTypeMappingFile」オプションを同時に指定することはできません。 |
MTK-10013 |
デフォルトの日付時刻は、「yyyy-MM-dd_HH:mm:ss」のフォーマットで指定する必要があります。時間部分はオプショナル。時間を指定するには、アンダースコア記号「_」が必要です。 |
MTK-10014 |
MySQLおよびSybaseを移行のターゲットデータベースとして選択することはできません。 |
MTK-10015 |
コピーデリミタは単一の文字でなければなりません。 |
MTK-10017 |
バッチサイズの数値が無効です。1〜50000の数値を使用してください。 |
MTK-10018 |
コピーバッチサイズは0より大きい必要があります。 |
MTK-10019 |
コピーバッチサイズの数値が無効です。0より大きい数値を使用してください。 |
MTK-10020 |
フェッチサイズは0より大きい必要があります。 |
MTK-10021 |
フェッチサイズの数値が無効です。0より大きい数値を使用してください。 |
MTK-10022 |
1つ以上のコマンドライン引数が無効です。 |
MTK-10023 |
-targetDBVersion値は、メジャー。/マイナー パターンを使用して指定する必要があります。 |
MTK-10024 |
-targetDBVersionは-offlineMigrationモードでのみ使用できます。 |
MTK-10025 |
オプション(-コンストレイン/|/-indexes|-triggers/|/-tables|-views/|/-sequences|-procs/|/-funcs|-パッケージソフト/|-synonyms)マルチプルのスキーマオプションでは使用できません。 |
MTK-10026 |
-allSchemasオプションは、コマンドラインオプションリストの最後のオプションとして指定する必要があります。 |
MTK-10027 |
無効なコマンドライン引数を指定しました。「runMTK-ヘルプ」を実行して、使用方法の詳細を確認します。 |
MTK-10028 |
-replaceNullCharは、-schemaOnlyオプションと一緒に指定できません。 |
MTK-10029 |
-nullReplacementCharは、-replaceNullCharオプションでのみ指定できます。 |
MTK-10030 |
コンストレイン--ignoreCheckConstFilterだけで与えることができます。 |
MTK-10031 |
-enableConstBeforeDataLoadは、-truncLoadオプションでのみ指定できます。 |
MTK-10032 |
retryCount値は0より大きい必要があります。 |
MTK-10033 |
retryCountの数値が無効です。0より大きい数値を使用してください。 |
MTK-10034 |
loaderCount値は0より大きい必要があります。 |
MTK-10035 |
loaderCountの数値が無効です。0より大きい数値を使用してください。 |
MTK-10036 |
COPYフォーマットのオフラインデータ移行にsingleDataFileオプションを使用できません。 |
MTK-10037 |
COPYフォーマットのオフラインデータ移行は、PostgreSQLまたはEnterpriseDB(EDBPostgresAdvancedServer)がターゲットデータベース場合にのみサポートされます。 |
MTK-10038 |
$SCHEMA*は、*$DATABASE のスキーマ名前として使用できません。-targetSchemaオプションで別のスキーマ名前を選択します。 |
MTK-10039 |
ログファイルサイズは0より大きい必要があります。 |
MTK-10040 |
ログファイルの数は0以上必要があります。 |
MTK-10041 |
オフライン移行は、スキーマのみのオプションでのみ使用できます。 |
MTK-10042 |
copyViaDBLinkOraオプションは、オラクルからEnterpriseDBにデータをコピーする場合にのみ使用できます。 |
MTK-10043 |
-recreateConstオプションは、-dataOnlyオプションでのみ指定できます。 |
MTK-10044 |
$DATABASE データベースタイプは、MigrationToolkitでサポートされていません。有効なデータベースタイプ文字列(つまり、EnterpriseDB、Postgres、オラクル、SQLServer、Sybase、またはMySQL)を指定します。 |
MTK-10045 |
$DATABASE データベースに指定されたURLは無効です。接続資格情報を確認してください。 |
MTK-10046 |
-escapeKeywords値は、真またはfalseです。 |
MTK-10047 |
-useOraCaseオプションは、オラクルからの移行にのみ使用できます。 |
MTK-10048 |
PostgresのエクスポートされたsnapshotIDは無効です。 |
MTK-10049 |
オラクルデータベースに指定されたURLは、dblink_oraではサポートされていません。接続資格情報を確認し、有効なURLを指定してください。 |
MTK-10050 |
スキーマ*$SCHEMA* がソースデータベースに見つかりません。 |
MTK-10051 |
skipUserSchemaCreationオプションは、オラクルからEnterpriseDBへのユーザ移行にのみ使用できます。 |
MTK-10052 |
-truncLoadオプションは、オフラインデータ移行では使用できません。 |
クラス11-構成の問題¶
このクラスは、toolkit.propertiesファイルまたはMigrationToolkitで使用される他の構成ファイルで提供される無効な構成設定を表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-11000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-11001 |
テーブルフィルター句を含むプロパティファイルを読み込めません。 |
MTK-11002 |
カスタムタイプマッピングファイルをロードできませんでした。理由:$REASON 。 |
MTK-11003 |
カスタムタイプマッピングファイルに無効なマッピングエントリーが含まれています。 |
MTK-11004 |
カスタムタイプマッピングファイルには、マッピングエントリーが含まれていません。 |
MTK-11005 |
ソースデータベースの接続情報は利用できません。 |
MTK-11006 |
ターゲットデータベースの接続情報は利用できません。 |
MTK-11007 |
ログディレクトリを作成できません。$PATH 。 |
MTK-11008 |
テーブル列フィルターリストを含むプロパティファイルを読み込めません。 |
MTK-11009 |
データベースの接続エラー*$DATABASE* 。 |
MTK-11010 |
$DBLINKORA_FILE ファイルのローディングエラー。 |
MTK-11011 |
DBLinkOraモジュールのローディング中にエラーが発生しました。$DBLINKORA_MODULE 。ターゲットのEnterpriseDBサーバーにdblink_oraがインストール/構成されていることを確認します。dblink_oraモジュールのインストールと構成の詳細については、『オラクル開発者ガイドのデータベース互換性ガイド』を参照してください。 |
MTK-11012 |
指定されたDBLink_Oraモジュールのローディング中にエラーが発生しました。$DBLINKORA_MODULE 。ターゲットのEnterpriseDBサーバーにdblink_oraがインストール/構成されていることを確認します。dblink_oraモジュールのインストールと構成の詳細については、『オラクル開発者ガイドのデータベース互換性ガイド』を参照してください。 |
MTK-11013 |
DBLinkOraモジュールをロードできませんでした。 |
MTK-11014 |
DBLinkOraへの接続エラー。 |
MTK-11015 |
接続資格情報ファイル*$TOOLKIT_PROP_FILE* は安全ではなく、グループ/他のユーザーはアクセスできません。このファイルにはプレーンパスワードが含まれており、MigrationToolkitの所有者ユーザのみに制限する必要があります。 |
クラス12-不十分な特権¶
このクラスは、データベースユーザ/ロール情報をローディングするための不十分権限エラーを表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-12000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-12001 |
権限が不十分なため、ユーザ/ロールの移行に失敗しました。オラクルカタログDBA_ROLES、DBA_USERS、DBA_TAB_PRIVS、DBA_PROFILES、DBA_ROLE_PRIVS、ROLE_ROLE_PRIVS、DBA_SYS_PRIVSに対するSELECT権限をユーザに付与します。 |
MTK-12002 |
権限が不十分なため、権限の移行に失敗しました。ユーザにオラクルカタログdba_tab_privsに対するSELECT権限します。 |
クラス13-サポートされていない機能¶
このクラスは、サポートされていないオブジェクトおよび句の移行に関連するエラーを表します。ターゲットデータベースが指定されたオブジェクトの実装を提供していないか、MigrationToolkitがその移行をハンドルしていません。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-13000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-13001 |
オラクルがインデックスをスキップすると、同じ列リストに対するマルチプルのインデックスは許可されません。 |
MTK-13002 |
$DATABASE ビューの移行はサポートされていません。 |
MTK-13003 |
$DATABASE ロールの場合、移行はサポートされていません。 |
MTK-13004 |
MySQL、SQLServer、Sybaseデータベースのトリガー、シーケンス、プロシージャ、関数、パッケージソフト、シノニムは移行できません。 |
MTK-13005 |
SQLServerデータベースのシーケンスとパッケージソフトを移行することはできません。 |
MTK-13006 |
トリガーが移行されない場合、トリガーは別のユーザスキーマによって所有され、スキーマ間トリガーはEnterpriseDBでサポートされません。 |
MTK-13007 |
指定されたトリガーは移行されません。トリガーには、EnterpriseDBでサポートされていないWHEN句があります。 |
MTK-13008 |
データベースリンク*$DATABASE_LINK* をスキップしています。EnterpriseDBは現在、このタイプのデータベースリンクをサポートしていません。 |
MTK-13009 |
警告!トリガー*$TRIGGER* の移行をスキップします。現在、非テーブルトリガーはターゲットデータベースではサポートされていません。 |
MTK-13010 |
プロシージャ、パッケージソフト、シノニム、およびデータベースリンクをPostgreSQLデータベースに移行することはできません。 |
MTK-13011 |
ドメインオブジェクトは、ターゲットデータベースではサポートされていません。 |
MTK-13012 |
ルールは*$DATABASE* データベースではサポートされていません。 |
MTK-13013 |
データベースの種類はサポートされていません。 |
MTK-13015 |
$TYPE はCOPYではサポートされていません。 |
MTK-13016 |
PostgreSQLへの移行は、オラクルまたはPostgreSQLがソースデータベース場合にのみサポートされます。 |
MTK-13017 |
グループは*$DATABASE* データベースではサポートされていません。 |
MTK-13018 |
プロファイルの移行は、$SRC_DB*から*$TARGET_DB への順列ではサポートされていません。 |
MTK-13019 |
不明なプロファイル*$PROFILE* を移行できません。 |
MTK-13020 |
プロファイルをデータベースバージョン*$VERSION* に移行できません。 |
MTK-13021 |
パスワードプロファイル確認ファンクション*$MY_VERIFICATION_FUNCTION* は明示的に移行する必要があります。 |
MTK-13022 |
アドバンスト・Queuesの移行は、$のSRC_DB*データベース*$TARGET_DBへ データベースからサポートされていません。 |
MTK-13023 |
アドバンストQueuesは、データベースバージョン*$VERSION* に移行できません。 |
MTK-13024 |
INTERVALパーティションは*$DATABASE* ではサポートされていません。テーブルはINTERVAL定義なしで移行され定義。 |
MTK-13025 |
警告!ユーザープロファイルの移行は、ターゲットデータベースバージョン*$VERSION*ではサポートされていません。ユーザ/"$USER/"のプロファイル/"$PROFILE /"はスキップされたます。 |
MTK-13026 |
$SRC_DB*から*$TARGET_DB へのオブジェクトタイプの移行はサポートされていません。 |
クラス14-欠落オブジェクト¶
このクラスは、ソースデータベース内のメタデータ情報の検索の失敗を表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-14000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-14001 |
ソース*$DATABASE* データベースに1つ以上のテーブルがありません。 |
MTK-14002 |
ソース*$DATABASE* データベースに1つ以上のテーブルが見つかりませんでした。-tablesモードでは、大文字と小文字を区別しない限り、テーブル名前は大文字にする必要があります。 |
MTK-14003 |
ソース*$DATABASE* データベースに1人以上のユーザーが見つかりませんでした。-usersモードでは、大文字と小文字を区別しない限り、ユーザ名前は大文字にする必要があります。 |
クラス15-スキーマの移行¶
このクラスは、テーブル、コンストレイン、インデックス、同義語、ビュー、ユーザー、ロールなどの非手続き型データベースオブジェクトに関連する移行の問題を表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-15000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-15001 |
制約*$CONSTRAINT* の作成エラー。 |
MTK-15002 |
ロール*$ROLE* の作成中にエラーが発生しました。 |
MTK-15003 |
$OBJECT*の特定の権限*$PRIVILEGE*を*$USER に付与する際にエラーが発生しました。 |
MTK-15004 |
$USER*への*$ROLE の付与エラー。 |
MTK-15005 |
権限*$REASON* の付与エラー。 |
MTK-15006 |
ユーザ*$USER* の作成中にエラーが発生しました。 |
MTK-15007 |
インデックス*$INDEX* の作成中にエラーが発生しました。 |
MTK-15008 |
ビュー*$VIEW* の作成中にエラーが発生しました。 |
MTK-15009 |
マテリアライズドビュー*$MVIEW* の作成中にエラーが発生しました。 |
MTK-15010 |
パブリックシノニム*$SYNONYM* の作成中にエラーが発生しました。 |
MTK-15011 |
プライベートシノニム*$SYNONYM* の作成中にエラーが発生しました。 |
MTK-15012 |
シーケンス*$SEQUENCE* の作成中にエラーが発生しました。 |
MTK-15013 |
テーブル*$TABLE* の作成中にエラーが発生しました。 |
MTK-15014 |
データベースリンク*$DATABASE_LINK* の作成中にエラーが発生しました。 |
MTK-15015 |
指定されたオブジェクトタイプ*$OBJECT_TYPE* の作成中にエラーが発生しました。 |
MTK-15016 |
テーブル*$TABLE*を*$DATABASE* データベースに作成できませんでした。 |
MTK-15017 |
リンクされたスキーマ*$LINKED_SCHEMA* はターゲットデータベースに存在しません。スキーマを作成してからリトライます。 |
MTK-15018 |
ドメイン*$DOMAIN* の作成中にエラーが発生しました。 |
MTK-15019 |
カスタムデータタイプ*$DATA_TYPE* の作成中にエラーが発生しました。 |
MTK-15020 |
グループ*$GROUP* のメンバーシップの作成中にエラーが発生しました。 |
MTK-15021 |
テーブル名前*$TABLE* にはスキーマ修飾子がありません。マルチプルのスキーマ移行コンテキストでは、各テーブルをスキーマ修飾する必要があります。 |
MTK-15022 |
スキーマ修飾子*$SCHEMA* は、スキーマリストとマッチしません。 |
MTK-15023 |
テーブルのメタデータ情報は利用できません。 |
MTK-15024 |
テーブルリストはまだ初期化されていません。 |
MTK-15025 |
データベースメタデータ情報の取得中にエラーが発生しました。 |
MTK-15026 |
グループ*$GROUP* の作成中にエラーが発生しました。 |
MTK-15027 |
プロファイル*$PROFILE* の作成中にエラーが発生しました。 |
クラス16-手続き言語の移行¶
このクラスは、プロシージャ、関数、パッケージソフト、匿名ブロック、トリガー、ルールなどの手続き言語に基づくデータベースオブジェクトに関連する移行の問題を表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-16000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-16001 |
トリガー*$TRIGGER* の作成中にエラーが発生しました。 |
MTK-16002 |
ルール*$RULE* の作成エラー。 |
MTK-16003 |
パッケージ仕様*$PACKAGE* の作成中にエラーが発生しました。 |
MTK-16004 |
パッケージ本体*$PACKAGE* の作成中にエラーが発生しました。 |
MTK-16005 |
パッケージボディが無効です。スキップしています...**Note:** このエラーメッセージは、パッケージ仕様が正常に移行されたが、ソースデータベースに対応するパッケージボディがない場合にも表示されます。この場合、エラーメッセージされても、ターゲットデータベースでパッケージ仕様が適切にファンクションする必要があります。 |
MTK-16006 |
プロシージャ*$PROCEDURE* の作成中にエラーが発生しました。 |
MTK-16007 |
ファンクション*$FUNCTION* の作成中にエラーが発生しました。 |
MTK-16008 |
匿名ブロック*$BLOCK* の作成エラー。 |
MTK-16009 |
キュー*$QUEUE* の作成中にエラーが発生しました。 |
クラス17-データの読み込み¶
このクラスは、ソースからターゲットデータベースにデータをコピーするときに発生する可能性のあるエラーを表します。
エラーコード |
メッセージと解決策 |
|---|---|
MTK-17000 |
このクラスに関連し、特定のエラーコードバインディングを持たないすべてのエラーは、このエラーコードを使用します。 |
MTK-17001 |
テーブルへのデータ読み込みエラー:$TABLE |
MTK-17002 |
エンコード変換では、代わりに一括挿入を使用して読み込まれるいくつかの文字が検出されました。 |
MTK-17003 |
コピーテーブル*$REASON* のエラー。 |
MTK-17004 |
無効なデータタイプ。 |
MTK-17005 |
このテーブルには、一括挿入ロード用にマークされたCLOBデータが含まれます。 |