PEMエージェントの管理

以下のセクションでは、PEMエージェントの動作と管理に関する情報を提供します。

エージェント権限

デフォルトでは、PEMエージェントはオペレーティングシステムホストの root 特権とデータベースサーバーのスーパーユーザー特権でインストールされます。これらの権限により、PEMエージェントは、システムの使用状況について監視対象ホストおよびデータベースサーバーで制限のないプローブを呼び出し、情報を取得してPEMサーバーに返すことができます。

PEMエージェントの権限が低下すると、PEM機能が低下することに注意してください。完全な機能を実現するには、PEMエージェントを root として実行する必要があります。 PEMエージェントがデータベースサーバーのサービスアカウントで実行されている場合、PEMプローブはレポートの生成に使用される統計情報に完全にアクセスできず、機能はそのアカウントの機能に制限されます。 PEMエージェントが別のより低い特権のアカウントで実行されている場合、機能はさらに制限されます。

PEMエージェントのオペレーティングシステム権限を制限すると、PEMプローブの一部が情報を返さず、次の機能が影響を受ける可能性があります。

プローブまたはアクション

オペレーティングシステム

影響を受けるPEM機能

データとログファイルの分析

Linux / Windows

Postgres Expertは完全な情報にアクセスできません。

セッション情報

Linux

プロセスごとの統計は不完全です。

PG HBA

Linux / Windows

Postgres Expertは完全な情報にアクセスできません。

サービス再起動機能

Linux / Windows

監査ログマネージャー、サーバーログマネージャー、ストリーミングレプリケーション、ログ分析エキスパート、およびPEMは、要求された変更を適用できない場合があります。

パッケージ展開

Linux / Windows

PEMはダウンロードしたインストールモジュールを実行できません。

バッチタスク

Windows

PEMは、Windowsでスケジュールされたバッチジョブを実行できません。

サーバーからデータを収集する(ルートアクセスが必要)

Linux / Windows

スワップ使用率、CPU使用率、IO読み取り、IO書き込みなどの列は、セッションアクティビティダッシュボードで0として表示されます。

注釈

上記のリストは包括的なものではありませんが、制限される機能の種類の概要を提供する必要があります。

PEMエージェントのデータベース特権を制限すると、次のPEM機能が影響を受ける可能性があります。

プローブ

オペレーティングシステム

影響を受けるPEM機能

監査ログの収集

Linux / Windows

PEMはPEMデータベースから空のデータを受け取ります。

サーバーログ収集

Linux / Windows

PEMはサーバーログ情報を収集できません。

データベース統計

Linux / Windows

データベース/サーバー分析ダッシュボードには、不完全な情報が含まれます。

セッション待機/システム待機

Linux / Windows

セッション/システム待機ダッシュボードには、不完全な情報が含まれます。

ロック情報

Linux / Windows

データベース/サーバー分析ダッシュボードには、不完全な情報が含まれます。

ストリーミングレプリケーション

Linux / Windows

ストリーミングレプリケーションダッシュボードには情報が表示されません。

Slonyレプリケーション

Linux / Windows

データベース分析ダッシュボードのSlony関連のグラフには情報が表示されません。

表領域サイズ

Linux / Windows

サーバー分析ダッシュボードには、完全な情報は表示されません。

xDBレプリケーション

Linux / Windows

PEMはxDBアラートとトラップを送信できません。

プローブが十分な権限を持たないオペレーティングシステムを照会している場合、プローブは permission denied エラーを返すことがあります。

プローブが不十分な特権でデータベースを照会している場合、プローブは permission denied エラーを返すか、返されたデータを空の値としてPEMチャートまたはグラフに表示します。

プローブが失敗すると、プローブの名前、プローブが失敗した理由、問題の解決に役立つヒントを含むエントリがログファイルに書き込まれます。

サーバーで発生したプローブ関連のエラーをプローブログダッシュボードで表示したり、PEMワーカーログファイルのエラーメッセージを確認したりできます。 Linuxでは、ログファイルのデフォルトの場所は次のとおりです。

/var/log/pem/worker.log

Windowsでは、ログ情報は Event Viewer で利用できます。

エージェント構成

多数のユーザー設定可能なパラメーターとレジストリエントリがPEMエージェントの動作を制御します。 PEMエージェントのパラメーター設定を変更して、 Streaming Replication ウィザードなどの一部のPEM機能を有効にする必要がある場合があります。 PEMエージェント構成ファイルの値を変更した後、変更を適用するにはPEMエージェントを再起動する必要があります。

PEM_MAXCONN パラメーターを除き、PEM機能を有効にするために変更が必要な場合を除き、EnterpriseDBサポートの専門家に相談することなく、以下にリストされている構成パラメーターまたはレジストリエントリを変更しないことを強くお勧めします。

Linuxシステムでは、PEM設定オプションは /opt/edb/pem/agent/etc にある agent.cfg ファイルに保存されます。 agent.cfg ファイルには次のエントリが含まれます:

パラメータ名

説明

デフォルト値

pem_host

PEMサーバーのIPアドレスまたはホスト名。

127.0.0.1。

pem_port

PEMサーバーと通信するためにエージェントが接続するデータベースサーバーポート。

ポート5432。

pem_agent

PEMエージェントに割り当てられた一意の識別子。

最初のエージェントは``1``、2番目のエージェントは``2``などです。

agent_ssl_key

PEMエージェントのキーファイルへの完全なパス。

/root/.pem/agent.key

agent_ssl_crt

PEMエージェントの証明書ファイルへの完全なパス。

/root/.pem/agent.crt

agent_flag_dir

HAサポートに使用されます。別のサーバーの監視を引き継ぐための要求をチェックするディレクトリパスを指定します。要求は、指定されたフラグディレクトリ内のファイルの形式で行われます。

デフォルトでは設定されていません。

log_level

ログレベルは、PEMログファイルに書き込まれるイベントのタイプを指定します。

警告

log_location

PEMワーカーログファイルの場所を指定します。

127.0.0.1。

agent_log_location

PEMエージェントのログファイルの場所を指定します。

/var/log/pem/agent.log

long_wait

最初の接続試行が失敗した場合に、PEMエージェントがPEMサーバーへの接続を試行する前に待機する最大時間(秒単位)。

30秒

short_wait

PEMエージェントがキュー内の次のプローブ(実行待ち)をチェックする前に待機する最小時間(秒単位)。

10秒

alert_threads

エージェントによって生成されるアラートスレッドの数。

PEMサーバーのホストに常駐するエージェントに対して1に設定します。他のすべてのエージェントの場合は0。

enable_smtp

trueに設定すると、SMTP電子メール機能が有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

enable_snmp

trueに設定すると、SNMPトラップ機能が有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

enable_nagios

trueに設定すると、Nagiosアラートが有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

connect_timeout

エージェントが接続を待機する最大時間(秒単位)(10進整数文字列)。

デフォルトでは設定されていません。 0に設定すると、エージェントは無期限に待機する必要があります。

allow_server_restart

TRUEに設定すると、エージェントは、監視するデータベースサーバーを再起動できます。このパラメーターの値に応じて、一部のPEM機能を有効/無効にすることができます。

偽

allow_package_management

TRUEに設定すると、更新モニターおよびパッケージ管理機能が有効になります。

偽

max_connections

接続スロットルで使用されるプローブ接続の最大数。

0(無制限の数)

connection_lifetime

ConnectionLifetime(またはconnection_lifetime)を使用して、開いているがアイドル状態の接続が保持される最小秒数を指定します。 MaxConnectionsで指定された値に達し、待機中の要求を満たすために(別のデータベースへの)新しい接続が必要な場合、このパラメーターは無視されます。

デフォルトでは、0に設定されます(エージェントの処理ループの後に接続がアイドル状態になると、接続はドロップされます)。

allow_batch_probes

TRUEに設定すると、ユーザーはカスタムプローブ機能を使用してバッチプローブを作成できます。

偽

heartbeat_connection

TRUEに設定すると、ハートビートの送信に専用の接続が使用されます。

偽

allow_streaming_replication

TRUEに設定すると、ユーザーはストリーミングレプリケーションを設定およびセットアップできます。

偽

batch_script_dir

スクリプトファイル(警告用)が保存されるパスを指定します。

/ tmp

connection_custom_setup

監視対象サーバーとの新しい接続が確立されたときに呼び出されるSQLコードを提供するために使用します。

デフォルトでは設定されていません。

ca_file

CA証明書が存在するパスを指定します。

/opt/PEM/agent/share/certs/ca-bundle.crt。

batch_script_user

バッチ/シェルスクリプトの実行に使用するユーザーの名前を指定します。

なし

64ビットWindowsシステムでは、PEMレジストリエントリは次の場所にあります。

HKEY_LOCAL_MACHINE/Software/Wow6432Node/EnterpriseDB/PEM/agent

レジストリには次のエントリが含まれます。

パラメータ名

説明

デフォルト値

PEM_HOST

PEMサーバーのIPアドレスまたはホスト名。

127.0.0.1。

PEM_PORT

PEMサーバーと通信するためにエージェントが接続するデータベースサーバーポート。

ポート5432。

AgentID

PEMエージェントに割り当てられた一意の識別子。

最初のエージェントは``1``、2番目のエージェントは``2``などです。

AgentKeyPath

PEMエージェントのキーファイルへの完全なパス。

%APPDATA%/ Roaming / pem / agent.key。

AgentCrtPath

PEMエージェントの証明書ファイルへの完全なパス。

%APPDATA%/ Roaming / pem / agent.crt

AgentFlagDir

HAサポートに使用されます。別のサーバーの監視を引き継ぐための要求をチェックするディレクトリパスを指定します。要求は、指定されたフラグディレクトリ内のファイルの形式で行われます。

デフォルトでは設定されていません。

LogLevel

ログレベルは、PEMログファイルに書き込まれるイベントのタイプを指定します。

警告

LongWait

最初の接続試行が失敗した場合に、PEMエージェントがPEMサーバーへの接続を試行する前に待機する最大時間(秒単位)。

30秒

shortWait

PEMエージェントがキュー内の次のプローブ(実行待ち)をチェックする前に待機する最小時間(秒単位)。

10秒

AlertThreads

エージェントによって生成されるアラートスレッドの数。

PEMサーバーのホストに常駐するエージェントに対して1に設定します。他のすべてのエージェントの場合は0。

EnableSMTP

trueに設定すると、SMTP電子メール機能が有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

EnableSNMP

trueに設定すると、SNMPトラップ機能が有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

ConnectTimeout

エージェントが接続を待機する最大時間(秒単位)(10進整数文字列)。

デフォルトでは設定されていません。 0に設定すると、エージェントは無期限に待機します。

AllowServerRestart

TRUEに設定すると、エージェントは、監視するデータベースサーバーを再起動できます。このパラメーターの値に応じて、一部のPEM機能を有効/無効にすることができます。

本当

AllowPackageManagement

TRUEに設定すると、更新モニターおよびパッケージ管理機能が有効になります。

偽

MaxConnections

接続スロットルで使用されるプローブ接続の最大数。

0(無制限の数)

ConnectionLifetime

ConnectionLifetime(またはconnection_lifetime)を使用して、開いているがアイドル状態の接続が保持される最小秒数を指定します。 MaxConnectionsで指定された値に達し、待機中の要求を満たすために(別のデータベースへの)新しい接続が必要な場合、このパラメーターは無視されます。

デフォルトでは、0に設定されます(エージェントの処理ループの後に接続がアイドル状態になると、接続はドロップされます)。

AllowBatchProbes

TRUEに設定すると、ユーザーはカスタムプローブ機能を使用してバッチプローブを作成できます。

偽

HeartbeatConnection

TRUEに設定すると、ハートビートの送信に専用の接続が使用されます。

偽

AllowStreamingReplication

TRUEに設定すると、ユーザーはストリーミングレプリケーションを設定およびセットアップできます。

偽

BatchScriptDir

スクリプトファイル(警告用)が保存されるパスを指定します。

/ tmp

ConnectionCustomSetup

監視対象サーバーとの新しい接続が確立されたときに呼び出されるSQLコードを提供するために使用します。

デフォルトでは設定されていません。

ca_file

CA証明書が存在するパスを指定します。

/opt/PEM/agent/share/certs/ca-bundle.crt。

AllowBatchJobSteps

trueに設定すると、バッチ/シェルスクリプトは管理者ユーザーアカウントを使用して実行されます。

なし

エージェントのプロパティ

PEM Agent Properties ダイアログは、ダイアログが開かれたPEMエージェントに関する情報を提供します。ダイアログを開くには、PEMクライアントツリーコントロールでエージェント名を右クリックし、コンテキストメニューから Properties を選択します。

The PEM Agent Properties dialog

The PEM Agent Properties dialog

PEMエージェントプロパティダイアログのフィールドを使用して、PEMエージェントに関する情報を確認または変更します。

  • Description フィールドには、PEMエージェントの変更可能な説明が表示されます。この説明は、PEMクライアントのツリーコントロールに表示されます。

  • グループを使用して、PEMクライアントツリーコントロールでサーバーとエージェントを整理できます。 Group ドロップダウンリストボックスを使用して、エージェントが表示されるグループを選択します。

  • Team フィールドを使用して、エージェントによって監視されているサーバーにアクセスできるグループロールの名前を指定します。このエージェントによって監視されるサーバーは、接続されたチームメンバーのPEMクライアントツリーコントロールに表示されます。これは便利な機能であることに注意してください。 [チーム]フィールドは真の分離を提供しないため、セキュリティの目的で使用しないでください。

  • Heartbeat interval フィールドは、PEMエージェントからPEMサーバーへのレポート間の経過時間を表示します。間隔を変更するには、 Minutes または Seconds フィールドの横にあるセレクターを使用します。