PEM 8.1 -PPEM Enterprise Features Guide

EnterpriseDB

navTitle: Enterprise Features Guide title: “PEM Enterprise Features Guide”
navigation: * - 01_what’s_new * - 02_pem_query_tool * - 03_pem_schema_diff_tool * - 04_pem_erd_tool * - 05_performance_monitoring_and_management * - 15_performance_diagnostic * - 06_capacity_manager * - 07_audit_manager * - 08_log_manager * - 09_sql_profiler * - 10_tuning_wizard * - 11_postgres_expert * - 17_monitoring_BDR_nodes * - 13_monitoring_failover_manager * - 14_monitoring_xdb_replication_cluster * - 12_reports * - 16_reference *

PEM Enterprise Features Guide

このガイドでは、 Postgres Enterprise Manager(PEM)Webインタフェースに組み込まれているツールとウィザードを使用しmake、システムのモニタと管理を容易にします。

このガイドは包括的なリソースではありません。むしろ、ツールの評価をヘルプ、製品の使用方法の基本を理解するための支援として機能することを目的としています。 PEMの機能の使用に関する詳細については、PEMクライアントで利用できるオンラインヘルプを参照してください。

このドキュメントでは、Postgresを使用して、 PostgreSQLまたはEDB Postgres Advanced ServerデータベースまたはEDB Postgres Extended(旧称2ndQPostgres)を意味します。

what’s_new pem_query_tool pem_schema_diff_tool pem_erd_tool performance_monitoring_and_management capacity_manager audit_manager log_manager sql_profiler Tuning_wizard postgres_expertレポートmonitoring_BDR_node monitoring_failover_manager monitoring_xdb_replication_cluster performance_diagnosticリファレンスの結論

</ div>

What’s New

バージョン8.1.0を作成するために、 Postgres Enterprise Managerに以下の変更が加えられました。

  • PEMコンソールを使用してBDR(Bi-Replication Replication)サーバーをモニタする機能が追加されました。
  • LinuxプラットフォームWebコンソール上のPEMサーバーのKerberos (GSSAPI)認証のサポートが追加されました。
  • 管理および監視用にEDB Postgres Extended(以前は2nQPostgresとして知られていました)のサポートを追加しました。
  • Entity-Relationship Diagram(ERD)デザインツールを追加して、データベースのER図を作成します。
  • PEMコンソールを介して論理レプリケーションのパブリッシャーとサブスクライバーを追加するためのサポートが追加されました。
  • 機能や関連するヘルプ記事をすばやく見つけるクイック検索オプションが追加されました。
  • データベースサーバを再起動せずに、次のPEMツールを使用してパラメーターを構成する機能が追加されました。
  • ログマネージャー
  • 監査マネージャー
  • チューニングウィザード

The PEM Query Tool

PEMには、 Postgresサーバーに対してアドホックSQLクエリを発行できる機能豊富なインタラクティブ開発環境(IDE)が含まれています。

クエリツールにアクセスするには、ToolsメニューのQuery Toolメニューオプションを使用するか、ブラウザツリーコントロールの選択ノードのコンテキストメニューを使用します。クエリツールを使用すると、次のことができます。

  • アドホックSQLクエリを発行します。
  • 任意のSQLコマンドを実行します。
  • updatableの場合、SELECTクエリーの結果セットを編集します。
  • ユーザが設定した現在の接続とトランザクションの状態を表示します。
  • 出力パネルに表示されるデータをCSVファイル。
  • テキスト、グラフィカルフォーマット、または表フォーマット(< https://explain.depesz.comに類似)でのSQLステートメントの実行計画を確認します。 SQLステートメントに関する分析情報を表示します。
Query Tool tab

クエリツールのマルチプルのコピーを個別のタブで同時に開くことができます。クエリツールのコピーを閉じるには、タブバーの右上隅にある* X *をクリックします。

クエリツールには2つのパネルがあります:

  • 上部パネルにSQL Editorが表示されます。パネルを使用して、クエリーを入力、編集、または実行ます。また、セッションで実行されたクエリをビューするために使用できるHistoryタブと、編集中にテキストスニペットを保持するために使用できるScratch Padも表示されます。スクラッチパッドが閉じている場合は、 SQLエディターおよびその他のパネルを右クリックして新しいパネルを追加することにより、スクラッチパッドを再度開く(または追加のものを開く)ことができます。
  • 下部のパネルには、Data Outputパネルが表示されます。タブ付きパネルには、クエリーによって返された結果セット、クエリの実行計画に関する情報、クエリの実行に関連するサーバメッセージ、およびサーバーから受信した非同期通知が表示されます。

クエリツールツールバー

Query Toolツールバーは、頻繁に実行されるタスクへのショートカットを提供する状況依存アイコンを使用します。アイコンが強調表示されている場合、オプションは有効になっています。アイコンがグレー表示されている場合、タスクは無効になっています。

Query Tool Toolbar

アイコンにカーソルを合わせると、アイコンの機能を説明するツールチップが表示されます。

Icon Behavior Shortcut
Open File Open Fileアイコンをクリックして、以前に保存したクエリーをSQLエディターに表示します。 Accesskey + O
Save Saveアイコンをクリックして、以前に保存したクエリーのクイック保存を実行するか、[保存]メニューにアクセスします。
-[Save]を選択して、 SQLエディターパネルの選択コンテンツをファイル。
-選択[名前を付けて保存]をクリックして、新しいブラウザーダイアログを開き、 SQLエディターパネルの選択したコンテンツを保存する新しい場所を指定します。
Accesskey + S
Save Data Changes Save Data Changesアイコンをクリックして、データ出力パネルのデータの変更(挿入、更新、または削除)をサーバーに保存します。 F6
Find Findメニューを使用して、 SQLエディターに表示されるコードを検索、置換、またはナビゲートします。
-検索ターゲットを提供するにはFindを選択し、 SQLエディターのコンテンツを検索します。
-次を検索するにはFind nextを選択検索ターゲットの出現。
-Find previousを選択して、検索ターゲットの最後の出現に移動します。
-Pesistent findを選択して、エディタ内の検索ターゲットのすべての出現を識別します。
-Replaceを選択します。ターゲットの個々の出現を見つけて(プロンプトで)置換します。
-Replace allを選択して、エディタ内のターゲットのすべての出現を見つけて置換します。
-Jumpを選択して、検索の次の出現にナビゲートし検索。ターゲット。
Cmd+F
Cmd+G
Cmd+Shift+G
Cmd+Shift+F
Alt+G
Copy Copyアイコンをクリックして、データ出力パネルで現在ハイライトされているコンテンツをコピーします。データの表示/編集モード。 Accesskey + C
Paste データの表示/編集モードで、Pasteアイコンをクリックして以前の行を新しい行に貼り付けます。 Accesskey + P
Delete Deleteアイコンをクリックして、選択した行を削除対象としてマークし削除。これらのマークされた行は、Save Data Changesアイコンをクリックすると削除されます。 Accesskey + D
Edit Editメニューのオプションを使用して、テキスト編集ツールにアクセスします。オプションは、クエリツールモードのときにSQLエディターパネルに表示されるテキストに作用します。
-現在選択されているテキストをインデントするには、Indent Selectionを選択します。
-現在選択されているテキストからインデントを削除するには、Unindent Selectionを選択します。
-Inline Comment Selectionを選択して、選択を含む行をSQLスタイルのコメント表記で囲みます。
-Inline Uncomment Selectionを選択して、選択した行からSQLスタイルのコメント表記を削除します。
-Block Commentを選択して、含む行をすべて囲みますCスタイルのコメント表記での選択。このオプションはトグルとして機能します。
Tab
Shift+Tab
Cmd+/
Cmd+.
Shift+Cmd+/
Filter Filterアイコンをクリックして、データの表示/編集モードでデータのフィルタリングおよび並べ替え基準を設定します。下矢印をクリックして、他のフィルタリングおよび並べ替えオプションにアクセスします。
-Sort/Filterをクリックして、並べ替えおよびフィルタリングダイアログを開きます。
-Filter by Selectionをクリックして、選択したセルの値を含む行のみを表示します。
-Exclude by Selectionをクリックして、選択したセルに値を含まない行のみを表示します。
-Remove Sort/Filterをクリックして、以前に選択した並べ替えまたはフィルタリングオプションを削除します。
Accesskey + F
Limit Selector Limit Selectorの値を選択して、データセットのサイズを行数に制限します。 Accesskey + R
Stop Stopアイコンをクリックして、現在実行中のクエリーの実行をキャンセルします。 Accesskey + Q
Execute/Refresh Execute/Refreshアイコンをクリックして、 SQLエディタパネルで強調表示されたクエリーを実行またはリフレッシュします。アクセス他の実行オプションにある下向き矢印をクリックしてください:
-トランザクション中にエラーが発生した場合にトランザクションをロールバック、自動的にサーバーに指示するために、次Auto-Rollbackにチェックを追加
-次Auto-Commitにチェックを追加します。各トランザクションを自動的にコミットするようサーバーに指示する。トランザクションによって行われたすべての変更は他のユーザーに可視れ、クラッシュしたイベントに永続的になります。
F5
Explain Explainアイコンをクリックして、現在のクエリーの説明プランをビューします。 EXPLAINの結果は、出力パネルのExplainタブにグラフィカルに表示され、Data Outputタブにテキストフォームで表示されます。 F7
Explain analyze Explain analyzeアイコンをクリックして、現在のクエリーでEXPLAIN ANALYZEコマンドを呼び出します。EXPLAINコマンドのオプションを選択オプションには、[説明オプション]メニューをナビゲートします。
-クエリプランに関する追加情報を表示するには、Verboseを選択します。推定されたスタートアップし、各プランノードの総コスト、ならびに行の推定数と行の推定幅に関する情報を含むように選択Costs
-選択バッファの使用状況に関する情報を含むようにBuffers <BR /。 >-Timingを選択して、スタートアップ時間とクエリーの各ノードで費やされた時間に関する情報を含めます。
-Summaryを選択して、クエリプランに関する要約情報を含めます。
NA
Commit Commitアイコンをクリックして、トランザクションをコミットします。 Shift+CTRL+M
Rollback Rollbackアイコンをクリックして、トランザクションをロールバックします。 Shift+CTRL+R
Clear Clearドロップダウンメニューのオプションを使用して、表示内容を消去します。
-Clear Query Windowを選択して、 SQL Editorパネルのコンテンツを消去します。
-Clear Historyを選択して、Historyタブのコンテンツを消去します。
Accesskey + L
Download as CSV Download as CSVアイコンをクリックして、現在のクエリーの結果セットをコンマ区切りリストにダウンロードします。 Preferences -> SQL Editor -> CSV outputダイアログでCSV設定を指定できます。 F8
Macros Macrosアイコンをクリックして、マクロを管理します。 [マクロの管理]オプションを使用して、macrosを作成、編集、またはクリアできます。
NA

SQLエディターパネル

SQL editorパネルは手動で、クエリーを提供し、別のソースからクエリーをコピー、またはファイルからのクエリーを読み取ることができるワークスペースです。 SQLエディタは、構文の色付けと自動補完を備えています。

Query Tool - Query Editor tab

オートコンプリートを使用するには、クエリーの入力を開始します;クエリエディタで、クエリーの次のオブジェクト名またはコマンドを提案する場合は、Control + Spaceキーの組み合わせをキー。例、タイプ(末尾のスペースを持つ)\*SELECT \* FROM\*、その後は、オートコンプリートオプションのポップアップメニューから選択しControl+Spaceキーの組み合わせを押してください。

Query Tool - Query Editor tab

クエリーを入力した後、ツールバーからExecute/Refreshアイコンを選択します。 SQLエディタパネルの完全な内容は、実行のためにデータベースサーバに送信されます。 SQLエディタに表示されるコードのセクションのみを実行には、サーバーで実行テキストを強調表示し、Execute/Refreshアイコンをクリックします。

Query Tool - Query Editor tab - Autocomplete feature

コマンドの実行時にサーバーから返されるメッセージは、Messagesタブに表示されます。コマンドが成功すると、Messagesタブに実行の詳細が表示されます。

Query Tool - Query Editor - Message tab

Editメニューのオプションは、コードのフォーマットとコメントを支援する機能を提供します。

  • 自動インデント機能は、Returnキーを押すと、前の行と同じ深さまでテキストを自動的にインデントます。
  • 2行以上を選択してTabキーを押すことでインデントテキストをブロックしキー。
  • 実装または削除SQLスタイルをしたり、コード内のCスタイルのコメント表記トグル。

ツリービューから特定のオブジェクトをdrag and dropして、長いオブジェクト名を入力する時間を節約することもできます。オブジェクト名前を含むテキストは、スキーマ名前で完全修飾されます。必要に応じて二重引用符が追加されます。関数とプロシージャの場合、ファンクション名前とパラメータ名がクエリツールに貼り付けられます。

データ出力パネル

Data Outputパネルには、最後に実行されたクエリーによって生成されたデータと統計が表示されます。

Query Tool - Data output tab

データ出力タブ

Data Outputタブには、クエリーの結果セットが表形式で表示されフォーマット。次のことができます。

  • 表示された結果セットから選択してコピーします。
  • 利用Execute/Refreshオプションは、クエリー実行情報とセットクエリー実行オプションを取得します。
  • Download as CSVアイコンを使用して、Data Outputタブのコンテンツをコンマ区切りファイルとしてダウンロードします。
  • SELECTクエリーの結果セットのデータが更新可能な場合は編集します。

結果セットは、次の場合に更新可能です。

  • すべての列は、単一の表から直接選択されるか、実際にはテーブル・カラムではありません(例、2つの列の結合)。テーブルから直接選択された列のみが編集可能で、他の列は読み取り専用です。
  • テーブルのすべてのプライマリキー列またはOIDが結果セットで選択されます。

複数回名前変更または選択された列も読み取り専用です。

Note * 更新可能なクエリー結果セットを使用するには、psycopg2ドライババージョン2.8以上がインストールされている必要があります。

編集可能で読み取り専用の列は、列ヘッダーの鉛筆アイコンとロックアイコンを使用してそれぞれ識別されます。

Query Tool - Editable and Read-only columns

更新可能な結果セットは、View/Edit DataモードのData Gridに似ており、同じ方法で変更できます。

自動コミットがoffの場合、進行中のトランザクションのパートとしてデータの変更が行われます。進行中のトランザクションがない場合、新しいトランザクションが開始されます。トランザクションがコミットされない限り、データの変更はデータベースにコミットされません。

すべてのエラーは、データの変更がバックをロールされていない現在進行中のトランザクション内のすべての以前に実行されたクエリを保証するために自動的に作成されたセーブポイントまでロールバックされます(NOT NULL制約を持つ列にNULLを保存しようと、例)保存中に発生した場合。

Data Outputパネルに表示される以前のクエリまたはコマンドのすべての行セットは、別のクエリーを呼び出すと破棄されます。別のクエリーツールのブラウザタブを開いて、以前の結果を利用できるようにします。

説明タブ

クエリーのExplainまたはExplain Analyzeプランを生成するには、ツールバーのExplainまたはExplain Analyzeボタンをクリックします。

ExplainおよびExplain Analyzeに関連するその他のオプションは、ツールバーのExplain Analyzeボタンの右側にあるドロップダウンから選択できます。

Query Tool - Toolbar Explain button

PEMはExplain [Analyze]プランをJSONフォーマットで生成することにノートてください。

Explainプランが正常に生成されると、Explainパネルの下に3つのタブ/パネルが作成されます。

グラフィカルタブ

Graphicalタブのアイコンにカーソルを合わせて、そのアイテムに関する情報を確認します。ポップアップウィンドウに、選択したオブジェクトに関する情報が表示されます。 JIT統計、トリガー、および概要については、右上隅のアイコンにカーソルを合わせてください。必要に応じて、同様のポップアップウィンドウが表示されます。

EXPLAIN VERBOSEはグラフィカルに表示できないことにノートてください。

Explainキャンバスの左上隅にあるダウンロードボタンを使用して、プランをSVGファイルとしてダウンロードします。 Download as SVG機能はInternet Explorerサポートされていないことにノートてください。

Query Tool - Explain tab - Graphical plan tab

Explain analyzeに付随するクエリプランは、Data Outputタブで利用できます。

分析タブ

Analysisタブには、プランの詳細が表フォーマットで表示され、explain.depsez.comで使用可能なフォーマットに類似したフォーマットが生成されます。テーブルの行は、Explain Plan Nodeのデータを表します。出力には、ノード情報、排他的タイミング、包括的タイミング、実際の行と計画された行、実際の行、計画された行、またはループが含まれる場合があります。あなたが行を選択すると、その選択された行の子行は、オレンジ色のドットでマークされています。

合計クエリー時間の排他的/包括的タイミングの割合が次の場合:

90より大きい->赤

50より大きい->オレンジ(赤と黄色の間)

10より大きい->黄色

プランナが行数(実際と計画)を誤って推定した場合:

10回->黄色

100回->オレンジ(赤と黄色の間)色

1000回->赤色

Query Tool - Explain tab - Analysis tab

統計タブ

Statisticsタブには、2つのテーブルに情報が表示されます。

  • Statistics per Node Typeは、各ノードタイプが被参照回数を示します。
  • Statistics per Tableは、各テーブルがクエリーによって被参照された回数を示します。
Query Tool - Explain plan tab - Statistics tab

メッセージタブ

Messagesタブを使用して、最後に実行されたクエリーに関する情報をビューます。

Query Tool - Output error

サーバーがエラーを返すと、エラーメッセージがMessagesタブに表示され、エラーの原因となった構文にSQLエディタで下線が引かれます。クエリーが成功した場合、Messagesタブには、クエリーの完了にかかった時間と取得された行数が表示されます。

Query Tool - Messages tab

通知タブ

Notificationsタブを使用して、 PostgreSQLのListen/Notify機能を使用して通知をビューします。詳細については、PostgreSQL documentationを参照してください。

例:

1.最初のQuery ToolセッションでLISTEN "foo"を実行します。

Query Tool - notifications listen

2.別のQuery Toolセッションで、Notifyコマンドまたはpg_notifyファンクションを実行して、ペイロードとともにイベントの通知を送信します。

Query Tool - notifications notify

3.最初のQuery ToolセッションのNotificationタブを見ると、特定のチャネルの記録時間、イベント、プロセスID、およびペイロードが表示されています。

Query Tool - Output Notifications panel

クエリ履歴パネル

Query Historyタブを使用して、現在のセッションのアクティビティを確認します。

Query Tool - Query History tab

Query Historyタブには、最近のコマンドに関する情報が表示されます。

  • クエリーが呼び出された日時。
  • クエリーのテキスト。
  • クエリーによって返される行の数。
  • サーバーがクエリーを処理して結果セットを結果のにかかった時間。
  • サーバーから返されたメッセージ(Messagesタブには記載されていません)。
  • クエリーのソース(ツールバーに対応するアイコンで示されます)。

(View/Edit DataまたはSave Data操作中に)pgAdminによって内部的に生成されたクエリを表示または非表示にすることができます。

Query Historyタブのコンテンツを消去するには、ClearドロップダウンメニューからClear historyを選択します。

クエリ履歴は、Query Toolモードで実行している場合、ユーザーごとに各データベースのセッションにわたって維持されます。 View/Edit Dataモードでは、履歴は保持されません。デフォルトでは、データベースごとに最後の20個のクエリが保存されます。これは、MAX_QUERY_HIST_STOREDの値をオーバーライドすることにより、config_local.pyで調整できます。

接続ステータス

クエリーツールのステータスアイコンをクリックして、Connection status機能を使用して現在の接続とトランザクションのステータスをビューします。

Query Tool - Connection Status button

マクロ

クエリツールマクロを使用すると、キーを1回キーで定義済みのSQLクエリを実行できます。事前定義されたクエリには、プレースホルダ$ SELECTION $を含めることができます。マクロを実行すると、プレースホルダはクエリツールのクエリエディターペインで現在選択されているテキストに置き換えられます。

Query Tool - Connection Status button

マクロを作成するには、クエリツールのマクロメニューからマクロの管理オプションを選択します。使用するキーを選択し、マクロの名前とクエリー(オプションで選択プレースホルダを含む)を入力し、[保存]ボタンをクリックしてマクロを保存します。

Query Tool - Connection Status button

マクロをクリアするには、* マクロを管理するダイアログでマクロを選択し、[クリア*ボタンをクリックしてください。

Query Tool - Connection Status button

サーバーは、マクロをクリアするための確認をプロンプトます。

Query Tool - Connection Status button

すべてのマクロをクリアするには、キーの左側にあるクリアボタンをクリックします。サーバーは、すべての行をクリアするための確認をプロンプトます。

Query Tool - Connection Status button

マクロを実行には、適切なショートカットキーを選択するか、マクロメニューから選択します。

Query Tool - Connection Status button

The PEM Schema Diff Tool

スキーマ差分は、2つのデータベーススキーマ間でスキーマオブジェクトを比較できる機能です。 Toolsメニューを使用して、スキーマ差分にアクセスします。

Schema Diff機能を使用すると、次のことができます。

  • データベーススキーマを比較および同期します(ソースからターゲットへ)。
  • データベーススキーマ間の違いを視覚化します。
  • ターゲットスキーマオブジェクトのSQLステートメントの違いを一覧表示します。
  • 同期スクリプトを生成します。

Note * ソースデータベースとターゲットデータベースは、同じメジャーバージョンである必要があります。

Toolsメニューの下のSchema Diffをクリックして、選択パネルを開きます。比較するソースサーバーとターゲットサーバー、データベース、およびスキーマを選択します。オブジェクトを選択したら、Compareボタンをクリックします。

個々のタブでSchema Diffのマルチプルのコピーを同時に開くことができます。タブを閉じるには、タブバーの右上隅にあるXをクリックします。

Schema Diff dialog

Preferencesダイアログを使用して、Schema Diffを新しいブラウザータブで開くかどうかを指定します。 Open in new browser tabオプションをtrueに設定します。

Schema Diffパネルは2つのパネルに分かれています。 Object Comparison panelおよびDDL Comparison panel。

スキーマ差分オブジェクト比較パネル

オブジェクト比較パネルでは、比較する同じメジャーバージョン、データベース、スキーマのソースサーバーとターゲットサーバーを選択できます。接続されているか切断されているかに関係なく、ブラウザツリーの下にリストされているサーバーを選択できます。接続されていないサーバーを選択すると、サーバーを使用する前にパスワードのプロンプトを求められます。

次に、比較するデータベースを選択します。データベースは同じでも異なっていてもかまいません(同じサーバー内または異なるサーバーから)。

最後に、比較するソーススキーマとターゲットスキーマを選択します。

Schema Diff dialog - Compare button

サーバー、データベース、およびスキーマを選択したら、CompareボタンをクリックしてComparison Resultを取得します。

Schema Diff dialog - Comparison Results

すべてのスキーマ・オブジェクトのDDLをビューするFunctions、マテリアライズド・Views、テーブル、トリガFunctions、Procedures、およびViewsのドロップダウンリストを使用してください。

オブジェクト比較パネルの右上隅にあるFilterオプションは、次の比較基準に基づいてスキーマオブジェクトをフィルタリングするために使用できます。

  • Identical –同じSQLステートメントを持つ両方のスキーマでオブジェクトが見つかった場合、比較結果は同じです。
  • Different –両方のスキーマでオブジェクトが見つかったが、 SQLステートメントが異なる場合、比較結果は異なります。
  • Source Only –ターゲットスキーマではなくソーススキーマのみでオブジェクトが見つかった場合、比較結果はソースのみです。
  • Target Only –オブジェクトがソーススキーマではなくターゲットスキーマのみで見つかった場合、比較結果はターゲットのみです。
Schema Diff dialog - Filter option

オブジェクト比較パネルでスキーマオブジェクトのいずれかをクリックして、DDL ComparisonパネルにそのオブジェクトのDDLステートメントを表示します。

スキーマ差分DDL比較パネル

DDL Comparisonパネルには3つの列が表示されます。

  • 最初の列には、ソーススキーマのオブジェクトのDDLステートメントが表示されます。
  • 2番目の列には、ターゲットスキーマのオブジェクトのDDLステートメントが表示されます。
  • 3列目には、ターゲットスキーマオブジェクトのSQLステートメントの違いが表示されます。
Schema Diff dialog - DDL Comparison panel

すべてのスキーマオブジェクトのDDLステートメントを確認して、 SQLステートメントの違いを確認できます。

スキーマ差分ツールを使用して、ソーススキーマオブジェクトのSQLステートメントに基づいて、ターゲットスキーマオブジェクトで見つかった差分のSQLスクリプトを生成することもできます。スクリプトを生成するには、オブジェクト比較パネルでスキーマオブジェクトのチェックボックスを選択し、オブジェクト比較パネルの右上隅にあるGenerate Scriptボタンをクリックします。

Schema Diff dialog - Generate Script button

スキーマオブジェクトを選択し、[Generate Script]ボタンをクリックして、Query Toolを新しいタブで開きます。Query Editorに表示されるSQLステートメントは異なります。

スキーマオブジェクトをクリックしてDDL Comparisonパネルで生成された違いを確認し、スキーマオブジェクトのチェックボックスを選択していないスキーマオブジェクト、PEMは新しいタブでQuery Toolを開き、 SQLステートメントの違いを表示します。 Query Editor。

Schema Diff dialog - Generate Script - Query Editor

Copyボタンを使用して、DDL Comparisonパネルで生成された差異をコピーすることもできます。

ターゲットスキーマのSQLステートメントを適用して、スキーマを同期します。

The ERD Tool

** Entity-Relationship Diagram(ERD)**ツールは、データベーステーブル、列、および相互関係のグラフィカル表現形式を提供するデータベースデザインツール。 ERDは、データベースを開発および保守する際にデータベース管理者が従うのに十分な情報を提供できデータベース。 ToolsメニューのERD ToolメニューオプションからERDツールにアクセスできます。 ERDツールを使用すると、次のことができます。

  • データベーステーブルとその関係を設計および視覚化します。
  • ダイアグラムにメモを追加します。
  • テーブルとリンクを自動調整して、視覚化を明確にします。
  • ダイアグラムを保存し、後で開いて作業を続けます。
  • データベースデザインから実行可能なSQLを生成します。
  • 既存のデータベースのデータベース図を生成します。
ERD Tool

ERDツールのマルチプルのコピーを個別のタブで同時に開くことができます。 ERDツールのコピーを閉じるには、タブバーの右上隅にあるXをクリックします。

ツールバー

** ERDツール**ツールバーは、頻繁に実行されるタスクへのショートカットを提供する状況依存アイコンを使用します。このオプションは、強調表示されたアイコンに対して有効になり、グレー表示されたアイコンに対しては無効になります。

ERD Tool - Toolbar

ファイルオプション

Icon Behavior Shortcut
Open File Open Fileアイコンをクリックして、以前に保存したダイアグラムをロードします。 Ctrl + O
Save Saveアイコンをクリックして、以前に保存したダイアグラムのクイック保存を実行するか、ダイアグラムをファイルに保存します。 Ctrl + S
Save as Save Asをクリックして新しいブラウザダイアログを開き、ダイアグラムを保存する新しい場所を指定します。 Ctrl + Shift + S

エクスポートオプション

Icon Behavior Shortcut
Generate SQL Generate SQLアイコンをクリックして、ダイアグラムのDDL SQLを生成し、生成されたSQLを実行できる状態でクエリーツールを開きます。 Option + Ctrl + S
Download image Download imageアイコンをクリックして、ERDダイアグラムをイメージ形式で保存しフォーマット。 Option + Ctrl + I

編集オプション

Icon Behavior Shortcut
Add table このボタンをクリックして、ダイアグラムに新しいテーブルを追加します。クリックすると、テーブルの詳細を入力できるテーブルダイアログが開きます。 Option/Alt + Ctrl + A
Edit table このボタンをクリックして、ダイアグラム上のテーブルを編集します。クリックすると、テーブルの詳細を変更できるテーブルダイアログが開きます。これにより、テーブルが選択されたときに有効になります。 Option/Alt + Ctrl + E
Clone table 、完全なテーブル構造を複製し、自動生成された名前でそれを名前、図にそれを置くためにこのボタンをクリックしてください。 Option/Alt + Ctrl + C
Drop table/link このボタンを使用して、テーブルまたはリンクをドロップできます。テーブルまたはリンクを選択し、このボタンをクリックしてドロップする必要があります。 Option/Alt + Ctrl + D

テーブル関係オプション

Icon Behavior Shortcut
1M このボタンをクリックして、 1対多のリレーションダイアログを開き、2つのテーブル間にリレーションを追加します。選択されたテーブルは参照テーブルになり、リンクのmanyエンドポイントを持ちます。 Option/Alt + Ctrl + O
MM このボタンをクリックして、多対多のリレーションダイアログを開き、2つのテーブル間にリレーションを追加します。このオプションは、2つの関連するテーブルに対して選択された列に基づいて新しいテーブルを作成し、それらをリンクします。 Option/Alt + Ctrl + M

ユーティリティオプション

Icon Behavior Shortcut
Add/Edit note データベースを設計しながら、テーブルのノードでノートをmakeためにこのボタンをクリックしてください。 Option/Alt + Ctrl + N
Auto align それはより多くのクリーナーを見えるmakeに自動整列するすべてのテーブルとのリンクを、このボタンをクリックします。 Option/Alt + Ctrl + L
Show details このボタンをクリックして、列の詳細の表示を切り替えます。いくつかの列の詳細を表示できます。 Option/Alt + Shift + D

ズームオプション

Icon Behavior Shortcut
Zoom to fit このボタンをクリックして、自動的にズームイン/ズームアウトし、すべてのテーブルをビューに合わせます。 Option/Alt + Shift + F
Zoom in このボタンをクリックして、ダイアグラムを拡大します。 Option/Alt + Shift + +
Zoom out このボタンをクリックして、ダイアグラムをズームアウトします。 Option/Alt + Shift + -

テーブルダイアログ

ERD Tool - Table Dialog

テーブルダイアログでは次のことができます。

  • テーブル構造の詳細を変更します。
  • 既存のテーブルを編集したり、新しいテーブルを追加したりできます。
  • さまざまなフィールドの詳細については、Table dialogを参照してください。

テーブルノード

ERD Tool - Table Node

テーブルノードは、グラフィカル表現形式でテーブルの詳細を表示します。

  • 上部のバーには、列の詳細の表示を切り替えるために使用されるdetails toggle buttonがあります。また、ノートが追加されている場合にのみ可視れるnote buttonもあります。このボタンをクリックすると、ノートをすばやく変更できます。
  • 最初の行は、テーブルのスキーマ名前を示しています。例上のイメージのpublic 行にはテーブル名前が表示されます。例上のイメージのusers
  • テーブル名前の下の他のすべての行は、データタイプとともにテーブルの列です。列がプライマリキーである場合、ロックキーアイコンが表示されます。 idは上記のイメージのプライマリキーです。それ以外の場合は、列アイコンが表示されます。
  • ノードをクリックしてドラッグし、キャンバス上を移動できます。
  • テーブルノードをダブルクリックするか、ツールバーの編集ボタンをクリックすると、テーブルダイアログが開き、そこでテーブルの詳細を変更できます。さまざまなフィールドについては、Table dialogを参照してください。

1対多のリンクダイアログ

ERD Tool - One to Many Dialog

1リンクダイアログでは、次のことができます。

  • 2つのテーブル間にフォリンキーリレーションを追加しキー。
  • Local Tableは、テーブルを参照し、manyエンドポイントを持つテーブルです。
  • Local Columnは参照する列です。
  • Referenced Tableは参照されているテーブルで、oneエンドポイントがあります。
  • Referenced Columnは参照されている列です。

多対多リンクダイアログ

ERD Tool - Many to Many Dialog

多対多リンクダイアログでは、次のことができます。

  • 2つのテーブル間に多対多のリレーションを追加します。
  • 2つのテーブルから派生した列を持つリレーションテーブルを作成し、それらをテーブルにリンクします。
  • Left Tableは、リンクされる最初のテーブルです。新しいリレーションテーブルを持つリンクのoneエンドポイントを受け取ります。
  • Left Columnは最初のテーブルの列で、常にプライマリキー。
  • Right Tableは、リンクされる2番目のテーブルです。新しいリレーションテーブルを持つリンクのoneエンドポイントを受け取ります。
  • Right Columnは2番目のテーブルの列であり、常にプライマリキー。

テーブルリンク

ERD Tool - Table Link

テーブルリンクは、テーブル間のリレーションを示しています。

  • リンクの単一行のエンドポイントには、リンクている列が表示されます。
  • リンクの3行のエンドポイントには、参照する列が表示されます。
  • 参照されている列または参照している列のいずれかがテーブルから削除されると、リンクはドロップされます。
  • リンクをクリックしてドラッグすると、キャンバス上を移動できます。

テーブルのメモ

ERD Tool - Table Notes
  • データベースの設計中に、ノートポップアップを使用していくつかのノートをマークできます。
  • ツールバーのノートボタンを使用してポップアップを開きます。
  • テーブルにノートが追加された場合、テーブルノードにノートボタンがあります。ボタンをクリックして、メモを確認/更新できます。

Performance Monitoring and Management

PEMには、すべての管理対象サーバーのエンタープライズ全体のパフォーマンスモニタリングを実装するビルトイン機能が含まれています。 PEMのさまざまなパフォーマンスモニタリングの側面の多くの側面をカスタマイズますが、製品に付属してすぐに使用できる推奨デフォルトを受け入れることもできます。

The Global Overview dashboard

最上位のダッシュボードはGlobal Overviewです。グローバル概要には、PEMサーバーによって監視されているすべてのサーバーとエージェントのステータス概要、監視対象サーバーのリスト、および現在トリガーされているアラートの状態が表示されます。

ダッシュボードを使用してパフォーマンス情報を表示する

PEMは、多数のダッシュボードを通じてパフォーマンス統計を表示します。各ダッシュボードには、選択したオブジェクトに関連する統計を表示するチャート、グラフ、および表を含むシリーズの概要ビューが含まれます。

PEMクライアントは、PEMサーバーに接続すると、Global Overviewダッシュボードを表示します。追加のダッシュボードは、監視対象オブジェクトに関する統計情報を提供します。これらには以下が含まれます。

アラートダッシュボード

アラートダッシュボードには、現在トリガーされているアラートが表示されます。グローバル概要から開くと、ダッシュボードにはシステム上のすべての監視対象ノードの現在のアラートが表示されます。サーバー内のノードから開くと、レポートはそのノードに関連するアラートと、ツリーコントロール内のそのオブジェクトの下にあるすべての監視対象オブジェクトを反映します。

監査ログ分析ダッシュボード

Advanced Serverのユーザーの場合、監査ログ分析ダッシュボードを使用すると、監査ロギングと収集が有効になっているインスタンスから収集された監査ログを閲覧することができます。

** BDR管理ダッシュボード**

BDR管理ダッシュボードには、BDRノード、BDRグループ、およびBDRワーカーに関する情報の概要が表示されます。

** BDRグループモニタリングダッシュボード**

BDRグループモニタリングダッシュボードには、BDRグループサブスクリプションおよびBDRグループレプリケーションスロットに関する情報が表示されます。

** BDRノード監視ダッシュボード**

BDRノードモニタリングダッシュボードには、選択したノードのBDRノードスロット、BDRノード複製率、およびBDR競合履歴の概要に関する情報が表示されます。

データベース分析ダッシュボード

データベース分析ダッシュボードには、選択したデータベースのパフォーマンス統計が表示されます。

** I / O分析ダッシュボード**

I / O分析ダッシュボードには、オブジェクトDMLアクティビティ、ログ操作など、さまざまな領域にわたるI / Oアクティビティが表示されます。

メモリ分析ダッシュボード

メモリ分析ダッシュボードは、 Postgresサーバーのさまざまなメモリ関連のメトリックに関する統計を提供します。

オブジェクトアクティビティ分析ダッシュボード

オブジェクトアクティビティ分析ダッシュボードは、選択したデータベースのテーブル/インデックスのパフォーマンスの詳細を提供します。

オペレーティングシステム分析ダッシュボード

オペレーティングシステム分析ダッシュボードは、基盤となるマシンのオペレーティングシステムのパフォーマンスに関する情報を提供します。

プローブログ分析ダッシュボード

プローブログ分析ダッシュボードには、PEMエージェントから返されたエラーメッセージが表示されます。

サーバー分析ダッシュボード

サーバー分析ダッシュボードは、選択したPostgresサーバーの全体的な操作に関する一般的なパフォーマンス情報を提供します。

サーバーログ分析ダッシュボード

Server Log Analysisダッシュボードを使用すると、PEMサーバーに保存されているサーバーログの内容をフィルタリングおよび確認できます。

セッションアクティビティ分析ダッシュボード

セッションアクティビティ分析ダッシュボードは、選択したサーバーのセッションワークロードとロックアクティビティに関する情報を提供します

セッション待機分析ダッシュボード

セッション待機分析ダッシュボードは、 Advanced Serverセッションの現在のDRITA待機イベントの概要を提供します。

ストレージ分析ダッシュボード

ストレージ分析ダッシュボードには、テーブルスペースとオブジェクトのスペース関連のメトリックが表示されます。

システム待機分析ダッシュボード

システム待機分析ダッシュボードには、 Advanced Serverセッションのシステム待機情報のグラフィカル分析が表示されます。

ストリーミングレプリケーション分析ダッシュボード

Streaming Replication Analysisダッシュボードには、監視対象サーバーのWALアクティビティに関する統計情報が表示され、フェールオーバーマネージャークラスターの状態をモニタできます。

ダッシュボードを開くには2つの方法があります。できること:

  • Dashboardsメニュー([管理]メニューからアクセス)からアクティブなダッシュボード名前を選択します。
  • ツリーコントロールで監視対象オブジェクトの名前を右クリックし、[ダッシュボード]メニューから確認するダッシュボードの名前を選択します。

各ダッシュボードは、クライアントウィンドウのメインパネルのMonitoringタブに表示されます。ダッシュボードを開いた後、同じタブ内の他のダッシュボードに移動できます。

各ダッシュボードヘッダーには、他のダッシュボードに移動できるナビゲーションメニューが含まれています。ブラウザの前後のアイコンを使用して、以前に表示したダッシュボードをスクロールします。更新アイコンを使用して、現在のダッシュボードを更新します。

Dashboard Configurationダイアログのオプションを使用すると、ダッシュボード上のすべての折れ線グラフのタイムラインをリンクできます。 Dashboard Configurationダイアログを開くには、ダッシュボードヘッダーに表示される[設定]アイコンをクリックします。

The Dashboard Configuration dialog

Dashboard Configurationダイアログのフィールドを使用して、ダッシュボードに表示されるチャートの属性を制御します。

  • すべての折れ線グラフスライダーのリンクタイムラインを有効に設定して、指定したタイムラインをダッシュボードに表示される折れ線グラフに適用することを示します。 [無効]に設定すると、設定は後で使用できるように保持されますが、表示されるデータの量は変更されません。
  • Daysセレクターを使用して、折れ線グラフに表示する収集データの日数を指定します。
  • Hour(s)セレクターを使用して、折れ線グラフに表示する収集データの時間数を指定します。
  • このダッシュボードの設定を記憶するの横のボックスをチェックして、カスタマイズされ時間間隔を現在のダッシュボードのみに適用することを示します。オフのままにすると、すべてのダッシュボードの折れ線グラフに時間間隔がグローバルに適用されます。

Dashboard Configurationダイアログで指定された設定は、現在のユーザーのセッションにのみ適用されることにノートてください。

カスタムダッシュボードの管理

PEMは、多数のシステム定義のダッシュボードを通じてパフォーマンス統計を表示します。各ダッシュボードには、選択したオブジェクトに関連する統計を表示するチャート、グラフ、およびテーブルを含むシリーズのサマリービューが含まれます。 Manage Dashboardsタブを使用して、システムに最も関連する情報を表示するカスタムダッシュボードを作成および管理できます。

The Manage Dashboards tab

カスタムダッシュボードを作成するには、[ダッシュボードの管理]タブの[クイックリンク]セクションにある[Create New Dashboard]リンクをクリックします。

既存のダッシュボードを変更するには、ダッシュボード名前の左側にある編集アイコンをクリックします。ダッシュボードエディタが開き、ダッシュボードの定義が表示されます。ダッシュボードの定義の変更が終了したら、Saveボタンをクリックして変更を保存します。 Cancelをクリックして、変更を保存せずに終了します。

ダッシュボードを削除するには、ダッシュボード名前の左側にある削除アイコンをクリックします。ダッシュボードを削除することを確認するポップアップが表示されます。 OKをクリックして、選択したダッシュボードを削除します。

カスタムダッシュボードの作成

PEMダッシュボードエディタを使用して、ユーザー定義のダッシュボードを作成または変更できます。カスタムダッシュボードには、事前定義されたチャート、ユーザー定義のチャート、または事前定義されたチャートとユーザー定義のチャートの組み合わせが含まれます。

The Create Dashboard editor

Configureセクションのフィールドを使用して、ダッシュボードに関する一般情報を指定します。

  • Nameフィールドにダッシュボードの名前を指定します。指定された名前は、タイトルが表示される場合、ダッシュボードのタイトルにもなります。
  • Levelドロップダウンリストボックスを使用して、ダッシュボードが表示されるPEMクライアント内のPEM階層のレベルを指定します。ダッシュボードには、グローバルレベル、エージェントレベル、サーバーレベル、またはデータベースレベルのダッシュボードメニューからアクセスできます。リスト内の選択された各レベルは、カスタムダッシュボードのグラフの基になるメトリックの異なるセットを公開します。
  • [説明]フィールドにダッシュボードの説明を入力します。

ダッシュボードをOpsダッシュボードとして使用する場合、Ops dashboard optionsボックスのフィールドに情報を入力します。

  • Ops Dashboard?フィールドをYesに設定して、Opsモニタに表示するためにフォーマットされたダッシュボードを作成するようサーバーに指示します。
  • Show Title?フィールドをYesに設定して、Opsダッシュボードの上部にダッシュボード名前を表示します。
  • Fontドロップダウンリストボックスを使用して、タイトルのカスタムフォントスタイルを選択します。選択したフォントスタイルがプレビューボックスに表示されます。
  • Font sizeドロップダウンリストボックスを使用して、タイトルのカスタムフォントサイズを選択します。選択したフォントスタイルがプレビューボックスに表示されます。

Permissionsボックスを使用して、新しいダッシュボードをビューできるユーザーを指定します。

  • Share with all sliderを[はい]に設定して、すべてのチームがダッシュボードにアクセスできるようにサーバーに指示するか、[すべてと共有]を[いいえ]に設定して、アクセス許可フィールドを有効にします。
  • Access permissionsフィールドを使用して、新しいダッシュボードをビューできるロールを指定します。フィールドをクリックし、ユーザーのリストから選択して、ダッシュボードにアクセスできるユーザーのリストにロールを追加します。

Configure Dashboardセクションが完成したら、右上隅の矢印をクリックしてセクションを閉じ、Dashboard Layout Designセクションにアクセスします。

Modifying a Section Header

セクションヘッダーの編集アイコンをクリックして、セクション名前を指定します。次に、追加アイコン(+)をクリックして、セクションにグラフを追加します。

Adding a Chart

各チャートカテゴリの右側にある矢印を使用して、使用可能なチャートを表示し、チャートを選択します。

Specifying placement details for a chart

チャート詳細セレクターを使用して、チャートの配置の詳細を指定します。

  • Chart widthセレクターを使用して、チャートの幅を示します。 50%を選択してダッシュボードの半分にグラフを表示するか、100%を選択してダッシュボードの幅全体を使用します。

  • Chart alignmentセレクターを使用して、セクション内のチャートの位置を示します。

    • Leftを選択して、チャートを左揃えにすることを示します。

    • Centerを選択して、チャートを中央に配置することを示します。

    • Rightを選択して、チャートを右揃えにすることを示します。

テーブルは常に中央に表示されることにノートてください。

カスタムダッシュボードを作成または編集する場合、ドラッグアンドドロップを使用して、セクション内のチャートを再配置したり、チャートを別のセクションに移動したりできます。

別のグラフをダッシュボードに追加するには、セクションヘッダーの追加アイコン(+)をクリックします。ダッシュボードの編集が終了したら、Saveボタンをクリックして編集内容を保存し、終了します。

変更を保存せずに終了するには、Cancelボタンをクリックします。

Opsダッシュボードの作成

PEMダッシュボードエディタを使用して、Opsモニタでの表示用にフォーマットされたカスタムダッシュボードを作成できます。 Opsダッシュボードは、ヘッダー情報を省略し、余分なバナー、タイトル、および境界線を最小限に抑えながら、指定されたチャートとグラフを表示します。

Ops dashboard options

Ops dashboardを作成するには、Create DashboardダイアログのOps dashboard optionsセクションでOps表示に関する詳細情報を提供します。

  • Ops Dashboard?フィールドをYesに設定して、Opsモニタに表示するためにフォーマットされたダッシュボードを作成するようサーバーに指示します。
  • Show Title?フィールドをYesに設定して、Opsダッシュボードの上部にダッシュボード名前を表示します。
  • Fontドロップダウンリストボックスを使用して、タイトルのカスタムフォントスタイルを選択します。選択したフォントスタイルがPreviewボックスに表示されます。
  • Font sizeドロップダウンリストボックスを使用して、タイトルのカスタムフォントサイズを選択します。選択したフォントスタイルがPreviewボックスに表示されます。

Opsダッシュボードにグラフと表を追加したら、Saveボタンをクリックして作業を保存します。その後、New DashboardダイアログのLevelフィールドで指定された階層レベルの[ダッシュボード]メニューをナビゲートして、ダッシュボードにアクセスできます。

チャートの管理タブを使用する

Manage Chartsタブを使用して、カスタム折れ線グラフまたは表を作成または変更したり、カスタムチャートで使用するCapacity Managerテンプレートをインポートたりできるダイアログにアクセスできます。チャートを定義した後、カスタムダッシュボードにチャートを表示できます。 Manage Chartsタブを開くには、PEMクライアントのManagementメニューからManage Charts...を選択します。

The Manage Charts tab

Manage Chartsタブには、次のダイアログにアクセスできるQuick Linksメニューがあります。

  • カスタムダッシュボードで使用するCreate a New Chart。
  • カスタムチャートを作成するためのテンプレートとして使用するImport a Capacity Managerテンプレート。
  • オンラインHelpにアクセスします。

Custom Chartsテーブルには、ユーザー定義のチャートのリストが表示されます。チャートが新しく追加されると、フォントは緑色で表示されます。追加のグラフを追加するか、スクリーンをリフレッシュすると、グラフの名前が黒で表示されます。

The Custom Charts table

Custom Chartsテーブルの右上隅にある検索ボックスを使用して、カスタムチャートを検索します。以下を指定します。

  • チャート名前
  • タイプ
  • レベル
  • メトリックカテゴリ

Custom Chartsテーブルのチャート名前の左側にあるアイコンを使用して、チャートを管理します。

  • 編集アイコンをクリックしてChart Configurationウィザードを開き、チャートまたはテーブルの側面を変更します。
  • 削除アイコンをクリックして、選択したチャートを削除します。

カスタムチャートの作成

Manage ChartsタブのQuick LinksセクションにあるCreate New Chartアイコンをクリックして、Create Chartウィザードを開きます。ウィザードは、新しいチャートを定義するために必要な手順をガイドします。

Specifying general information about the chart

Configure Chartダイアログのフィールドを使用して、チャートに関する一般情報を指定します。

  • Nameフィールドにチャートの名前を指定します。
  • Categoryフィールドのドロップダウンリストボックスを使用して、このチャートが表示されるカテゴリを指定します。カスタムダッシュボードにカスタムチャートを追加すると、指定したカテゴリで選択するためにチャートが表示されます。
  • Typeフィールドのラジオボタンを使用して、チャートがLine chartかTableかを指定します。
  • Descriptionフィールドにチャートの説明を入力します。説明は、情報アイコンをクリックすると、グラフを表示するユーザ(カスタムダッシュボード)に表示されます。

Configure Chartダイアログのフィールドに入力したら、Nextをクリックして続行します。

Specifying the metrics that will be displayed

Select Metricsダイアログのフィールドを使用して、チャートに表示されるメトリックを選択します。

  • Metric levelドロップダウンリストボックスを使用して、メトリックを選択するPEM階層のレベルを指定します。エージェント、データベース、またはサーバーを指定できます。各レベルは、プローブとメトリックの一意のセットへのアクセスを提供します。

  • [利用可能なメトリック]ボックスのツリーコントロールを使用して、チャートに表示されるメトリックを選択します。

    • テーブルを作成する場合、1つのプローブからメトリックのみを選択できます。ツリーコントロールの各ノードは、単一のプローブによって返されるメトリックをリストします。ツリーコントロールのノードを展開し、メトリック名前の左側のボックスをオンにして、そのメトリックデータをテーブルに含めます。

    • 折れ線グラフを作成している場合は、ツリーコントロールのノードを展開し、グラフに含める各メトリックをダブルクリックします。

  • [選択した指標]パネルのフィールドを使用して、グラフでの指標データの表示方法を指定します。選択パネルには、(変更不可能な)Metric  [Probe]列にメトリックの名前が表示されます。次のことができます。

    • -ごみ箱アイコンをクリックして、選択したメトリックのリストからメトリックを削除します。 -Selection Criteria列のドロップダウンリストボックスを使用して、表示されるデータのオーダーを指定します。 -Limitフィールドを使用して、テーブルの行数またはチャートの行数を指定します。

    • チャートで許可される最大行数は32です。

    • テーブルで許可される行の最大数は100です。

  • 折れ線グラフを作成する場合、PEMは階層間のメトリックの比較をサポートします。

    • -compare iconをクリックして選択ボックスを開き、1つ以上のプローブ固有の属性(CPU、インターフェイス、データベースなど)を選択してチャートで比較できるようにします。 -copyアイコンをクリックして、同じプローブのすべてのメトリックに選択を適用します。ポップアップが開いたら、Yesをクリックして同じプローブの他の選択が上書きされることを確認するか、Noをクリックして属性をコピーせずにポップアップを終了します。

Select Metricsダイアログのフィールドに入力したら、Nextをクリックして続行します。

Specifying chart options

Set Optionsダイアログのフィールドを使用して、チャートの表示オプションを指定します。

  • 利用チャートの更新間隔を分単位で指定するAuto Refreshフィールド-デフォルトの自動リフレッシュレートが2分である1から120まで値を選択します。

折れ線グラフのオプション見出しの下にあるフィールドを使用して、折れ線グラフの表示設定を指定します。

  • Points to plotフィールドを使用して、チャートにプロットするポイントの最大数を指定します。
  • 履歴スパンlabelの右側のフィールドを使用して、グラフに表示する履歴データの量を指定します。
  • Day(s)フィールドを使用して、チャートに含める履歴データの日数を指定します。
  • Hour(s)フィールドを使用して、チャートに含める履歴データの時間数を指定します。
  • Minute(s)フィールドを使用して、チャートに含める履歴データの分数を指定します。

Data extrapolationボックスのフィールドを使用して、PEMが履歴データに基づいて外挿データを生成するかどうかを指定します。

  • No Extrapolationlabelをクリックして、外挿データをチャートから除外します。
  • [Span]labelをクリックして、[日]および[時間]セレクターを使用して、チャート上のメトリックがスパンする期間を指定します。
  • しきい値セレクターを使用してグラフの最大値または最小値を指定するには、Thresholdlabelをクリックします。

Set Optionsダイアログのフィールドに入力したら、Nextをクリックして続行します。

Specifying access permissions

Set Permissionsダイアログのフィールドを使用して、グラフの表示オプションを指定します。

  • Share with all sliderをYesに設定して、すべての許可ユーザーがグラフを使用できることを示すか、Noを[アクセス許可]フィールドで指定されたユーザーまたはグループへのアクセスを制限します。
  • Access permissionsフィールドを使用して、チャートにアクセスするグループを選択します。
The chart definition is displayed on the Manage Charts tab

チャートの定義が終了したら、Finishをクリックして編集内容を保存し、Manage Chartsタブのリストにチャートを追加します。

キャパシティマネージャテンプレートのインポート

Manage Chartsタブの[クイックリンク]セクションにあるImport Capacity Manager TemplateアイコンをクリックしてCreate Chartダイアログを開き、Capacity Managerテンプレートをチャートまたはテーブルの開始点として使用します。

Importing a Capacity Manager template

Create Chartダイアログが開いたら、カスタムチャートに関する情報を提供します。

  • Import capacity templateフィールドのドロップダウンリストボックスを使用して、チャートのベースとなるテンプレートの名前を選択します。
  • Nameフィールドにチャートの名前を指定します。
  • Categoryフィールドのドロップダウンリストボックスを使用して、このチャートが表示されるカテゴリを指定します。カスタムチャートをカスタムダッシュボードに追加すると、指定したカテゴリで選択するためにチャートが表示されます。
  • Typeフィールドのラジオボタンを使用して、チャートがLine chartかTableかを指定します。
  • Descriptionフィールドにチャートの説明を入力します。説明は、情報アイコンをクリックすると、グラフを表示するユーザ(カスタムダッシュボード)に表示されます。

[Next]をクリックして、[メトリックの選択]ダイアログに進みます。

The template metrics

Select Metricsウィンドウでは、選択したテンプレートで指定されたメトリックを確認できます。チャートエディタの下部パネルには、チャートに含まれるメトリックが表示されます。チャートに含まれるメトリックは、チャートエディタでは変更できません。メトリックを変更するには、Capacity Managerユーティリティを使用してテンプレートを更新する必要があります。

メトリックを確認したら、[Next]をクリックして[オプションの設定]ダイアログに進みます。

Selecting chart options

Set Optionsウィンドウのフィールドを使用して、チャートの表示オプションを指定します。

  • 利用チャートの更新間隔を分単位で指定するAuto Refreshフィールド-デフォルトの自動リフレッシュレートが2分である1から120まで値を選択します。

Data extrapolationボックスのフィールドを使用して、チャートでカバーされる期間を指定します。次のいずれかを実行できます。

  • Historical days and extrapolated dayslabelをクリックして、以下を入力します。
  • Historicalフィールドにグラフ化する必要がある履歴データの日数。
  • Extrapolatedフィールドにチャート化する予定の日数。
  • または、履歴日としきい値のlabelをクリックして、以下を提供します。
  • Historicalフィールドにグラフ化する必要がある履歴データの日数
  • チャートが終了するthreshold値。

[オプションの設定]ウィンドウが完了したら、[Next]をクリックして続行します。

Selecting permissions for the chart

Set Permissionsウィンドウのフィールドを使用して、チャートの表示オプションを指定します。

  • Share with all sliderをYesに設定すると、すべての許可ユーザーがグラフを使用できることを示し、Noを設定すると、[アクセス許可]フィールドで指定されたユーザーまたはグループへのアクセスが制限されます。
  • Access permissionsフィールドを使用して、チャートにアクセスするグループを選択します。

チャートの定義が終了したら、Finishをクリックして編集内容を保存し、Manage Chartsタブのリストにチャートを追加します。

プローブ

probeは、PEMエージェントによって監視されているデータベースオブジェクトに関する情報を取得するスケジュールされたタスクです。 PEMは収集した情報を使用して、各ホームページに表示されるグラフを作成します。 (Managementメニューを介してアクセス)Manage Probesタブでは、データ収集スケジュールとPEMは、特定のプローブによって返された情報を保持する時間の長さを変更することができます。

システムプローブ

特に明記しない限り、 Postgres Enterprise Managerは以下の表にリストされたプローブを有効にします。

Probe Name Information Monitored by Probe Level
Background Writer Statistics このプローブは、バックグラウンドライタに関する情報を監視します。情報には以下が含まれます。
時間指定されたチェックポイントの数
要求されたチェックポイントの数
書き込まれたバッファの数(チェックポイントごと)
書き込まれたバッファの数(バックグラウンドライタ)< br />バックグラウンドライタサイクルの数
書き込まれたバックグラウンドバッファの数
割り当てられたバッファの数
Server
Blocked Session Information このプローブは、ブロックされたセッションに関する情報を提供します。 Server
CPU Usage このプローブは、CPU使用率情報を監視します。 Agent
Data and Log File Analysis このプローブは、ログファイルに関する情報を監視します。情報には以下が含まれます。
ログファイルの名前
ログファイルが存在するディレクトリ
Server
Database Frozen XID このプローブは、各データベースの凍結XIDを監視します。 Server
Database Size このプローブは、監視対象のデータベースのサイズに関する情報を監視します。情報には以下が含まれます。
情報が収集された時間
データベース名前
データベースサイズ(MB)。
Server
Database Statistics このプローブは、データベース統計を監視します。情報には以下が含まれます:
バックエンドの数
コミットされたトランザクションの数
ロールバックされたトランザクションの数
読み込まれたブロックの数
ヒットしたブロックの数< br />返された行の数
フェッチされた行の数
挿入された行の数
更新された行の数
削除された行の数
Server
Disk Busy Info このプローブは、ディスクアクティビティに関する情報を監視します。
注:このプローブは、Mac OS X、Solaris、またはHP-UXではサポートされていません
Agent
Disk Space このプローブは、ディスクスペースの使用状況に関する情報を監視します。情報には以下が含まれます:
使用されているディスクスペース
利用可能なディスクスペース
Agent
EDB Audit Configuration このプローブは、 EDB Postgres Advanced Serverの監査ロギング設定を監視します。 Server
Failover Manager Cluster Info このプローブは、フェールオーバーマネージャークラスターを監視し、クラスターに関する情報を返します。フェールオーバーマネージャーバイナリのクラスター名前とパスが[サーバーのプロパティ]ダイアログされない限り、このプローブは無効になります。 Server
Failover Manager Node Status このプローブは、フェールオーバーマネージャークラスターを監視し、クラスター内の各ノードに関する詳細を返します。フェールオーバーマネージャーバイナリのクラスター名前とパスが[サーバーのプロパティ]ダイアログされない限り、このプローブは無効になります。 Server
Function Statistics このプローブは、データベースを監視し、機能に関する情報を取得します。情報には以下が含まれます:
ファンクション名
引数の型
戻り値
Database
Index Size このプローブはデータベースを監視し、インデックスに関する情報を取得します。情報が含まれています:時間
インデックスの名前
データ(MBの中に)インデックスのサイズ
集めました
Database
Index Statistics このプローブは、インデックス統計を監視します。情報には以下が含まれます:
インデックススキャンの数
読み込まれた行の数
フェッチされた行の数
読み込まれたブロックの数
ヒットしたブロックの数
Database
Installed Packages このプローブは、現在インストールされているパッケージソフトを監視します。収集される情報には以下が含まれます。
インストール済みパッケージの名前
インストール済みパッケージのバージョン
プローブが実行された日時
Agent
IO Analysis このプローブは、ディスクI / O情報を監視します。情報には、
読み込まれたブロック数
書き込まれたブロック数
プローブが実行された日時
注:このプローブはMac OS Xではサポートされていません
Agent
Load Average このプローブは、CPUのロード平均を監視します。情報には以下が含まれます:
1分間のロード平均
5分間のロード平均
15分間のロード平均
注:このプローブはWindowsサポートされていません
Agent
Lock Information このプローブはロック情報を監視します。情報には以下が含まれます:
データベース名前
ロックタイプ
ロックモード
ロックを保持しているプロセス
Server
Memory Usage システムメモリusage.The情報については、このプローブの監視情報は、<BR / メガバイトにおけるメガバイト
無料スワップ・メモリ内のメガバイト
総スワップ・メモリのメガバイト
フリーRAMにおける総RAM
> メガバイト単位の共有システムメモリ(データベースサーバのメモリパラメータを調整するためにチューニングウィザードによって使用されます)
-非Windowsシステムでは、shmmax値であり、/proc/sys/kernel/shmmaxから読み取られます。
-Windows 、それは合計メモリと同じです。
Agent
Network Statistics このプローブは、ネットワーク統計を監視します。情報には以下が含まれます:
インタフェースIPアドレス
送信パケット数
受信パケット数
送信バイト数
受信バイト数
リンク速度( メガバイト/秒)
Agent
Number of Prepared Transactions このプローブは、準備されたトランザクションの数を保存します。 Server
Number of WAL Files このプローブは、WALファイルの数を監視します。 Server
Object Catalog: Database このプローブは、データベースとそのプロパティのリストを監視します。情報には以下が含まれます。
データベース名前
データベースエンコーディングタイプ
データベースでユーザ接続またはシステム接続が許可されている場合
Server
Object Catalog: Foreign Key このプローブは、外部キーとそのプロパティのリストを監視します。情報には、外部キー参照テーブルが存在するが
たデータベースの名前を
するテーブルの名前
外部キーを含むテーブルの名前
テーブルが存在するスキーマの名前
Schema
Object Catalog: Function このプローブは、関数とそのプロパティのリストを監視します。情報には、ファンクションが存在するが、ファンクションが存在するデータベースの名前を
たスキーマの名前
ファンクションの
名前
Schema
Object Catalog: Index このプローブは、インデックスとそのプロパティのリストを監視します。情報には、テーブルの名前
インデックスの
名前をインデックスがでインデックス付きテーブルが存在するデータベースの
名前に関連付けられていること
Schema
Object Catalog: Schema このプローブは、スキーマのリスト、およびそれらに関連付けられているデータベースとサーバーを監視します。 Database
Object Catalog: Sequence このプローブは、シーケンスとそのプロパティのリストを監視します。 Schema
Object Catalog: Table このプローブは、テーブル情報のリストを監視します。情報には、テーブルが存在するスキーマが存在するがどうかを示すブール指標を
れたデータベースの名前を
たスキーマの名前
はテーブル名前をテーブルにはプライマリキー
Schema
Object Catalog: Tablespace このプローブは、テーブルスペースのリストを監視します。 Server
Operating System Information このプローブは、オペレーティングシステムの詳細と起動時間を監視します。 Agent
Package Catalog このプローブは、現在インストール可能なパッケージソフトを監視します。収集される情報には以下が含まれます:
パッケージ名前
パッケージのバージョン
Agent
PG HBA Conf このプローブは、pg_hba.confファイルの認証設定情報を監視します。 Server
Server Information このプローブはサーバー情報を監視します。 Server
Session Information このプローブは、セッション情報を監視します。情報には次のものが含まれます。
セッションユーザの名前
セッションがサーバーに接続した日時
情報が収集された時点のセッションのステータス(アイドル、待機中)など)
クライアントアドレスとポート番号
Server
Settings このプローブは、現在GUC変数に割り当てられている値を監視します。 Server
SQL Protect このプローブはサーバーを監視し、 SQLインジェクション攻撃に関する情報を取得します。 Server
Slony Replication このプローブは、Slonyを使用して複製されたクラスターの遅延データを監視します。 Database
Streaming Replication このプローブは、ストリーミングレプリケーションを使用しているクラスターを監視し、次の情報を取得します:
送信されたXlogロケーション(バイト単位)
書き込みXlogロケーション(バイト単位)
フラッシュXlogロケーション(バイト単位) )
Xlogのリプレイ場所(バイト単位)
Xlogのラグ(セグメント)
Xlogのラグ(ページ)
Server
Streaming Replication Lag Time このプローブは、ストリーミングレプリケーションを使用しているクラスターを監視し、次に関する遅延情報を取得します。
レプリケーションラグタイム(秒単位)
レプリケーションの現在のステータス(実行中/一時停止)
Server
Streaming Replication Database Conflicts このプローブは、ストリーミングレプリケーションを使用しているデータベースを監視し、発生した競合に関する情報を取得します。これは、にキャンセルされたクエリについての情報が含まれていますドロップテーブルスペースの競合の#は、ロック・タイムアウトの競合の#を

は固定の#を古いsnapshotの競合の#を
バッファの競合
デッドロックの競合の数
Server
Table Bloat このプローブは、現在のテーブルの膨張に関する情報を監視します。情報には、テーブルが存在するが、ページの推定数が無駄ページの推定数は
は
たスキーマの名前
テーブルの名前
行ごとの推定バイト数
Database
Table Frozen XID このプローブは、各テーブルの凍結されたXIDを監視します。 Schema
Table Size このプローブは、テーブルサイズに関する情報を監視します。情報には以下が含まれます。
テーブルサイズ(MB単位)
総インデックスサイズ(MB単位)
総テーブルサイズ、インデックスおよびTOAST (MB単位)
Database
Table Statistics このプローブは、テーブル統計を監視します。情報には以下が含まれます:
シークエンシャル スキャンの数
シーケンシャルスキャンの行の数
インデックススキャンの数
インデックススキャンの行の数
行の数挿入
更新された行の数
削除された行の数
ライブ行の数
デッド行の数
最後のVACUUM
最後auto-vacuum
最後のANALYZE
最後のauto-analyze
ANALYZEによって推定されたページ数
ANALYZEによって推定された行数
Database
Tablespace Size このプローブは、テーブルスペースとそのサイズのリストを監視します。 Server
User Information このプローブは、現在のユーザーのリストを監視します。格納される情報には以下が含まれます。
ユーザ名前
ユーザの種類(スーパーユーザと非スーパーユーザー)
ユーザが接続しているサーバー
Server
WAL Archive Status このプローブは、WALアーカイブのステータスを監視します。格納される情報には、
完了したWALアーカイブの数
保留中のWALアーカイブの数
最終アーカイブ時刻
失敗したWALアーカイブの数
最後の失敗
Server
xDB Replication このプローブは、xDBレプリケーションを使用して複製されたクラスターの遅延データを監視します。 Database