Administering
=============

When running a PGD cluster with Group Commit, there are some things you
need to be aware of when administering the system, such as how to safely
shut down and restart nodes.

Planned shutdown and restarts
-----------------------------

When using Group Commit with receive confirmations, take care with
planned shutdown or restart. By default, the apply queue is processed
prior to shutting down. However, in the ``immediate`` shutdown mode, the
queue is discarded at shutdown, leading to the stopped node “forgetting”
transactions in the queue. A concurrent failure of the origin node can
lead to loss of data, as if both nodes failed.

To ensure the apply queue gets flushed to disk, use either :ref:`smart <Monitoring through SQL>` 
for maintenance tasks. This approach maintains the required
synchronization level and prevents loss of data.
