Trusted Postgres Architect 23.17 release notes

New features, enhancements, bug fixes, and other changes in Trusted Postgres Architect 23.17 include the following:

Type

Description

Enhancement

Added a new –pgd-proxy-routing parameter to the configure command. This can be set to global or local. Local routing will make every PGD-Proxy route to a write leader within its own location. Global routing will make every proxy route to a single write leader, elected amongst all available data nodes across all locations.

Change

Removed the –active-locations parameter from the configure command.

Enhancement

TPA now supports Ubuntu 22.04

Change

Updated the AWS AMIs used for RHEL 7 and 8.

Bug fix

Fixed an issue whereby TPA would incorrectly remove groups from existing Postgres users.

Bug fix

Fixed an issue whereby TPA would print an unhelpful error message when a git commit failed.

Bug fix

Fixed an issue whereby group names were incorrectly sanitized and uppercase letters were converted to underscores rather than lowercase ones.

Bug fix

Fixed an issue whereby Postgres was not restarted when required after CAMO configuration.

Bug fix

Fixed an issue with etcd changes, ensuring that they are now idempotent and avoiding unnecessary restarts of etcd on subsequent deployments.