Trusted Postgres Architect 23.32 release notes

Trusted Postgres Architect 23.32 release notes#

Released: 15 May 2024

New features, enhancements, bug fixes, and other changes in Trusted Postgres Architect 23.32 include the following:

Type

Description

Enhancement

The M1 architecture now supports the following additional arguments to tpaexec configure: --location-names, --primary-location, --data-nodes-per-location, --witness-only-location, and --single-node-location. By combining these arguments, most common layouts can be specified without needing to edit config.yml.

Enhancement

TPA now installs chrony during deploy, keeping the default config upon all except on AWS where we point to Amazon Time Sync service.

Enhancement

TPA now supports RHEL 8 and 9 on IBM Power (PPC64le).

Enhancement

Added a --force option to tpaexec relink. By default, relink doesn't modify targeted files if they already exist. With --force, relink removes all existing targeted files then recreates them.

Enhancement

TPA now supports Debian 12 x86.

Enhancement

pg_failover_slots is now a recognized extension

Enhancement

The sql_profiler, edb_wait_states and query_advisor extensions are now automatically included for any pem-agent node. The list of default extensions for pem-agent nodes can be overridden by including a list of pemagent_extensions in config.yml. If this list is empty, no extensions will be automatically included.

Change

TPA can now provision Docker clusters on hosts running cgroups 2 for all systems except RHEL 7. On newer systems (RHEL 9 or Ubuntu 22.04), TPA will use cgroups 2 scopes for additional isolation between the host and the containers.

Change

Updated AWS AMI versions to the latest versions.

Bug Fix

Fixed an issue whereby deploying to Debian 10 on AWS would fail with the message The repository 'http://cdn-aws.deb.debian.org/debian buster-backports Release' does not have a Release file. The backports repository for debian 10 (buster) is no longer available on deb.debian.org but the standard AWS AMI still refers to it, so we modify /etc/apt/sources.list accordingly before attempting apt operations.

Bug Fix

Fixed an issue whereby deployment would fail on AWS when assign_public_ip:no was set.

Bug Fix

Fixed problems with various roles that caused mixed errors when trying to use custom users for barman and postgres, thereby resulting in a failed deployment.

Bug Fix

Fixed an issue whereby deployments after the initial one could fail with an error like Unrecognised host=... in primary_conninfo if the key ip_address was used to define the IP address.

Bug Fix

Fixed an error whereby tpaexec upgrade could invoke the relink script in a way which caused an error and showed an unhelpful usage message for tpaexec relink.

Bug Fix

Fixed an issue whereby a task to reload Postgres was skipped resulting in the restore_command override not being removed from postgresql.auto.conf

Bug Fix

Fixed an issue whereby TPA did not change to the source directory before attempting to compile BDR from source.

Bug Fix

Fixed an issue whereby TPA would require a valid 2ndQuadrant token even if one was not needed for the specified cluster.

Documentation

Updated the tower/AAP documentation to include instructions on creating an AAP Execution Environment.