Trusted Postgres Architect 23.38.1 release notes#
リリース日2025年6月25日
Trusted Postgres Architect 23.38.1は、次の問題を解決するバグ修正リリースです。
バグ修正#
Description |
Addresses |
|---|---|
ベアプラットフォームを使用するPGD6のconfigureコマンドの問題を修正しました。 PGD6の新しくリリースされたアーキテクチャPGD-SおよびPGD-Xでのtpaexecconfigureコマンドのバグを修正しました。`--platform bare`を使用してクラスターを生成しようとすると、不明なプラットフォームエラーが発生します。この修正により、configureコマンドはベアプラットフォームのPGD6構成ファイルを正常に生成します。 |
49673 |
pgpass_usersが.pgpassファイルに正しく追加されない問題を修正しました。以前は、 generate_password: true`で指定され、 `pgpass_users`リストに含まれる`postgres_users`リスト内のユーザーは、初期展開で`~postgres/.pgpass`ファイルに追加されません。これは、 pgpassタスクが実行されたときにユーザーのパスワードがまだ存在せず、したがって、ユーザーがスキップされたためです。これは、すべてのPostgresユーザーが作成された後、pgpassタスクを再度呼び出すことにより修正されます。 `repmgr`および`replication`ユーザーは、以前は`default_pgpass_users`リストに含まれていました。これらは`pgpass_users`に追加され、使用中のレプリケーションマネージャーの必要に応じて.pgpassファイルに追加されます。 `postgres_user デフォルトでは`postgres`または`enterprisedb` は、`default_pgpass_users`リストの一部です。これが`postgres_user`を含まない`config.yml`の`pgpass_users`リストによってオーバーライドされる場合、PEM対応クラスターは、暗号化された`postgres_user`パスワードを必要とするため、エージェントの登録に失敗します。これは、PEMエージェントタスクの一部として`postgres_user`を`~postgres/.pgpass`ファイルに追加することにより修正されます。 |
|
無効なcluster_vars辞書により、展開の失敗または予期しない構成が発生する問題を修正しました。以前は、無効な辞書が`config.yml`の`cluster_vars`辞書として設定されている場合他の`cluster_vars`変数を参照する`cluster_vars`変数など、TPAは空の辞書のデフォルト値にフォールバックすることによりAnsibleエラーを飲み込んでいた。これにより、すべての`cluster_vars`変数が未定義になるため、それぞれがTPAデフォルト値に設定されました。結果のクラスターは、ユーザーが`config.yml`ファイルで指定したものとは完全に異なります。これは、構成ファイルのロード時に`cluster_vars`ディクショナリが定義され空でないことをアサートすることにより修正されます。また、最終的な救済として、 `cluster_vars`変数がデフォルトで空の辞書に設定されなくなりました。これにより、Ansibleは`group_vars`の作成時にエラーをスローして終了できます。 |