Trusted Postgres Architect 23.43.0 release notes#
リリース日2026年3月18日
Trusted Postgres Architect 23.43.0の新機能、機能強化、バグ修正、およびその他の変更には次のものが含まれます。
ハイライト#
SLES 15 SP7のサポート
SSH構成オプションの改善
機能強化#
Description |
Addresses |
|---|---|
すべてのプラットフォームでSLES 15 SP7のサポートを追加しました。 TPAはSLES 15 SP7をサポートするようになりました、SP6からのアップグレード。このサポートは、ベアメタル、AWS、Dockerを含むすべてのプラットフォームに拡張されます。 TPAはSLES 15 SP7で展開ノードとして使用できるようになり、このService Packを実行しているターゲットノードをプロビジョニングおよび管理することもできます。更新には、新しいAMIイメージ、Dockerベースイメージ、および検証済みパッケージビルドが含まれます。</p> |
|
SSH構成を改善し、ジャンプホストをサポート。 TPAは、生成された`ssh_config`に、ansibleに必要なすべてのオプションを完全に設定するようになりました。 Ansibleは、コマンドラインにオプションを追加する代わりに、構成を使用します。構成にジャンプホストを含められるようになりました。したがって、展開時に自動的に使用されます。</p> |
|
enabled_keysでのクラスターSSHキーのインストールをスキップするタスクセレクターを追加しました。 新しいタスクセレクター`ssh-cluster-key-config`を追加しました。これにより、展開中に'Ensure individually_keys allow admin access'タスクをスキップできます。これは、 `authorized_keys`ファイルが外部で管理されている環境または読み取り専用である環境Oracle Cloud Infrastructureなどに役立ちます。</p> |
の変更#
Description |
Addresses |
|---|---|
barman-wal-restore`で--keep-compression`をサポートしました。 Barman 3.12+を使用したインストールの場合、 Barman restore_command`で非推奨の-z`フラグを`--keep-compression`に置き換えました。 TPAは、古いバージョンの非推奨フラグへの条件付きフォールバックを実装し、下位互換性を維持しながら、検出または指定されたBarmanバージョンに基づいて最新のCLI標準を採用します。</p> |
|
PEM 10.4の`pemworker`引数の順序を標準化します。 `pemworker`コマンドラインの使用法をリファクタリングして、サブコマンドたとえば `--enable-probe`を最初の引数として配置します。この更新は、任意の引数の配置をサポートしなくなったPEM 10.4 CLIの変更に対処し、TPAがPEMエージェントを正常に構成および管理し続けます。</p> |
|
Dockerプラットフォームの最近のDockerバージョンとの互換性を確認します。 Dockerの最近のバージョンは、コンテナを検査するときにトップレベルの`NetworkSettings.IPAddress`フィールドを設定しなくなりました。IPは`NetworkSettings.Networks[<name>].IPAddress`内でのみ使用できるようになりました。これにより、TPAがコンテナのIPを決定しようとしたときに、コンテナのプロビジョニングが失敗しました。 TPAは、古いDockerバージョンとの互換性についてトップレベルフィールドをチェックし、設定済みの`docker_networks`エントリーが定義されている場合はフォールバックし、それ以外の場合は、最初に使用可能なネットワークIPを使用します。</p> |
|
EFM SLES 15展開で使用されるOpenJDKバージョンの更新。 SLES 15展開のEFMで使用されるOpenJDKバージョンは、新しいバージョン バージョン11から21に更新されました。背後にある理由は、dockerイメージで使用されるSLES 15リポジトリでOpenJDKバージョンの可用性を保証することです。</p> |
|
RHEL、Debian、UbuntuでEFM依存関係のOpenJDKを更新しました。 この変更により、EFMはサポートされているディストリビューションでOpenJDKの最新バージョンを使用します。</p><ul><li>RHEL 8および9、バージョン11から21まで。</li><li>Debian 11、バージョンから11〜17.</li><li>Ubuntu 22.04および24.04、バージョン11から21.</li></ul> |
|
TPAは、rc-localのないシステムでrc-localサービスを作成するようになりました。 デフォルトでrc-localを持たないディストリビューションをサポートするために変更が導入されました。この変更には、カスタムTPA rc-localサービスの作成と、システムのブート時にそれが有効になっていることの確認が含まれています。これにより、TPAは起動時に`/etc/tpa/rc.local`を実行でき、異なるディストリビューション間でTPA起動タスクを実行する一貫した方法を提供します。</p> |
|
TPAは、PGD 4以降でのpgextendedフレーバーの使用をブロックするようになりました。 bdr_version 4以降で`postgres_flavour`が`pgextended`に設定されている場合、展開がクリアエラーで失敗するようになりました。 `pgextended`フレーバーは、 BDR 3でのみサポートされています。 PGD 4以降では、代わりに`edbpge`を使用します。</p> |
51418 |
バグ修正#
Description |
Addresses |
|---|---|
TPAは、アップグレード後にEFMのヘルスチェックを再試行するようになりました。 ビジーなシステムでは、クラスターの復旧に少し時間がかかり、1つのヘルスチェックだけでは不十分になる場合があります。この変更では、アップグレード後にefmのヘルスチェックの再試行メカニズムを導入して、アップグレードが失敗したと判断するまでにクラスターに多くの時間を与えます。</p> |
|
Debian / UbuntuでのPEMバージョンの固定の問題を修正しました。 PEMバージョンを固定するときに発生したDebian / Ubuntuシステムでの依存関係の競合を解決しました。 TPAは、 `edb-pem-cli`と`edb-pem-agent`の両方の依存関係を同じバージョンに正しく固定するようになり、バージョン要件の不一致のためにパッケージマネージャーがインストールを拒否するのを防ぎます。</p> |
|
スタンバイラグのあるビジーシステムでのEFMスイッチオーバーの失敗を修正しました。 スタンバイサーバーがプライマリサーバーから遅延している場合、ビジーシステムのアップグレードまたはメンテナンス操作中にEFMスイッチオーバー操作が失敗する可能性がある問題を修正しました。以前は、スタンバイノードがプライマリと完全に同期していない場合、TPAのスイッチオーバー前ヘルスチェックがすぐに失敗し、ノードが数秒以内に追いつく場合でも、アップグレード手順が中断されていました。 TPAは、クラスターステータスを監視し、スイッチオーバーを続行する前にすべてのノードが同期するのを待機するEFMヘルスチェックに待機および再試行メカニズムを実装するようになりました。これにより、クラスターがプロモーションにとって安全な状態にある場合にのみスイッチオーバー操作が開始されます。これにより、アクティブなワークロードを持つ実稼働システムでのアップグレードワークフロー中に一時的なレプリケーションラグが存在する分散システムでのスプリアス障害が解決されます。</p> |
|
AWSプロビジョニングは、指定されたセキュリティグループが存在することを検証するようになりました。 `config.yml`で構成された`ec2_groups`を使用してAWSクラスターをプロビジョニングする場合、TPAは、指定されたセキュリティグループが実際に存在することを明示的に検証するようになりました。以前は、存在しないセキュリティグループが指定された場合たとえば、グループ名のタイプミスのため、プロビジョニングはサイレントに続行され、代わりにVPCのデフォルトのセキュリティグループを使用してEC2インスタンスが作成されました。これにより、インスタンスに、ユーザーが気づかないうちに、誤ったまたは予期しないネットワークアクセスルールが設定される可能性があります。プロビジョニングはすぐに失敗し、問題があるリージョン、使用されたフィルタ、および問題を修正する方法に関するガイダンスを示す明確なエラーメッセージが表示されます。これにより、セキュリティの誤った構成が防止され、トラブルシューティングが簡単になります。さらに、TPAは、インターネットゲートウェイ、ルートテーブル、Elastic IPアソシエーションなどのオプションのAWSリソースを作成するときに、アクション可能なエラーメッセージを含む明示的な検証を提供し、プロビジョニング中のエラーの可視性を向上させます。</p> |