Known issues
============

このページには、TPAの現在のバージョンに影響を与える既知の問題をリストしています。既知の場合、各問題の回避策が提供されます。

Barmanユーザーは\ ``deploy`` を実行した後、データベースに接続できません TPA-1218
--------------------------------------------------------------------------------

詳細
^^^^

TPA 23.35以降を使用して、以前のバージョンのTPAで作成されたPGD/
BDRクラスターに展開すると、\ ``barman``
ユーザーのスーパーユーザー権限が取り消されます。したがって、このユーザーが\ ``postgres``
データベースに接続しようとすると、失敗します。これにより、 Barman
``check`` コマンドは障害を報告します。

回避策
^^^^^^

デプロイ後フックを使用して、スーパーユーザーに\ ``barman``
を付与します。

複数のロケーションを持つEFMクラスターにロケーション間のHBAルールがありません TPA-1247
-------------------------------------------------------------------------------------

.. _詳細-1:

詳細
^^^^

複数の場所でEFMクラスターを展開し、1つのノードで\ ``efm cluster-status``
コマンドを実行すると、\ ``FATAL: password authentication failed for user "efm"``
が、ノードと同じ場所にないすべてのノードの **Promote Status**
セクションに表示されることがわかります。コマンドが実行されました。

これは、TPAが、EFMユーザーがある場所のノードから別の場所のノードに接続するために必要なHBAルールを追加できないために発生します。

.. _回避策-1:

回避策
^^^^^^

``postgres_hba_settings`` クラスター変数を使用して、\ ``efm``
ユーザーおよび\ ``replication``
ユーザーが任意のノードから他のノードに接続できるように、ノードごとに1つのHBAルールを指定します。例

.. code:: yaml

   postgres_hba_settings:
     - hostssl all efm 192.168.57.12/32 md5
     - hostssl all efm 192.168.57.13/32 md5
     - hostssl all efm 192.168.58.11/32 md5
     - hostssl all efm 192.168.58.12/32 md5
     - hostssl all efm 192.168.58.13/32 md5

     - hostssl replication replication 192.168.57.12/32 md5
     - hostssl replication replication 192.168.57.13/32 md5
     - hostssl replication replication 192.168.58.11/32 md5
     - hostssl replication replication 192.168.58.12/32 md5
     - hostssl replication replication 192.168.58.13/32 md5

現在以外の\ ``pem_server_package_version`` が指定されている場合、Debianのようなインスタンスでのデプロイが失敗する TPA-1178
--------------------------------------------------------------------------------------------------------------------------

.. _詳細-2:

詳細
^^^^

TPAは、 ``edb-pem``
メタパッケージをインストールすることによりPEMサーバーをインストールします。
Debianに似たシステムでは、このパッケージでバージョン指定子を使用すると、パッケージマネージャーが解決できないインストールの組み合わせを試行し、次のエラーが発生する場合があります。\ ``Some packages could not be installed. This may mean that you have, requested an impossible situation...``

.. _回避策-2:

回避策
^^^^^^

PEMの最新バージョンの使用を検討します。ただし、特定のバージョンが必要な場合は、パッケージマネージャーがそれらを正しく解決できるように、必要なPEMパッケージの正確なバージョンを指定できます。

通常のようにPEMサーバーとエージェントのバージョンを指定します
次に、PEMパッケージのフルセットをインスタンス変数の下に\ ``packages``
として含めます。

.. code:: yaml

   cluster_vars:
     ...
     pem_server_package_version: 10.2.0-1.bookworm
     pem_agent_package_version: 10.2.0-1.bookworm

     ...

     instances:
     ...
     - Name: pemserver
       ...
       vars:
         packages:
           Debian:
             - edb-pem=10.2.0-1.bookworm
             - edb-pem-agent=10.2.0-1.bookworm
             - edb-pem-server=10.2.0-1.bookworm
             - edb-pem-cli=10.2.0-1.bookworm

PEM 9が必要な場合は、docsパッケージも含める必要があります。

.. code:: yaml

   cluster_vars:
     ...
     pem_server_package_version: 9.8.0-1.bookworm
     pem_agent_package_version: 9.8.0-1.bookworm

     ...

     instances:
     ...
     - Name: pemserver
       ...
       vars:
         packages:
           Debian:
             - edb-pem=9.8.0-1.bookworm
             - edb-pem-agent=9.8.0-1.bookworm
             - edb-pem-server=9.8.0-1.bookworm
             - edb-pem-cli=9.8.0-1.bookworm
             - edb-pem-docs=9.8.0-1.bookworm

TPA 23.34以前で展開されたPGDクラスターにはprimary_slot_name設定があり、bdr_init_physicalが動作しない TPA-1229
-------------------------------------------------------------------------------------------------------------

.. _詳細-3:

詳細
^^^^

TPA
23.35は、EFMで使用するレプリケーションスロット名がPGDクラスターで\ ``primary_slot_name``
として誤って設定される問題を解決しました。 TPA
23.35以降で展開されたクラスターには、この問題は発生しません。ただし、以前のバージョンで展開された既存のクラスターは、新しいTPAバージョンで展開が実行された後でも、誤った\ ``primary_slot_name``
設定を保持します。

この不正な\ ``primary_slot_name`` の影響は、
bdr_init_physicalを使用してクラスターに新しいノードを追加またはノードをリビルドしようとすると、\ ``Waiting for PostgreSQL to accept connections...``
でハングし、ログに致命的エラー\ ``replication slot ... does not exist``
が表示されることです。

.. _回避策-3:

回避策
^^^^^^

ファイル\ ``/opt/postgres/data/conf.d/8901-primary_slot_name.conf``
を削除し、Postgresをリロードすることにより、クラスター内の各Postgresノードからこの誤った設定を手動で削除できます。
TPA 23.35以降を使用している限り、復元されることはありません。
