Version 4.2ΒΆ

Enhancements, bug fixes, and other changes in EFM 4.2 include:

Type

Description

Enhancement

A new Eager Failover setup was added to move primary resources from an unmonitored and unhealthy node to a fully operational and healthy node. With this setup, a failover is exercised when the primary EFM agent is stopped. Without Eager Failover, the primary Postgres instance is left available but unmanaged.

Enhancement

The EDB Postgres High Availability and Horizontal Read Scaling Architecture is certified with PgPool-II 4.2 and is supported with non-sudo mode.

Enhancement

Promotion priority for standbys can now be defined per primary. [Support Ticket #1092697]

Enhancement

The stop-cluster command can now be disabled in EFM configuration.

Bug Fix

Standbys configured with archiving are now properly reconfigured to follow the new primary. [Support Ticket #1127627, #1182654]

Bug Fix

A new option can disable the LoadBalancer detach script when the primary EFM agent fails but Postgres is still running. [Support Ticket #1096007]

Bug Fix

Added validation in the agent startup to check if the parent directory of pg_wal/pg_xlog is writable. The parent directory needs to be writable so EFM can create a backup of it and later restore it. If the new validation fails, an error is logged and the agent refuses to start.

See The Cluster Properties File for more information on the new properties.