Notifications¶
</ div>
フェールオーバーマネージャーは、クラスターに影響する重要なイベントが発生すると、メール通知を送信し、通知スクリプトを呼び出します。メール通知を送信するようにフェールオーバーマネージャーを構成した場合は、クラスターの各ノードのポート25で実行されているSMTPサーバーが必要です。次のパラメーターを使用して、フェールオーバーマネージャーの通知動作を構成します。
user.email
script.notification
from.email
構成プロパティの編集の詳細については、Specifying cluster propertiesを参照してください。
通知の本文には、通知をトリガーしたイベントとクラスターの現在の状態に関する詳細が含まれます。例:
EFM node: 10.0.1.11
Cluster name: acctg
Database name: postgres
VIP: ip_address (Active|Inactive)
Database health is not being monitored.
ノードに実装されている場合、VIPフィールドには仮想IPのIPアドレスと状態が表示されます。
フェールオーバーマネージャーは、各通知に重大度レベルを割り当てます。次のレベルは、必要な注意のレベルが高まることを示しています。
INFOは、エージェントに関する情報メッセージを示しており、マニュアル介入は必要ありません(例、フェールオーバーマネージャーの起動または停止)。 List of INFO level notificationsを参照WARNINGは、管理者がシステムをチェックする必要があるイベントが発生したことを示します(例、フェイルオーバーが発生した)。 List of WARNING level notificationsを参照SEVEREは、重大なイベントが発生し、管理者の即時の注意が必要であることを示します(例、フェイルオーバーが試行されましたが完了できません)。 List of SEVERE level notificationsを参照
重大度レベルは、通知の緊急度を指定します。重大度レベルがSEVEREの通知はすぐにユーザの注意を必要としますが、重大度レベルがINFOの通知はユーザのアクションを必要としないクラスターに関する操作情報に注意を喚起します。通知の重大度レベルはロギングレベルとは関係ありません。構成ファイルで指定されたログレベルの詳細に関係なく、すべての通知が送信されます。
`notification.level <04_configuring_efm/01_cluster_properties/#notification_level>`__プロパティを使用して、通知をトリガーする最小の重大度レベルを指定できます。
!!! Note *
管理用メールアドレスへの通知の送信に加えて、すべての通知はエージェントログファイル(/var/log/efm-4.<x>/<*cluster name*>.log)に記録されます。
この表にリストされている条件はINFOレベル通知を引き起こします:
</ div>
Subject |
Description |
|---|---|
Executed fencing script |
実行されたフェンシングスクリプト* script_name 結果: script_results * |
Executed post-promotion script |
実行されたプロモーション後のスクリプト* script_name 結果: script_results * |
Executed remote pre-promotion script |
実行されたリモート事前プロモーションスクリプト* script_name 結果: script_results * |
Executed remote post-promotion script |
実行されたリモートプロモーション後スクリプト* script_name 結果: script_results * |
Executed post-database failure script |
実行されたデータベース障害後のスクリプト* script_name 結果: script_results * |
Executed primary isolation script |
実行されたプライマリ分離スクリプト* script_name 結果: script_results * |
Witness agent running on node_address for cluster cluster_name |
監視エージェントが実行されています。 |
Primary agent running on node_address for cluster cluster_name |
プライマリエージェントが実行されており、データベースの状態が監視されています。 |
Standby agent running on node_address for cluster cluster_name |
スタンバイエージェントが実行されており、データベースの状態が監視されています。 |
Idle agent running on node node_address for cluster cluster_name |
アイドル状態のエージェントが実行されています。ローカルデータベースを起動した後、エージェントを再開できます。 |
Assigning VIP to node node_address |
VIP * VIP_address をノード node_address に割り当てます結果: script_results * |
Releasing VIP from node node_address |
ノード* node_address からVIP * VIP_address *を解放する結果: script_results * |
Starting auto resume check for cluster cluster_name |
このノードのエージェントは、* auto.resume.period *秒ごとにチェックして、障害が発生したデータベースのモニタリングを再開できるかどうかを確認します。この間にクラスターを確認し、データベースが再度起動されない場合はエージェントを停止します。詳細については、エージェントログを参照してください。 |
Executed agent resumed script |
実行されたエージェントはスクリプトを再開しましたscript_name結果:script_results |
WAL logs backed up during promotion |
新しいプライマリに従うようにこのスタンバイを再構成すると、pg_xlogまたはpg_walの内容がpgdataディレクトリにバックアップされました。ディスクスペースをフリーするのに都合がよい場合は、このバックアップを削除してください。 |
以下のこの表にリストされている条件は、警告レベルの通知をトリガーします。
</ div>
Subject |
Description |
Notes |
|---|---|---|
Witness agent exited on node_address for cluster cluster_name |
監視エージェントが終了しました。 |
|
Primary agent exited on node_address for cluster cluster_name |
データベースの状態は監視されていません。 |
|
Cluster cluster_name notified that primary agent has left |
プライマリエージェントが再起動されるまで、クラスタのフェールオーバーは無効になります。 |
|
Standby agent exited on node_address for cluster cluster_name |
データベースの状態は監視されていません。 |
|
Agent exited during promotion on node_address for cluster cluster name |
データベースの状態は監視されていません。 |
|
Agent exited on node_address for cluster cluster name |
エージェントが終了しました。これは、アイドル状態のエージェントによって生成されます。 |
|
Agent exited for cluster cluster name |
エージェントが終了しました。この通知は通常、スタートアップ中にエージェントがスタートアップが完了する前に終了したときに生成されます。 |
|
Virtual IP address assigned to non-primary node |
仮想IPアドレスが非プライマリノードに割り当てられているようです。競合を回避するために、FailoverManagerはVIPをリリースします。 VIPがプライマリノードに割り当てられていることを確認し、割り当てられていない場合は手動でアドレスを再割り当てします。 |
|
Virtual IP address not assigned to primary node. |
仮想IPアドレスがプライマリノードに割り当てられていないようです。フェールオーバーマネージャーはVIPの再取得を試みます。 |
|
No standby agent in cluster for cluster cluster name |
|
|
Standby agent failed for cluster cluster name |
|
|
Standby database failed for cluster cluster name |
スタンバイエージェントは、データベースに障害が発生したことを通知しました。他のノードもスタンバイデータベースに到達できません。 |
|
Standby agent cannot reach database for cluster cluster name |
スタンバイエージェントはデータベース障害を通知しましたが、他のノードはスタンバイデータベースがまだ実行中であることを検出しました。 |
|
Cluster cluster name has dropped below three nodes |
完全なフェイルオーバー保護には、少なくとも3つのノードが必要です。監視ノードまたはエージェントノードをクラスターに追加します。 |
|
Subset of cluster cluster name disconnected from primary |
このノードは、クラスター*クラスター名前*の大部分に接続されなくなりました。このノードはクラスターのサブセットのパートであるため、フェイルオーバーは試行されません。可視されている現在のノードは次のとおりです:* node_address *。 |
|
Promotion has started on cluster cluster name. |
スタンバイの昇格がクラスター* cluster_name *で開始されました。 |
|
Witness failure for cluster cluster_name |
|
|
Idle agent failure for cluster cluster_name. |
|
|
One or more nodes isolated from network for cluster cluster_name |
このノードはネットワークから分離されているようです。クラスターに表示される他のメンバーは次のとおりです。node_name |
|
Node no longer isolated from network for cluster cluster_name. |
このノードはネットワークから分離されなくなりました。 |
|
|
Failover Managerはプロモーション手順を開始しましたが、プライマリDBがまだ*アドレス*で実行されていることを検出しました。これは通常、プライマリFailover Managerエージェントが終了したことを示します。フェイルオーバーは発生していません。プライマリエージェントが再起動されるまで、フェイルオーバー保護はありません。 |
|
Primary agent missing for cluster cluster_name |
プライマリエージェントは以前にクラスターを離れました。プライマリエージェントがクラスターに参加するまで、フェイルオーバー保護はありません。 |
Available in Failover Manager 4.2 and later. |
|
スタンバイFailover Managerエージェントは自分自身のプロモートを開始しましたが、プライマリエージェントがクラスターに再参加していることがわかりました。フェイルオーバーは発生していません。 |
|
|
スタンバイFailover Managerエージェントは自分自身をプロモートしようとしましたが、プライマリDBが* node_address *でまだ実行されているかどうかを検出できませんでした。フェイルオーバーは発生していません。 |
Description applicable for Failover Manager 4.2 and later. |
|
スタンバイFailover Managerエージェントは自分自身をプロモートしようとしましたが、プライマリDBがまだ* node_address *で実行されていることを検出しました。これは通常、プライマリFailover Managerエージェントが終了したことを示します。フェイルオーバーは発生していません。 |
Description applicable for Failover Manager 4.1 and earlier. |
|
スタンバイFailover Managerエージェントは自分自身をプロモートさせようとしましたが、仮想IPアドレス(VIP_address)がまだ別のノードに割り当てられているように見えるため、昇格できませんでした。このような状況でプロモートすると、データが破損する可能性があります。フェイルオーバーは発生していません。 |
|
|
スタンバイFailover Managerエージェントは自分自身をプロモートしようとしましたが、既知のサーバー(server_address)に到達できなかったため、プロモートできませんでした。これは通常、スタンバイエージェントを他のエージェントから分離したネットワークの問題を示しています。フェイルオーバーは発生していません。 |
|
Potential manual failover required on cluster cluster_name. |
クラスタ* cluster_name *で潜在的なフェイルオーバーシチュエーションが検出されました。このクラスターでは自動フェイルオーバーが無効になっているため、マニュアル介入が必要です。 |
|
Failover has completed on cluster cluster_name |
クラスタ* cluster_name *でフェイルオーバーが完了しました。 |
|
Lock file for cluster cluster_name has been removed |
クラスタ* cluster_name のロックファイルは、ノード node_address *のpath_nameから削除されました。このロックは、マルチプルのエージェントが同じノード上の同じクラスターをモニタリングするのを防ぎます。クラスタの別のエージェントを誤って起動しないように、このファイルを復元してください。 |
|
A recovery file for cluster cluster_name has been found on primary node |
クラスター* cluster_name * hwasのリカバリファイルは、プライマリノード* node_address *のpath_nameにあります。このノードでDBをリスタートしようとすると、問題が発生する可能性があります。 |
|
recovery_target_timeline is not set to latest in recovery settings |
リカバリ設定でrecovery_target_timelineパラメータがlatestに設定されていません。スタンバイサーバは、新しいプライマリが昇格されたときに発生するタイムラインの変更に従うことができません。 |
|
Promotion has not occurred for cluster cluster_name |
昇格が試行されましたが、昇格されているノードip_addressがすでに存在します。 |
|
Standby will not be reconfigured after failover in cluster cluster_name |
このノードの 'auto.reconfigure'プロパティはfalseに設定されているため、昇格後に新しいプライマリノードに従うように再構成されません。 |
Subject and Description applicable to Failover Manager 4.2 and later. |
Standby not reconfigured after failover in cluster cluster_name |
このノードの`auto.reconfigure`プロパティはfalseに設定されました。フェイルオーバー後に新しいプライマリノードに従うようにノードが再構成されていません。 |
Subject and Description applicable to Failover Manager 4.1 and earlier. |
Could not resume replay for standby standby_id. |
スタンバイのリプレイを再開できませんでした。手動による介入が必要になる場合があります。エラー:error_message。 |
|
Possible problem with database timeout values |
`remote.timeout`の値(value)が`local.timeout`の値(value)よりも高くなっています。ローカルデータベースの応答に時間がかかりすぎる場合、他のエージェントは接続できますが、ローカルエージェントはデータベースに障害が発生したと見なす場合があります。これによってフェイルオーバーが発生することはありませんが、ローカルエージェントがモニタリングを停止し、フェイルオーバー保護が失われる可能性があります。 |
|
No standbys available for promotion in cluster cluster_name |
クラスター内の現在のスタンバイノードの数は、最小数:numberに減少しました。別のスタンバイノードを追加するか、昇格可能にしない限り、フェイルオーバーは発生しません。 |
|
No promotable standby for cluster cluster_name |
クラスタ内の現在のフェイルオーバー優先度リストは空です。クラスタ* cluster_name *の唯一の昇格可能なスタンバイを削除しました。別の昇格可能なスタンバイノードを追加するか、フェイルオーバー優先度リストに追加して昇格しない限り、フェイルオーバーは発生しません。 |
|
Synchronous replication has been reconfigured for cluster cluster_name |
クラスター内の同期的スタンバイノードの数が数を下回りました。プライマリの同期的スタンバイ名は、新しいsynchronous_standby_names値に再構成されました。 |
|
Synchronous replication has been disabled for cluster cluster_name. |
クラスター内の同期的スタンバイノードの数がカウントを下回りました。プライマリは同期レプリケーションモードから外されました。 |
|
Could not reload database configuration. |
データベース構成をリロードできませんでした。手動による介入が必要です。エラー:error_message。 |
|
Custom monitor timeout for cluster cluster_name |
次のカスタムモニタリングスクリプトがタイムアウトしました:script_name |
|
Custom monitor 'safe mode' failure for cluster cluster_name |
次のカスタムモニタスクリプトは失敗しましたが、*モード*で実行されています:script_name。出力:script_results |
|
primary.shutdown.as.failure set to true for primary node |
プライマリ。このクラスターのシャットダウン.as.failureプロパティはtrueに設定されています。クラスタ全体を停止せずにプライマリエージェントを停止すると、クラスタの残りの部分によって、即時のプライマリエージェント障害として扱われます。プライマリデータベースのメンテナンスが必要な場合は、プライマリエージェントをシャットダウンし、フェイルオーバーが発生しないという残りのノードからの通知を待ちます。 |
|
Primary_or_Standby cannot ping local database for cluster cluster_name |
Primary_or_Standbyエージェントは、* node_address *で実行されているローカルデータベースに到達できなくなりました。他のノードはデータベースにリモートでアクセスできるため、エージェントはIDLEになり、データベースのモニタリングを再開しようとします。 |
Subject and Description applicable to Failover Manager 4.1 and later. |
PPrimary cannot ping local database for cluster cluster_name |
プライマリエージェントは、node_addressで実行されているローカルデータベースに到達できなくなります。他のノードはデータベースにリモートでアクセスできるため、プライマリはIDLEになり、データベースのモニタリングを再開しようとします。 |
Subject and Description applicable to Failover Manager 4.0. |
Standby cannot resume monitoring local database for cluster cluster_name |
スタンバイエージェントは、* node_address *で実行されているローカルデータベースに到達できなくなります。他のノードはデータベースにリモートでアクセスできます。スタンバイエージェントは、`resume`コマンドを実行してデータベースのモニタリングを再開するまでIDLEのままです。 |
Available in Failover Manager 4.1 and later. |
Primary agent left the cluster and node detached from load balancer |
スタンバイエージェントは、* node_address *で実行されているローカルデータベースに到達できなくなります。他のノードはデータベースにリモートでアクセスできます。スタンバイエージェントは、`resume`コマンドを実行してデータベースのモニタリングを再開するまでIDLEのままです。 |
Available in Failover Manager 4.2 and later. |
Standby database in cluster cluster_name not stopped before primary is promoted |
このエージェントには`standby.restart.delay`プロパティが設定されているため、プロモーションが完了してからnum_seconds秒後まで、新しいプライマリに従うように再構成されません。場合によっては、マニュアルの介入なしに新しいプライマリを追跡できない場合があります。 |
Available in Failover Manager 4.2 and later. |
</ div>
この表にリストされている条件は重大な通知を引き起こします:
Subject |
Description |
Notes |
|---|---|---|
Standby database restarted but Failover Manager cannot connect |
データベースのスタートまたはリスタートコマンドは正常に実行されましたが、データベースは接続を受け入れていません。 Failover Managerは、.connectionをリスタートするまで接続を試み続けます。タイムアウト秒。 |
|
Unable to connect to DB on node_address |
最大接続制限に達しました。 |
|
Unable to connect to DB on node_address |
dbのパスワードが無効です。 ユーザ= user_name。 |
|
Unable to connect to DB on node_address |
権限指定が無効です。 |
|
Primary cannot resume monitoring local database for cluster cluster_name |
プライマリエージェントは、* node_address *で実行されているローカルデータベースに到達できなくなります。他のノードはデータベースにリモートでアクセスできるため、プライマリはVIPをリリースしたり、`recovery.conf`ファイルを作成したりしません。プライマリエージェントは、`resume`コマンドを実行してデータベースのモニタリングを再開するまでIDLEのままです。 |
|
Fencing script error |
フェンシングスクリプトscript_nameは正常に実行できませんでした。終了値:exit_code結果:script_resultsフェイルオーバーは発生していません。 |
|
Post-promotion script failed |
プロモーション後のスクリプトscript_nameを正常に実行できませんでした。終了値:exit_code結果:script_results |
|
Remote post-promotion script failed |
リモートのプロモーション後スクリプトscript_nameを正常に実行できませんでした終了値:exit_code結果:script_resultsNode:* node_address * |
|
Remote pre-promotion script failed |
リモート事前プロモーションスクリプトscript_nameは正常に実行できませんでした終了値:exit_code結果:script_resultsNode:* node_address * |
|
Post-database failure script error |
データベース障害後のスクリプトscript_nameは正常に実行できませんでした。終了値:exit_code結果:script_results |
|
Agent resumed script error |
エージェントが再開したスクリプトscript_nameは正常に実行できませんでした。結果:script_results |
|
Primary isolation script failed |
一次分離スクリプトscript_nameは正常に実行できませんでした。終了値:exit_code結果:script_results |
|
Could not promote standby |
ノードでプロモートコマンドが失敗しました。スタンバイをプロモートできませんでした。エラーの詳細:error_details |
|
Error creating recovery.conf file on node_address for cluster cluster_name |
プロモーション中にプライマリノード* node_address *にリカバリ.confファイルを作成中にエラーが発生しました。プロモーションは継続されてい保証が、古いプライマリノードを再起動できないようにマニュアルで介入する必要があります。エラーの詳細:message_details |
|
An unexpected error has occurred for cluster cluster_name |
このノードで予期しないエラーが発生しました。詳細については、エージェントログを確認してください。エラー:error_details |
|
Primary database being fenced off for cluster cluster_name |
プライマリデータベースは、クラスターの大部分から分離されています。クラスターは、ip_addressのプライマリエージェントに、フェイルオーバーマネージャクラスターの残りの部分がスタンバイをプロモートするときに2つのプライマリを防ぐために、プライマリデータベースをフェンスオフするように指示しています。 |
|
Isolated primary database shutdown. |
分離されたプライマリデータベースは、フェイルオーバーマネージャによってシャットダウンされました。 |
|
Primary database being fenced off for cluster cluster_name |
プライマリデータベースは、クラスターの大部分から分離されました。プライマリが分離の検出を完了する前に、スタンバイが昇格され、クラスター内のこのノードに再参加しました。このノードは、複数のプライマリデータベースを回避するために自分自身を分離しています。 |
|
Could not assign VIP to node node_address |
フェイルオーバーマネージャは、何らかの理由でVIPアドレスを割り当てることができませんでした。 |
|
primary_or_standby database failure for cluster cluster_name |
指定されたノードでデータベースに障害が発生しました。 |
|
Agent is timing out for cluster cluster_name |
このエージェントは、ローカルデータベースにアクセスしようとしてタイムアウトしました。タイムアウト後、エージェントはデータベースに正常にpingを実行し、モニタリングを再開しました。ただし、データベースまたはエージェントの障害を防ぐために、ノードをチェックして正常に実行されていることを確認してください。 |
|
Resume timed out for cluster cluster_name |
このエージェントは、ローカルデータベースを再構成して再起動した後、モニタリングを再開できませんでした。詳細については、エージェントログを参照してください。 |
|
Internal state mismatch for cluster cluster_name |
Failover Managerクラスターの内部状態が、クラスターメンバーの実際の状態とマッチしませんでした。これはまれであり、ノードがクラスターに参加したり、ノードの状態を変更したりするタイミングの問題が原因である可能性があります。問題は解決する必要がありますが、クラスターのステータスも確認して確認してください。不一致の詳細は、エージェントログファイルに記載されています。 |
|
Failover has not occurred |
エージェントは、プライマリデータベースがクラスター* cluster_name *で使用できなくなったことを検出しましたが、フェイルオーバーに使用できるスタンバイノードがありません。 |
|
Failover has not occurred |
エージェントは、プライマリデータベースがクラスター* cluster_name *で使用できなくなったことを検出しましたが、フェイルオーバーに使用できるスタンバイノードが十分にありません。 |
|
Database in wrong state on node_address |
スタンバイエージェントは、ローカルデータベースがリカバリ中でなくなったことを検出しました。エージェントはIDLEになります。手動による介入が必要です。 |
|
Database in wrong state on node_address |
プライマリエージェントは、ローカルデータベースがリカバリ中であることを検出しました。エージェントはIDLEになります。手動による介入が必要です。 |
|
Database connection failure for cluster cluster_name |
このノードは、* node_address *で実行されているデータベースに接続できません。これが修正されるまで、このノードはデータベースが実行されているかどうかを確認できないため、フェイルオーバーが正しく機能しない可能性があります。 |
|
Standby custom monitor failure for cluster cluster_name |
次のカスタムモニタスクリプトは、スタンバイノードで失敗しました。エージェントはローカルデータベースのモニタリングを停止します。スクリプトの場所:script_nameスクリプト出力:script_results |
|
Primary custom monitor failure for cluster cluster_name |
次のカスタムモニタスクリプトは、プライマリノードで失敗しました。フェールオーバーマネージャーはスタンバイのプロモートを試みます。スクリプトの場所:script_nameスクリプト出力:script_results |
|
Loopback address set for ping.server.ip |
ループバックアドレスはピングプロパティに設定されます。この設定はネットワーク分離の検出に干渉する可能性があるため、変更する必要があります。 |
|
Load balancer attach script error |
ロードバランサー接続スクリプトscript_nameを正常に実行できませんでした。終了値:exit_code結果:script_results |
|
Load balancer detach script error |
ロードバランサーのデタッチスクリプトscript_nameを正常に実行できませんでした。終了値:exit_code結果:script_results |
|
Pgpool attach node error |
フェールオーバーマネージャーはpgpoolノードの接続に失敗しました。終了値:exit_code。結果:script_results |
Available in Failover Manager 4.1 and later. |
Pgpool detach node error |
フェールオーバーマネージャーは、pgpoolノードのデタッチに失敗しました。終了値:exit_code。結果:script_results |
|
Not enough synchronous standbys available in cluster cluster_name |
クラスター内の同期的スタンバイノードの数がカウントダウンしました。プライマリでのすべての書き込みクエリは、十分な同期的スタンバイノードが追加されるまでブロックされます。 |