Release notes for EDB Postgres Distributed version 4.2.0

EDB Postgres Distributedバージョン4.2.0はEDB Postgres Distributed 4のマイナーリリースであり、以前のバージョンで特定された問題の修正と新機能が含まれています。

Component

Version

Type

Description

BDR

4.2.0

Enhancement

予約されたgallocシーケンススロットの消費を許可します(BDR-2367、RT83437、RT68255)<p>バックグラウンドアロケーターによる将来の使用のために予約されたgallocシーケンススロットは、コンセンサス障害の存在下で消費できます。 </p>

BDR

4.2.0

Bug fix

アイドル接続での誤ったpglogicalレシーバータイムアウトを修正しました(RT82315) <p> レプリケートして適用するものが何もない場合、pglogicalレシーバーは状態をタイムアウトと誤って解釈し、「ERROR: 08006: termination pglogical receiver due to timeout」で終了する場合があります。この誤解を修正します。 </p>

BDR

4.2.0

Bug fix

スーパーユーザー以外の信頼できる拡張機能の「不十分な特権」エラーを修正しました(BDR-2350)<p> PostgreSQL 13以降で非スーパーユーザーによって実行されるCREATE EXTENSIONコマンドは、実行されたBDRノードでは成功する場合がありますが、複製に失敗しますレプリケーションを壊す他のノードに。このようなコマンドを非オリジンノードに適用できるようにして、これを修正します。</p>

BDR

4.2.0

Bug fix

パラレル適用が有効になっている場合、再起動時にglobal_locksを再構築するときの競合状態を回避する(RT83435、 BDR-2383)<p>これが発生するBDRノードは回復不能になります。単一のライタにすべてのグローバルロックを回復させることにより、これを修正します。 </p>

BDR

4.2.0

Bug fix

競合がbdr.conflict_historyに記録されるときのスプリアスセグメンテーションフォールトを修正しました(BDR-2403、 ライタプロセス 、RT83928)<p>使用されているポインター。この使用法を修正します。 </p>

BDR

4.2.0

Bug fix

bdr_init_physicalが失敗したときにレプリケーションスロットをクリーンアップする(BDR-2364、RT74789)<p> bdr_init_physicalがノードに参加できないまま中止すると、非アクティブなレプリケーションスロットが残ります。不規則な終了の前に非アクティブになっているときに、このようなレプリケーションスロットを削除します。 </p>

HARP

2.2.0

Enhancement

処理フックを含む、接続文字列にsslpasswordのサポートを追加する (HNG-626)