Error codes

Migration Toolkitで問題が発生すると、エラーコードとメッセージのフォームで通知が発行されます。

各エラーコードは、プレフィックスMTK-で始まり、その後に5桁が続きます。最初の2桁は、エラーの一般的な分類であるエラークラスを示します。最後の3桁は特定のエラー状態を表します。

次の表にエラークラスを示します。

Error Class

Description

00

正常に完了

01

情報

02

警告

03

一般的なdrror

0x

予約済み

10

無効なユーザ入力

11

構成エラー

12

不十分な特権

13

サポートされていない機能

14

不足しているオブジェクト

15

スキーマの移行

16

手続き型言語の移行

17

データのローディング

NA

特定のデータベースサーバからエラーが報告された場合、このエラーメッセージの先頭にはDB-が付きます。例、 Postgresデータベースサーバの既存のテーブルが原因でテーブルの作成が失敗した場合、エラーコード42P07がデータベースサーバによって返されます。 Migration Toolkitログの特定のエラーは、DB-42P07として表示されます。

エラーコードの概要

次の表では、列エラーコードにMigration Toolkitエラーコードがリストされています。 ** Message and resolution **列には、エラーコードとともに表示されるメッセージが含まれます。メッセージには、エラーの原因とその解決方法が説明されています。

** Message and resolution **列の$NAMEは、ランタイムに適切な値に置き換えられる情報のプレースホルダです。

クラス02-警告

このクラスはワーニングメッセージを表します。

Error code

Message and resolution

MTK-02000

All the warnings that relate to this class and don't have a specific error code binding use this error code.

MTK-02001

Run 'runMTK -help' to see the usage details.

MTK-02002

Warning! The offline migration path $OFFLINE_PATH does not exist, the scripts will be created under the user home folder.

クラス10-無効なユーザ入力

このクラスは、無効なユーザ入力値を表します。

クラス11-構成の問題

このクラスは、toolkit.propertiesファイルまたはMigration Toolkitで使用される他の構成ファイルの無効な構成設定を表します。

Error code

Message and resolution

MTK-11000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-11001

The properties file containing table filter clause cannot be loaded.

MTK-11002

The custom type mapping file couldn't be loaded. Reason: $REASON.

MTK-11003

The custom type mapping file contains an invalid mapping entry.

MTK-11004

The custom type mapping file doesn't contain any mapping entry.

MTK-11005

Connectivity information for source database is not available.

MTK-11006

Connectivity information for target database is not available.

MTK-11007

Unable to create the logs directory. $PATH.

MTK-11008

The properties file containing table columns filter list cannot be loaded.

MTK-11009

Error Connecting Database $DATABASE.

MTK-11010

Error loading $DBLINKORA_FILE file.

MTK-11011

Error while loading DBLink Ora module. $DBLINKORA_MODULE. Verify that dblink_ora is installed/configured on target EnterpriseDB server. Please see the Database Compatibility for Oracle Developer's Guide for more information about installing and configuring the dblink_ora module.

MTK-11012

Error while loading given DBLink_Ora module. $DBLINKORA_MODULE. Verify that dblink_ora is installed/configured on target EnterpriseDB server. Please see the Database Compatibility for Oracle Developer's Guide for more information about installing and configuring the dblink_ora module.

MTK-11013

Could not load DBLinkOra Module.

MTK-11014

Error connecting to DBLinkOra.

MTK-11015

The connection credentials file $TOOLKIT_PROP_FILE is not secure and accessible to group/others users. This file contains plain passwords and should be restricted to Migration Toolkit owner user only.

MTK-11016

Data loader task failed to initialize. Reason: $REASON

クラス12-不十分な特権

このクラスは、データベースユーザ/ロール情報をローディングするための不十分権限エラーを表します。

Error code

Message and resolution

MTK-12000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-12001

The user/role migration failed due to insufficient privileges. Grant the user SELECT privilege on the following Oracle catalogs: DBA_ROLES, DBA_USERS, DBA_TAB_PRIVS, DBA_PROFILES, DBA_ROLE_PRIVS, ROLE_ROLE_PRIVS, DBA_SYS_PRIVS.

MTK-12002

The migration of privileges failed due to insufficient privileges. Grant the user SELECT privilege on the following Oracle catalog: dba_tab_privs.

クラス13-サポートされていない機能

このクラスは、サポートされていないオブジェクトおよび句の移行に関連するエラーを表します。ターゲットデータベースが指定されたオブジェクトを実装していないか、 Migration Toolkitがその移行をハンドルしていません。

Error code

Message and resolution

MTK-13000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-13001

Skipping index as Oracle does not allow multiple indexes against same column list.

MTK-13002

For $DATABASE views migration is not supported.

MTK-13003

For $DATABASE roles migration is not supported.

MTK-13004

You cannot migrate triggers, sequences, procedures, functions, packages and synonyms for MySQL, SQL Server, and Sybase databases.

MTK-13005

You cannot migrate sequences and packages for SQL Server database.

MTK-13006

Given trigger is not migrated, the trigger is owned by a different user schema and cross-schema triggers are not supported by EnterpriseDB.

MTK-13007

The given trigger is not migrated, the trigger has WHEN clause which is not supported by EnterpriseDB.

MTK-13008

Skipping Database Link $DATABASE_LINK. EnterpriseDB currently does not support this type of Database Link.

MTK-13009

Warning! Skipping migration of trigger $TRIGGER, currently non-table triggers are not supported in target database.

MTK-13010

You cannot migrate procedures, packages, synonyms and database links to PostgreSQL database.

MTK-13011

Domain objects are not supported in target database.

MTK-13012

Rules are not supported in $DATABASE database.

MTK-13013

The database type is not supported.

MTK-13015

$TYPE is Not Supported by COPY.

MTK-13016

The migration to PostgreSQL is supported only when Oracle or PostgreSQL is the source database.

MTK-13017

Groups are not supported in $DATABASE database.

MTK-13018

Profile migration is not supported in $SRC_DB to $TARGET_DB permutation.

MTK-13019

Cannot migrate unknown Profile $PROFILE.

MTK-13020

Profiles cannot be migrated to database version $VERSION.

MTK-13021

Password Profile verify function $MY_VERIFICATION_FUNCTION must be explicitly migrated.

MTK-13022

Advanced Queues migration is not supported from $SRC_DB database to $TARGET_DB database.

MTK-13023

Advanced Queues cannot be migrated to database version $VERSION.

MTK-13024

The INTERVAL partition is not supported in $DATABASE, the table will be migrated without INTERVAL definition.

MTK-13025

Warning! User profile migration is not supported in target database version $VERSION. The profile $PROFILE for user $USER will be skipped.

MTK-13026

Object Type migration is not supported from $SRC_DB to $TARGET_DB.

MTK-13027

Migration is not supported from $DATABASE database for PDB Admin schemas/users with PDB_DBA role.

クラス14-欠落オブジェクト

このクラスは、ソースデータベース内のメタデータ情報の検索の失敗を表します。

Error code

Message and resolution

MTK-14000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-14001

One or more tables are missing from the source $DATABASE database.

MTK-14002

One or more tables couldn't be found in the source $DATABASE database. With -tables mode, the table name should be in uppercase unless it is case-sensitive.

MTK-14003

One or more users couldn't be found in the source $DATABASE database. With -users mode, the user name should be in uppercase unless it is case-sensitive.

クラス15-スキーマの移行

このクラスは、テーブル、コンストレイン、インデックス、同義語、ビュー、ユーザー、ロールなどの非手続き型データベースオブジェクトに関連する移行の問題を表します。

Error code

Message and resolution

MTK-15000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-15001

Error creating constraint $CONSTRAINT.

MTK-15002

Error creating role $ROLE.

MTK-15003

Error granting given privilege $PRIVILEGE on $OBJECT to $USER.

MTK-15004

Error granting $ROLE to $USER.

MTK-15005

Error granting privilege $REASON.

MTK-15006

Error creating user $USER.

MTK-15007

Error creating index $INDEX.

MTK-15008

Error creating view $VIEW.

MTK-15009

Error creating materialized view $MVIEW.

MTK-15010

Error creating public synonym $SYNONYM.

MTK-15011

Error creating private synonym $SYNONYM.

MTK-15012

Error creating sequence $SEQUENCE.

MTK-15013

Error creating table $TABLE.

MTK-15014

Error creating database link $DATABASE_LINK.

MTK-15015

Error creating given object type $OBJECT_TYPE.

MTK-15016

The table $TABLE could not be created in $DATABASE database.

MTK-15017

The linked schema $LINKED_SCHEMA doesn't exist in the target database. Create the schema and then retry.

MTK-15018

Error creating domain $DOMAIN.

MTK-15019

Error creating custom data type $DATA_TYPE.

MTK-15020

Error creating membership for group $GROUP.

MTK-15021

Table name $TABLE does not have a schema qualifier. With multiple schema migration context, each table should be schema qualified.

MTK-15022

Schema qualifier $SCHEMA does not match the schema list.

MTK-15023

The table metadata information is not available.

MTK-15024

Tables list is not initialized yet.

MTK-15025

Error while getting database metadata information.

MTK-15026

Error creating group $GROUP.

MTK-15027

Error creating Profile $PROFILE.

クラス16-手続き言語の移行

このクラスは、プロシージャ、関数、パッケージソフト、匿名ブロック、トリガー、ルールなどの手続き言語に基づくデータベースオブジェクトに関連する移行の問題を表します。

Error code

Message and resolution

MTK-16000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-16001

Error Creating Trigger $TRIGGER.

MTK-16002

Error Creating Rule $RULE.

MTK-16003

Error Creating Package Spec $PACKAGE.

MTK-16004

Error Creating Package Body $PACKAGE.

MTK-16005

Package Body is invalid, skipping... Note: This error message also appears when a package specification is successfully migrated, but there is no corresponding package body in the source database. In this case, the package specification should function properly in the target database despite the appearance of the error message.

MTK-16006

Error Creating Procedure $PROCEDURE.

MTK-16007

Error Creating Function $FUNCTION.

MTK-16008

Error Creating Anonymous Block $BLOCK.

MTK-16009

Error creating Queue $QUEUE.

クラス17-データのローディング

このクラスは、ソースからターゲットデータベースにデータをコピーするときに発生する可能性のあるエラーを表します。

Error code

Message and resolution

MTK-17000

All the errors that relate to this class and don't have a specific error code binding use this error code.

MTK-17001

Error Loading Data into Table: $TABLE

MTK-17002

Encoding Conversion encountered some characters that will be loaded using Bulk Inserts instead.

MTK-17003

Error in copy tables $REASON.

MTK-17004

Invalid DataType.

MTK-17005

This Table Contains CLOB data, Marked for Bulk Insert Loading.

MTK-17006

One of the table loader threads failed while copying data for table $TABLE.