トラブルシューティング

PEMサーバーの再構成

特定の状況では、PEMサーバーのアンインストール、再インストール、およびPEMサーバーの再構成が必要になる場合があります。次のコマンドを指定された順序で使用します。

  1. 次のコマンドを使用して、PEMサーバー構成を削除し、アンインストールします。

    /usr/edb/pem/bin/configure-pem-server.sh –un

  2. 次のコマンドを使用して、PEMパッケージを削除します。

    yum erase edb-pem-server

  3. 次のコマンドを使用して、 pem データベースを削除します。

    DROP DATABASE pem

  4. 証明書を /root/.pem/ から別の場所に移動します:

    mv /root/.pem/* <new_location>

  5. agent.cfg ファイルを /usr/edb/pem/agent/etc/agent.cfg から別の場所に移動します:

    mv /usr/edb/pem/agent/etc/agent.cfg <new_location>

  6. 次に、次のコマンドを使用してPEMサーバーを再構成します。

    /usr/edb/pem/bin/configure-pem-server.sh'

pem.alertテーブルが復元に失敗する

When restoring the pem backing database from backup, you may encounter an error during the restoration of the pem.alert table. This is caused by a missing table pre-requisite for the table - the pg_restore utility may restore the pem.alert pre-requisites after it attempts to restore pem.alert.

この場合、 pg_restore からの出力には、 alert テーブルを参照するエラーメッセージが含まれます。

pg_restore: [archiver (db)] could not execute query: ERROR: insert or
 update on table "alert_history" violates foreign key constraint
 "alert_history_alert_id_fkey"
DETAIL: Key (alert_id)=(3) is not present in table "alert".
Command was: ALTER TABLE ONLY alert_history
ADD CONSTRAINT alert_history_alert_id_fkey FOREIGN KEY (alert_id)
 REFERENCES alert(id) ON...
pg_restore: creating FK CONSTRAINT alert_status_alert_id_fkey
pg_restore: [archiver (db)] Error from TOC entry 3265; 2606 18355 FK
 CONSTRAINT alert_status_alert_id_fkey postgres
pg_restore: [archiver (db)] could not execute query: ERROR: insert or
 update on table "alert_status" violates foreign key constraint
 "alert_status_alert_id_fkey"
DETAIL: Key (alert_id)=(1) is not present in table "alert".
Command was: ALTER TABLE ONLY alert_status
ADD CONSTRAINT alert_status_alert_id_fkey FOREIGN KEY (alert_id)
 REFERENCES alert(id) ON U...

If you encounter this problem, restore the pem database before restoring the pem.alert table. Restoring the pem database will install the pre-requisites for pem.alert, and the restoration of the table should complete as expected.