Managing a PEM Agent

以下のセクションでは、PEMエージェントの動作と管理に関する情報を提供します。

エージェント権限

デフォルトでは、PEMエージェントは、オペレーティングシステムホストの root 権限とデータベースサーバーのスーパーユーザー権限でインストールされます。これらの特権により、PEMエージェントは、システムの使用状況について監視対象ホストおよびデータベースサーバーで無制限のプローブを呼び出し、情報を取得してPEMサーバーに返すことができます。

PEMエージェントの権限が低下すると、PEM機能が低下することに注意してください。完全な機能を実現するには、PEMエージェントを root として実行する必要があります。PEMエージェントがデータベースサーバーのサービスアカウントで実行されている場合、PEMプローブはレポートの生成に使用される統計情報に完全にアクセスできず、機能はそのアカウントの機能に制限されます。PEMエージェントが別のより低い特権のアカウントで実行されている場合、機能はさらに制限されます。

PEMエージェントのオペレーティングシステム権限を制限すると、一部のPEMプローブは情報を返さず、次の機能が影響を受ける可能性があります。

プローブまたはアクション

オペレーティングシステム

影響を受けるPEM機能

データとログファイルの分析

Linux/Windows

PostgresExpertは完全な情報にアクセスできません。

セッション情報

Linux

プロセスごとの統計は不完全です。

PGHBA

Linux/Windows

PostgresExpertは完全な情報にアクセスできません。

サービス再起動機能

Linux/Windows

監査ログマネージャー、サーバーログマネージャーログ分析エキスパート、およびPEMは、要求された変更を適用できない場合があります。

パッケージ展開

Linux/Windows

PEMは、ダウンロードしたインストールモジュールを実行できません。

バッチタスク

Windows

PEMは、Windowsでスケジュールされたバッチジョブを実行できません。

サーバーからデータを収集する(ルートアクセスが必要)

Linux/Windows

スワップ使用率、CPU使用率、IO読み取り、IO書き込みなどの列は、セッションアクティビティダッシュボードに0として表示されます。

注釈

上記のリストは包括的なものではありませんが、制限される機能の種類の概要を提供する必要があります。

PEMエージェントのデータベース特権を制限すると、次のPEM機能が影響を受ける可能性があります。

プローブ

オペレーティングシステム

影響を受けるPEM機能

監査ログの収集

Linux/Windows

PEMはPEMデータベースから空のデータを受け取ります。

サーバーログ収集

Linux/Windows

PEMはサーバーログ情報を収集できません。

データベース統計

Linux/Windows

データベース/サーバー分析ダッシュボードには、不完全な情報が含まれます。

セッション待機/システム待機

Linux/Windows

セッション/システム待機ダッシュボードには、不完全な情報が含まれます。

ロック情報

Linux/Windows

データベース/サーバー分析ダッシュボードには、不完全な情報が含まれます。

ストリーミングレプリケーション

Linux/Windows

ストリーミングレプリケーションダッシュボードには情報は表示されません。

Slonyレプリケーション

Linux/Windows

データベース分析ダッシュボードのSlony関連のチャートには情報が表示されません。

表領域サイズ

Linux/Windows

サーバー分析ダッシュボードには完全な情報は表示されません。

xDBレプリケーション

Linux/Windows

PEMはxDBアラートとトラップを送信できません。

プローブが不十分な特権でオペレーティングシステムを照会している場合、プローブは permission denied エラーを返す場合があります。

プローブが不十分な権限でデータベースを照会している場合、プローブは permission denied エラーを返すか、返されたデータを空の値としてPEMチャートまたはグラフに表示する場合があります。

プローブが失敗すると、プローブの名前、プローブが失敗した理由、問題の解決に役立つヒントを含むエントリがログファイルに書き込まれます。

サーバーで発生したプローブ関連のエラーを Probe Log ダッシュボードで表示したり、PEMワーカーログファイルのエラーメッセージを確認したりできます。Linuxでは、ログファイルのデフォルトの場所は次のとおりです。

/var/log/pem/worker.log

Windowsでは、ログ情報は Event Viewer で利用できます。

エージェント構成

多数のユーザー設定可能なパラメーターとレジストリエントリが、PEMエージェントの動作を制御します。一部のPEM機能を有効にするには、PEMエージェントのパラメーター設定を変更する必要がある場合があります。PEMエージェント設定ファイルの値を変更した後、PEMエージェントを再起動して変更を適用する必要があります。

PEM_MAXCONN パラメーターを除いて、PEM機能を有効にするために変更が必要な場合を除き、EDBサポートの専門家に相談せずに、以下にリストされている構成パラメーターまたはレジストリエントリを変更しないことを強くお勧めします。

Linuxシステムでは、PEM設定オプションは /usr/edb/pem/agent/etc にある agent.cfg ファイルに保存されます。 agent.cfg ファイルには次のエントリが含まれます。

パラメータ名

説明

デフォルト値

pem_host

PEMサーバーのIPアドレスまたはホスト名。

127.0.0.1。

pem_port

エージェントがPEMサーバーと通信するために接続するデータベースサーバーポート。

ポート5432。

pem_agent

PEMエージェントに割り当てられた一意の識別子。

最初のエージェントは 、2番目のエージェントは などです。

agent_ssl_key

PEMエージェントのキーファイルへの完全なパス。

/root/.pem/agent.key

agent_ssl_crt

PEMエージェントの証明書ファイルへの完全なパス。

/root/.pem/agent.crt

agent_flag_dir

HAサポートに使用されます。別のサーバーの監視を引き継ぐための要求をチェックするディレクトリパスを指定します。要求は、指定されたフラグディレクトリ内のファイルの形式で行われます。

デフォルトでは設定されていません。

log_level

ログレベルは、PEMログファイルに書き込まれるイベントのタイプを指定します。

警告

log_location

PEMワーカーログファイルの場所を指定します。

127.0.0.1。

agent_log_location

PEMエージェントログファイルの場所を指定します。

/var/log/pem/agent.log

long_wait

最初の接続試行が失敗した場合に、PEMエージェントがPEMサーバーへの接続を試行する前に待機する最大時間(秒)。

30秒

short_wait

PEMエージェントがキュー内に次にある(実行を待機している)プローブをチェックする前に待機する最小時間(秒単位)。

10秒

alert_threads

エージェントによって生成されるアラートスレッドの数。

PEMサーバーのホストに常駐するエージェントに対して1に設定します。他のすべてのエージェントの場合は0。

enable_smtp

複数のPEMエージェント(7.13以下)およびPEMバックエンドデータベース(9.4以下)に対してtrueに設定すると、より多くの重複メールを送信する場合があります。一方、PEMエージェント(7.14以降)およびPEMバックエンドデータベース(9.5以降)の場合、送信する重複メールの数は少なくなります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

enable_snmp

複数のPEMエージェント(7.13以下)およびPEMバックエンドデータベース(9.4以下)に対してtrueに設定すると、より多くの重複トラップが送信される場合があります。一方、PEMエージェント(7.14以降)およびPEMバックエンドデータベース(9.5以降)の場合、送信する重複トラップが少なくなる場合があります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

enable_nagios

trueに設定すると、Nagiosアラートが有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

enable_webhook

trueに設定すると、Webhookアラートが有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

max_webhook_retries

失敗時にpemAgentがwebhookの呼び出しを再試行する最大回数を設定します。

デフォルト3。

connect_timeout

エージェントが接続を待機する最大時間(秒)(10進整数文字列)。

デフォルトでは設定されていません。0に設定すると、エージェントは無期限に待機する必要があります。

allow_server_restart

TRUEに設定すると、エージェントは、監視するデータベースサーバーを再起動できます。このパラメータの値に応じて、一部のPEM機能が有効/無効になる場合があります。

False

max_connections

接続スロットルで使用されるプローブ接続の最大数。

0(無制限の数)

connection_lifetime

ConnectionLifetime(またはconnection_lifetime)を使用して、開いているがアイドル状態の接続が保持される最小秒数を指定します。MaxConnectionsで指定された値に達し、待機中の要求を満たすために(別のデータベースへの)新しい接続が必要な場合、このパラメーターは無視されます。

デフォルトでは、0に設定されます(接続は、エージェントの処理ループの後にアイドル状態になると切断されます)。

allow_batch_probes

TRUEに設定すると、ユーザーはカスタムプローブ機能を使用してバッチプローブを作成できます。

False

heartbeat_connection

TRUEに設定すると、ハートビートの送信に専用の接続が使用されます。

False

batch_script_dir

スクリプトファイル(アラート用)が保存されるパスを指定します。

/tmp

connection_custom_setup

監視対象サーバーとの新しい接続が確立されたときに呼び出されるSQLコードを提供するために使用します。

デフォルトでは設定されていません。

ca_file

CA証明書が存在するパスを指定します。

デフォルトでは設定されていません。

batch_script_user

バッチ/シェルスクリプトの実行に使用するユーザーの名前を指定します。

なし

webhook_ssl_key

WebhookのSSLクライアントキーファイルへの完全なパス。

webhook_ssl_crt

webhookのSSLクライアント証明書ファイルへの完全なパス。

webhook_ssl_crl

webhookサーバー証明書を検証するためのCRLファイルの完全なパス。

webhook_ssl_ca_crt

webhookのSSLca証明書ファイルへの完全なパス。

allow_insecure_webhooks

trueに設定すると、webhookが安全でないフラグで呼び出せるようになります。

False

64ビットWindowsシステムでは、PEMレジストリエントリは次の場所にあります。

HKEY_LOCAL_MACHINE/Software/Wow6432Node/EnterpriseDB/PEM/agent

レジストリには次のエントリが含まれます。

パラメータ名

説明

デフォルト値

PEM_HOST

PEMサーバーのIPアドレスまたはホスト名。

127.0.0.1。

PEM_PORT

エージェントがPEMサーバーと通信するために接続するデータベースサーバーポート。

ポート5432。

AgentID

PEMエージェントに割り当てられた一意の識別子。

最初のエージェントは 、2番目のエージェントは などです。

AgentKeyPath

PEMエージェントのキーファイルへの完全なパス。

%APPDATA%//Roaming//pem//agent.key。

AgentCrtPath

PEMエージェントの証明書ファイルへの完全なパス。

%APPDATA%//Roaming//pem//agent.crt

AgentFlagDir

HAサポートに使用されます。別のサーバーの監視を引き継ぐための要求をチェックするディレクトリパスを指定します。要求は、指定されたフラグディレクトリ内のファイルの形式で行われます。

デフォルトでは設定されていません。

LogLevel

ログレベルは、PEMログファイルに書き込まれるイベントのタイプを指定します。

警告

LongWait

最初の接続試行が失敗した場合に、PEMエージェントがPEMサーバーへの接続を試行する前に待機する最大時間(秒)。

30秒

shortWait

PEMエージェントがキュー内に次にある(実行を待機している)プローブをチェックする前に待機する最小時間(秒単位)。

10秒

AlertThreads

エージェントによって生成されるアラートスレッドの数。

PEMサーバーのホストに常駐するエージェントに対して1に設定します。他のすべてのエージェントの場合は0。

EnableSMTP

trueに設定すると、SMTP電子メール機能が有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

EnableSNMP

trueに設定すると、SNMPトラップ機能が有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

EnableWebhook

trueに設定すると、Webhookアラートが有効になります。

PEMサーバーホストの場合はtrue。他のすべての場合はfalse。

MaxWebhookRetries

失敗時にpemAgentがwebhookの呼び出しを再試行する最大回数を設定します。

デフォルト3。

ConnectTimeout

エージェントが接続を待機する最大時間(秒)(10進整数文字列)。

デフォルトでは設定されていません。0に設定すると、エージェントは無期限に待機します。

AllowServerRestart

TRUEに設定すると、エージェントは、監視するデータベースサーバーを再起動できます。このパラメータの値に応じて、一部のPEM機能が有効/無効になる場合があります。

本当

MaxConnections

接続スロットルで使用されるプローブ接続の最大数。

0(無制限の数)

ConnectionLifetime

ConnectionLifetime(またはconnection_lifetime)を使用して、開いているがアイドル状態の接続が保持される最小秒数を指定します。MaxConnectionsで指定された値に達し、待機中の要求を満たすために(別のデータベースへの)新しい接続が必要な場合、このパラメーターは無視されます。

デフォルトでは、0に設定されます(接続は、エージェントの処理ループの後にアイドル状態になると切断されます)。

AllowBatchProbes

TRUEに設定すると、ユーザーはカスタムプローブ機能を使用してバッチプローブを作成できます。

False

HeartbeatConnection

TRUEに設定すると、ハートビートの送信に専用の接続が使用されます。

False

BatchScriptDir

スクリプトファイル(アラート用)が保存されるパスを指定します。

/tmp

ConnectionCustomSetup

監視対象サーバーとの新しい接続が確立されたときに呼び出されるSQLコードを提供するために使用します。

デフォルトでは設定されていません。

ca_file

CA証明書が存在するパスを指定します。

デフォルトでは設定されていません。

AllowBatchJobSteps

trueに設定すると、バッチ/シェルスクリプトは管理者ユーザーアカウントを使用して実行されます。

なし

WebhookSSLKey

WebhookのSSLクライアントキーファイルへの完全なパス。

WebhookSSLCrt

webhookのSSLクライアント証明書ファイルへの完全なパス。

WebhookSSLCrl

webhookサーバー証明書を検証するためのCRLファイルの完全なパス。

WebhookSSLCaCrt

webhookのSSLca証明書ファイルへの完全なパス。

AllowInsecureWebhooks

trueに設定すると、webhookが安全でないフラグで呼び出せるようになります。

False

エージェントのプロパティ

PEMエージェントの Properties ダイアログは、ダイアログを開いたPEMエージェントに関する情報を提供します。ダイアログを開くには、PEMクライアントツリーコントロールでエージェント名を右クリックし、コンテキストメニューから Properties を選択します。

The PEM Agent Properties dialog

PEMエージェントプロパティダイアログ-[全般]タブ

PEMエージェント Properties ダイアログのフィールドを使用して、PEMエージェントに関する情報を確認または変更します。

  • Description フィールドには、PEMエージェントの変更可能な説明が表示されます。この説明は、PEMクライアントのツリーコントロールに表示されます。

  • グループを使用して、PEMクライアントツリーコントロールでサーバーとエージェントを整理できます。 Group ドロップダウンリストボックスを使用して、エージェントが表示されるグループを選択します。

  • Team フィールドを使用して、エージェントによって監視されているサーバーにアクセスできるグループロールの名前を指定します。このエージェントによって監視されているサーバーは、接続されているチームメンバーのPEMクライアントツリーコントロールに表示されます。これは便利な機能であることに注意してください。[チーム]フィールドは真の分離を提供しないため、セキュリティの目的で使用しないでください。

  • Heartbeat interval フィールドには、PEMエージェントからPEMサーバーへのレポート間で経過する時間の長さが表示されます。 Minutes または Seconds フィールドの隣のセレクターを使用して、間隔を変更します。

    PEM agent job notification properties

    PEMエージェントプロパティダイアログ-ジョブ通知タブ

    Job Notifications タブのフィールドを使用して、エージェントレベルで電子メール通知設定を構成します。

    • Override default configuration? スイッチを使用して、エージェントレベルのジョブ通知設定でデフォルトのジョブ通知設定を上書きするかどうかを指定します。このスイッチに Yes を選択した場合、このダイアログの残りの設定を使用して、ジョブ通知をいつ誰に送信するかを定義できます。このダイアログの残りの設定は、 Override default configuration? スイッチを有効にした場合にのみ機能することに注意してください。

    • Email on job completion? スイッチを使用して、ジョブが正常に完了したときにジョブ通知を送信するかどうかを指定します。

    • Email on a job failure? スイッチを使用して、ジョブの失敗時にジョブ通知を送信するかどうかを指定します。

    • Email group フィールドを使用して、ジョブ通知の送信先の電子メールグループを指定します。

    PEM agent agent configuration properties

    PEMエージェントプロパティダイアログ-エージェント設定タブ

    Agent Configurations タブには、エージェントの現在の構成と機能がすべて表示されます。

    • Parameter 列には、パラメーターのリストが表示されます。

    • Value 列には、対応するパラメーターの現在の値が表示されます。

    • Category 列には、対応するパラメーターのカテゴリが表示されます。 configuration または capability のいずれかです。