PEMのWebインタフェースの使用

PEM Webインターフェイスは、PEMサーバーとともにインストールされます。サーバーのインストールが完了したら、次の場所に移動して、選択したブラウザーでPEMインターフェイスを開くことができます。

https://<ip_address_of_PEM_host>:8443/pem

どこip_address_of_PEM_host PEMサーバのホストのIPアドレスを指定します。 Postgres Enterprise Managerログインウィンドウが開きます。

PEMログインページ

PEMログインページ

上のフィールドを使用しPostgres Enterprise Manager Login PEMサーバーで自分自身を認証するためにウィンドウを:

  • でPEMのデータベースユーザの名前の提供Usernameフィールドを。最初に接続するユーザーの場合、これはPEMサーバーのインストール時に指定された名前になります。
  • 内のユーザーに関連付けられているパスワードを提供Passwordフィールドを。

資格情報を入力したら、[ログイン]をクリックしてPEMに接続します。

PEMのWebインタフェースが表示され、開くGlobal Overviewダッシュボードを。

クライアントに表示されるグローバル概要ダッシュボード

クライアントに表示されるグローバル概要ダッシュボード

Browserペインには、各サーバー上に存在するデータベースオブジェクトに関する情報へのアクセスを提供し、ツリーコントロールを表示します。ツリーコントロールが展開され、PEMサーバーによって監視されているサーバーとオブジェクトの階層ビューが表示されます。

PEMメニューバーを使用すると、データベースサーバーとそれらのサーバーに存在するオブジェクトを管理するために使用できるコマンドと機能にアクセスできます。オプションが無効になっている場合:

  • 現在接続しているデータベースサーバーは、選択した機能をサポートしていない可能性があります。
  • 選択されたメニューオプションは、現在のオブジェクトに対して有効でない場合があります(設計上)。
  • サーバーへの接続に使用した役割には、選択したオブジェクトを変更するための十分な権限がない可能性があります。

PEMツールバー

PEM Webインターフェイスの上部にあるコンテキスト依存メニューにより、環境をカスタマイズし、PEMのエンタープライズ管理機能へのアクセスを提供できます。

ファイルメニュー

ファイルメニュー

ファイルメニュー

使用するFileは、次のオプションにアクセスするには、メニューを:

メニューオプションアクション
プリファレンス クリックして[設定]ダイアログを開き、PEMクライアント設定をカスタマイズします。
レイアウトをリセットワークスペースを変更した場合、クリックしてデフォルトのレイアウトに戻します。

オブジェクトメニュー

オブジェクトメニュー

オブジェクトメニュー

Objectメニューはコンテキスト依存です。使用するObject次のオプションにアクセスするには、メニューを:

メニューオプションアクション
サーバーに接続… [サーバーに接続]ダイアログをクリックして開き、サーバーとの接続を確立します。
作成する [作成]をクリックして、コンテキスト依存の選択を提供するコンテキストメニューにアクセスします。
CREATEスクリプトクリックしてクエリツールを開き、選択したスクリプトを編集または表示します。
削除/ドロップクリックして、現在選択されているオブジェクトをサーバーから削除します。
サーバーを切断… クリックすると、現在選択されているオブジェクトが更新されます。
ドロップカスケード クリックすると、現在選択されているオブジェクトとすべての依存オブジェクトがサーバーから削除されます。
隠す… クリックすると、現在選択されているグループが非表示になります。非表示のグループを表示するには、[設定]の[非表示のグループを表示]オプションを有効にします。
プロパティ… クリックして、現在選択されているオブジェクトのプロパティを確認または変更します。
更新… クリックすると、現在選択されているオブジェクトが更新されます。
トリガー現在選択されているテーブルの*無効*または*有効*トリガーをクリックします。
切り捨てクリックすると、テーブルからすべての行が削除されます(切り捨て)。または、テーブルとその子テーブルからすべての行が削除されます(カスケードの切り捨て)。
データを見るクリックして、データを表示するためのいくつかのオプションを提供するコンテキストメニューにアクセスします。

管理メニュー

管理メニュー

管理メニュー

使用Management 、次のPEMの機能にアクセスするためのメニューを。

メニューオプションアクション
監査マネージャー… クリックして監査マネージャーを開き、監視対象サーバーで監査を構成します。
自動検出… クリックして自動検出ダイアログを開き、PEMエージェントに監視対象データベースサーバーを見つけてバインドするよう指示します。
キャパシティマネージャー… クリックしてCapacity Managerダイアログを開き、履歴またはプロジェクトの将来のリソース使用量を分析します。
ログマネージャー… クリックして[ログマネージャー]ダイアログを開き、サーバーのログ収集を構成します。
アラートを管理する… クリックして[アラートの管理]タブにアクセスし、アラートの動作を作成または変更します。
チャートを管理… クリックして[チャートの管理]タブを開き、PEMチャートを作成または変更します。
ダッシュボードを管理… クリックして、[ダッシュボードの管理]ダイアログを開き、VACUUM、ANALYZE、REINDEX、またはCLUSTERを選択します。
プローブを管理… クリックして、プローブの管理ダイアログを開き、VACUUM、ANALYZE、REINDEX、またはCLUSTERを実行します。
パッケージの展開… クリックしてパッケージ展開ウィザードを開き、パッケージをインストールまたは更新します。
Postgresエキスパート… クリックしてPostgres Expertウィザードを開き、サーバーとデータベースの静的分析を実行します。
Postgresログ分析エキスパート… クリックしてPostgres Log Analysis Expertダイアログにアクセスし、使用傾向のログファイルの内容を分析します。
キューサーバーの起動… クリックすると、現在選択されているサーバーを起動するようにPEMサーバーに指示します。
キューサーバーのシャットダウンクリックすると、現在選択されているサーバーをシャットダウンするようにPEMサーバーに指示します。
クラスターマスターの交換クリックして、レプリケーションシナリオの現在のマスターノードを置き換えます。
スケジュールされたタスク [スケジュールされたタスク]タブをクリックして開き、保留中または最近完了したタスクを確認します。
サーバー構成… [サーバー構成]ダイアログをクリックして開き、PEMサーバーの構成設定を更新します。
SQLプロファイラ… クリックしてSQLプロファイラダイアログを開き、SQLクエリパフォーマンスに関する統計情報をキャプチャします。
ストリーミングレプリケーション… クリックして、[ストリーミングレプリケーション]ダイアログにアクセスし、ストリーミングレプリケーションシナリオを構成します。
チューニングウィザード… クリックして[チューニングウィザード]ダイアログを開き、サーバーの一連のチューニング推奨事項を生成します。

ダッシュボードメニュー

ダッシュボードメニュー

ダッシュボードメニュー

コンテキスト依存使用Dashboardsダッシュボードにアクセスするためのメニューを。

オプションアクション
アラートダッシュボードクリックして、選択したノードのアラートダッシュボードを開きます。
監査ログ分析クリックして、選択したノードの監査ログ分析ダッシュボードを開きます
データベース分析クリックして、選択したノードのデータベース分析ダッシュボードを開きます。
I / O分析クリックして、選択したノードのI / O分析ダッシュボードを開きます。
メモリ分析クリックして、選択したノードのメモリ分析ダッシュボードを開きます
オブジェクトアクティビティ分析クリックして、選択したノードのオブジェクトアクティビティ分析ダッシュボードを開きます。
オペレーティングシステム分析クリックして、選択したノードのオペレーティングシステム分析ダッシュボードを開きます。
プローブログ分析 クリックして、選択したノードのプローブログ分析ダッシュボードを開きます。
サーバー分析クリックして、選択したノードのサーバー分析ダッシュボードを開きます。
サーバーログ分析クリックして、選択したノードのサーバーログ分析ダッシュボードを開きます。
セッション活動分析クリックして、選択したノードのセッションアクティビティ分析ダッシュボードを開きます。
ストレージ分析クリックして、選択したノードのストレージ分析ダッシュボードを開きます。
ストリーミングレプリケーション分析クリックして、選択したノードのストリーミングレプリケーション分析ダッシュボードを開きます。
システム待機分析クリックして、選択したノードのシステム待機分析ダッシュボードを開きます。

ツールメニュー

[ツール]メニュー

[ツール]メニュー

上のオプションを使用するTools次の機能にアクセスするには、メニュー:

オプションアクション
名前付き復元ポイントを追加 クリックしてダイアログを開き、現在のサーバー状態のポイントインタイムスナップショットを作成します。
バックアップ… クリックして[バックアップ]ダイアログを開き、データベースオブジェクトをバックアップします。
バックアップグローバル... クリックして[グローバルのバックアップ]ダイアログを開き、クラスターオブジェクトをバックアップします。
バックアップサーバー… [サーバーのバックアップ...]ダイアログをクリックして、サーバーをバックアップします。
グラントウィザード… クリックして、Grant Wizardツールにアクセスします。
インポート・エクスポート… クリックして[データのインポート/エクスポート]ダイアログを開き、テーブルからデータをインポートまたはエクスポートします。
メンテナンス… VACUUM、ANALYZE、REINDEX、またはCLUSTERの[メンテナンス…]ダイアログをクリックして開きます。
WALのリプレイを一時停止クリックして、WALログの再生を一時停止します。
クエリツールクリックすると、現在選択されているオブジェクトのクエリツールが開きます。
設定を再読み込み… サーバーを再起動せずに構成ファイルを更新する場合にクリックします。
リストア… クリックして[復元]ダイアログにアクセスし、バックアップからデータベースファイルを復元します。
WALのリプレイを再開するクリックして、WALログの再生を再開します。

ヘルプメニュー

ヘルプメニュー

ヘルプメニュー

上のオプションを使用しHelpのオンラインヘルプドキュメントにアクセスしたり、PEMのインストールに関する情報を確認するためのメニューを。

オプションアクション
オンラインヘルプクリックして、Postres Enterprise Managerのドキュメントを開きます。
EnterpriseDB WebサイトブラウザウィンドウでEnterpriseDB Webサイトをクリックして開きます。
Postgres Enterprise Managerについてクリックして、Postgres Enterprise Managerのバージョン情報とユーザー情報を見つけます。

チャート、グラフや表を制御し、カスタマイズ

ダッシュボードの各グラフィックの右上隅にあるアイコンを使用して、現在のユーザーセッション用にPEMクライアントに表示されるチャート、グラフ、および表を制御およびカスタマイズします。

PEMクライアントチャートコントロールアイコン

PEMクライアントチャートコントロールアイコン

アイコンを選択して:

icon1 チャート、グラフ、または表のコンテンツを更新します。
icon2 チャートまたはグラフをフルスクリーンに展開します。
icon3 現在のユーザーのチャート、グラフ、またはテーブル設定をカスタマイズします。
icon4 チャートまたはグラフの画像をダウンロードする
icon5 チャート、グラフ、またはテーブルに関する情報を表示します。

PEMダッシュボードに表示されるグラフィックのカスタマイズの詳細については、PEMクライアントのオンラインヘルプを参照してください。

オンラインヘルプとドキュメント

PEMには、ツールの使用を支援する組み込みヘルプが含まれています。 PEMのオンラインヘルプにアクセスするには、[ヘルプ]メニューの[ヘルプ]オプションから[オンラインヘルプ]を選択します。

PEMオンラインヘルプ

PEMオンラインヘルプ

Helpメニューには、EnterpriseDBのウェブサイトへの迅速なアクセスを可能にします。