Keyboard Shortcuts :

pgAdminにはキーボードショートカットが提供されているため、特定の機能に簡単にアクセスできます。必要に応じて、[File>Preferences]で代替ショートカットを構成できます。

メインブラウザウィンドウ

メインブラウザーウィンドウを使用している場合、次のキーボードショートカットを使用できます。

すべてのプラットフォームのショートカット

ファンクション

Shift+Ctrl+a

グリッド行を追加

Shift+Alt+b

オブジェクトエクスプローラー

Shift+Alt+n

オブジェクトを作成

Shift+Alt+d

オブジェクトを削除

Shift+Ctrl+[

ダイアログタブ後方

Shift+Ctrl+]

ダイアログタブを進む

Shift+Alt+g

ダイレクトデバッグ

Shift+Alt+e

オブジェクトのプロパティを編集する

Shift+Alt+f

ファイルメインメニュー

Shift+Alt+h

ヘルプメインメニュー

Shift+Alt+o

オブジェクトメインメニュー

Shift+Alt+c

コンテキストメニューを開く

Shift+Alt+q

クエリツールを開く

Shift+Ctrl+f

クイック検索

F5

オブジェクトエクスプローラーを更新

Shift+Alt+s

オブジェクトを検索

Shift+Alt+[

タブ付きパネル後方

Shift+Alt+]

タブ付きパネルを前方に

Shift+Alt+l

ツールメインメニュー

Shift+Alt+v

データを見る

ダイアログタブ

以下のショートカットを使用して、ダイアログのタブセットをナビゲートします。

すべてのプラットフォームのショートカット

ファンクション

Control+Shift+[

ダイアログタブ後方

Control+Shift+]

ダイアログタブを進む

プロパティグリッドコントロール

プロパティグリッドコントロールを操作するときは、以下のショートカットを使用します。

すべてのプラットフォームのショートカット

ファンクション

Control+Shift+A

グリッドに行を追加

タブ

次のコントロールにフォーカスを移動する

Shift+Tab

フォーカスを前のコントロールに移動する

戻る

コンボボックスで選択された項目をピックします

Control+Shift+A

グリッドに行を追加

SQLエディター

構文強調表示SQLエディターを使用する場合、次のショートカットを使用できます。

ショートカット(Windows/Linux)

ショートカット(Mac)

ファンクション

Alt+左

Option+左

行の先頭に移動

Alt+右

Option+右

行末に移動

Ctrl+Alt+左

Cmd+Option+Left

左に1単語移動

Ctrl+Alt+右

Cmd+Option+Right

1単語右に移動

Ctrl+/

Cmd+/

選択したコードをコメントする(インライン)

Ctrl+.

Cmd+.

選択したコードのコメントを解除(インライン)

Ctrl+Shift+/

Cmd+Shift+/

コードのコメント/アンコメント(ブロック)

Ctrl+a

Cmd+a

すべて選択

Ctrl+c

Cmd+c

選択したテキストをクリップボードにコピー

Ctrl+r

Cmd+r

最後の編集をやり直す

Ctrl+v

Cmd+v

クリップボードからテキストを貼り付ける

Ctrl+z

Cmd+z

最後の編集を元に戻す

タブ

タブ

選択したテキストをインデント

Shift+Tab

Shift+Tab

選択したテキストのインデントを解除

Alt+g

Option+g

ジャンプ(行:列へ)

Ctrl+スペース

Ctrl+スペース

オートコンプリート

Ctrl+f

Cmd+f

探す

Ctrl+g

Cmd+g

次を探す

Ctrl+Shift+g

Cmd+Shift+g

前を検索

Ctrl+Shift+f

Cmd+Shift+f

置き換える

クエリツール

クエリツールを使用する場合、次のショートカットを利用できます。

ショートカット(Windows/Linux)

ショートカット(Mac)

ファンクション

<アクセスキー>+q

<アクセスキー>+q

クエリをキャンセル

<アクセスキー>+t

<アクセスキー>+t

接続状態

<アクセスキー>+d

<アクセスキー>+d

行を削除する

<アクセスキー>+×

<アクセスキー>+×

実行オプション

<アクセスキー>+f

<アクセスキー>+f

フィルタダイアログ

<アクセスキー>+i

<アクセスキー>+i

フィルタオプション

<アクセスキー>+n

<アクセスキー>+n

オプションを探す

<アクセスキー>+o

<アクセスキー>+o

ファイルを開く

<アクセスキー>+p

<アクセスキー>+p

行を貼り付ける

<アクセスキー>+r

<アクセスキー>+r

行制限

<アクセスキー>+s

<アクセスキー>+s

ファイルを保存

Ctrl+Alt+L

Ctrl+option+L

クエリをクリア

Shift+Ctrl+m

Shift+Ctrl+m

コミットする

F8

F8

ダウンロード結果

Shift+F7

Shift+F7

EXPLAINANALYZEクエリ

F7

F7

EXPLAINクエリ

F5

F5

クエリを実行

Shift+Alt+]

Shift+option+]

次のタブ

Shift+Alt+[

Shift+option+[

前のタブ

Shift+Ctrl+r

Shift+Ctrl+r

ロールバック

F6

F6

データの変更を保存する

Shift+Alt+Tab

Shift+option+Tab

スイッチパネル

Shift+Ctrl+u

Shift+Ctrl+u

選択したテキストの大文字と小文字を切り替えます

デバッガー

デバッガーを使用する場合、次のショートカットを使用できます。

ショートカット(Windows/Linux)

ショートカット(Mac)

ファンクション

<アクセスキー>+×

<アクセスキー>+×

すべてのブレークポイントをクリア

<アクセスキー>+c

<アクセスキー>+c

続行/開始

<アクセスキー>+i

<アクセスキー>+i

踏み込む

<アクセスキー>+o

<アクセスキー>+o

ステップオーバー

<アクセスキー>+s

<アクセスキー>+s

ストップ

<アクセスキー>+t

<アクセスキー>+t

トグルブレークポイント

Shift+Alt+q

Shift+option+q

グリッド値を編集する

Shift+Alt+]

Shift+option+]

次のタブ

Shift+Alt+[

Shift+option+]

前のタブ

Shift+Alt+Tab

Shift+option+Tab

スイッチパネル

ERDツール

ERDツールを使用する場合、次のショートカットを使用できます。

ショートカット(Windows/Linux)

ショートカット(Mac)

ファンクション

Ctrl+Alt+a

Ctrl+option+a

テーブルを追加

Ctrl+Alt+n

Ctrl+option+n

メモの追加/編集

Ctrl+Alt+l

Ctrl+option+l

自動整列

Ctrl+Alt+c

Ctrl+option+c

クローンテーブル

Ctrl+Alt+i

Ctrl+option+i

画像をダウンロード

Ctrl+Alt+d

Ctrl+option+d

ドロップテーブル

Ctrl+Alt+e

Ctrl+option+e

テーブルを編集

Ctrl+Alt+s

Ctrl+option+s

SQLを生成

Ctrl+Alt+m

Ctrl+option+m

多対多リンク

Ctrl+Alt+o

Ctrl+option+o

1対多のリンク

Ctrl+o

Ctrl+o

プロジェクトを開く

Ctrl+s

Ctrl+s

プロジェクトを保存

Shift+Ctrl+s

Shift+Ctrl+s

プロジェクトを名前を付けて保存

Ctrl+Alt+t

Ctrl+option+t

詳細を表示する/少なく表示する

Shift+Alt++

Shift+option++

ズームイン

Shift+Alt+-

Shift+option+-

ズームアウト

Shift+Alt+f

Shift+option+f

ズームしてフィット

内部タブとパネルナビゲーション

クエリツールとデバッガーを使用する場合、内部パネルのナビゲーションに次のショートカットを使用できます。

アクセスキー

<accesskey>は、ブラウザーとプラットフォームに依存します。次の表に、サポートされているブラウザーのデフォルトのアクセスキーを示します。

Windows

Linux

マック

エッジ

代替

Chrome

代替

代替

Ctrl+Option

Firefox

Alt+Shift

Alt+Shift

Ctrl+Option

サファリ

代替

Ctrl+Option