Trusted Postgres Architect 23.1 to 23.11 release notes#

TPA 23.11#

リリース日2023-01-31

重要な変更#

  • TPA-180 PGD-Always-ONアーキテクチャ今年後半にリリースの実験的なサポートを導入します。 PGD-Always-ONアーキテクチャは、次のBDRバージョン5を使用します。初期サポートは内部目的に追加され、今後のリリースで改善されます。

マイナー変更#

  • TPA-349 依存関係バージョンのバンプ 暗号化バージョン38.0.4から39.0.0のバンプ jqバージョン1.3.0から1.4.0のバンプ

  • TPA-345 ドキュメント内のTPAexec参照をTPAに変更します。製品を参照するときは、’TPAexec’の代わりに’TPA’を使用するようにドキュメントを更新します。

TPA 23.10#

リリース日2023-01-04

マイナー変更#

  • TPA-161 harp_manager_restart_on_failure 設定デフォルトfalseを導入して、harp-manager systemdサービスの障害時のプロセスの再起動を有効にします

バグ修正#

  • TPA-281 AWSクラスターのプロビジョニングを解除するときにFMSセキュリティグループを削除する 削除されていない依存関係が原因でクラスターのVPCのプロビジョニング解除の失敗を修正します。

  • TPA-305 Towerの事前生成されたシークレットにenterprisedb_passwordを追加します

  • TPA-306 PEM_PYTHON_EXECUTABLEが存在する場合は、/usr/bin/python3に優先します PEM 9.0での展開中のPythonモジュールのインポートエラーを修正します。

  • TPA-219 BDRインスタンスでpem-agentにデフォルトでbdr_databaseを監視させます

TPA 23.9#

リリース日2022-12-12

バグ修正#

  • TPA-301 Towerクラスターのcluster_dirの自動検出を修正 Towerプロジェクトディレクトリに基づいてcluster_dirを設定する場合、デプロイ先のインスタンスではなく、コントローラ上のディレクトリの存在を正しく確認するようになりました。

  • TPA-283 Ansible Towerに必要な psutilへの依存関係を追加します。

  • TPA-278 rsyslog構成から「umask 0」指示子を削除します。これにより、以前は rsyslogd.pidなどの誰でも読み取り可能なファイルが作成されます。

  • TPA-291 PostgresサーバーパッケージをインストールしてBarmanインスタンスでpg_receivewalを取得するときは、 postgres_package_version設定を尊重します。

TPA 23.8#

リリース日2022-11-30

重要な変更#

  • TPA-18サポート Ansible Tower 3.8 このリリースでは、Ansible Tower 3.8を介してbare クラスターつまり既存のサーバーでのdeploy.yml のみの実行をサポートしています。 TowerサーバーにTPAexecをインストールし、tpaexec setup を実行して、Towerテンプレートで使用できる仮想環境を作成してTPAexecプレイブックを実行します。 --use-ansible-tower および--tower-git-repository 構成オプションを使用して、Tower互換のクラスター構成を生成します。詳細については、 Ansible Tower を参照してください。

マイナー変更#

  • TPA-238 クラスターディレクトリをgitリポジトリとして初期化する TPAexecを実行するシステムでgitが利用可能な場合、 tpaexec configure はデフォルトでクラスターディレクトリ内のgitリポジトリを初期化します。 gitが利用できない場合、以前と同様に続行されます。リポジトリの作成を回避するにはたとえば、既存のリポジトリ内にクラスタディレクトリを保存する場合、 --no-git オプションを使用します。

TPA 23.7#

リリース日2022-11-09

重要な変更#

  • TPA-234 Ansible 2.9のコミュニティリリースをサポート TPAexecは、Ansible 2.9の2ndQuadrant/ansibleフォークを必要としました。このリリースでは、代わりにAnsibleのコミュニティリリースをtpaexec setup --use-community-ansible で使用することを選択できます。今のところ、デフォルトは引き続き2ndQuadrant/ansibleを使用することです。これは将来のリリースで変更される予定です。 2ndQuadrant / ansibleのサポートがドロップされ、Ansibleが新しいデフォルトになります。

マイナー変更#

  • TPA-209 Postgres 15のリリースに続いて、有効なtpaexec configure オプションとして--postgres-version 15 を受け入れます

  • TPA-226 --hostnames-from ファイルのIPアドレスの受け入れ 以前は、tpaexec configure に渡されるファイルには、行ごとに1つのホスト名が含まれることが想定されていました。各ホスト名の後にオプションのIPアドレスを含めることもできるようになりました。存在する場合、このアドレスはconfig.ymlの対応するインスタンスのip_address として設定されます。独自の--hostnames-from ファイルを指定すると、ホスト名がデフォルトでランダム化されなくなります。

  • TPA-231 新しいbdr-pre-group-joinフックを追加します このフックは、各ノードがBDRノードグループに参加する前に実行されます。 TPAexecが提供するデフォルトのレプリケーションセット構成を変更するために使用される場合があります。

  • TPA-130 Community.postgresqlのpostgresql_userモジュールを使用します SCRAMパスワードを使用するときにタスクステータスを正しく報告するには、 Community.postgresqlコレクションの更新されたモジュールが必要です。デフォルトモジュールは常にchanged を報告します。

  • TPA-250 さまざまなPython依存関係の最新バージョンへのアップグレード

バグ修正#

  • TPA-220 .bashrcのLD_LIBRARY_PATHが「:」で始まらないことを確認します

  • TPA-82 BDRの削除を回避する -internal ${group_name}_extレプリケーションセット

  • TPA-247 AWSでの「‘str object’には属性’node_dsn’」エラーを修正します。コードはhostvars[hostname] を中間変数に割り当てず、後で通常のdictと同様に動作することを想定しています時々のみ動作します。これにより、PEMが有効になっているAWSクラスターで報告された23.6の回帰が修正されますが、コードベース全体の他の同様のエラーも修正されます。

  • TPA-232 インベントリーで生成されたシークレットへのシンボリックリンクを作成する際の競合状態を排除し、「Error while linking: [Errno 17] File attempts」エラーを発生させました

  • TPA-252 すべてのBDRノードを監視専用レプリケーションセットに公開する復元コード このコードブロックは、TPA-193に対して行われたリファクタリング作業の一部として、v23.6リリースで誤って削除されました。

TPA 23.6#

リリース日2022-09-28

重要な変更#

  • TPA-21 AWS展開には、メンテナンスされていないboto2の代わりにboto3 AWSクライアントライブラリを使用します。これにより、SSOログインやその他の便利な機能が有効になります。

  • TPA-202 harp-configフックを追加します。この展開時フックは、 HARPがインストールおよび構成された後、 HARPがインストールされているすべてのノードで開始される前に実行されます。

バグ修正#

  • TPA-181 RHEL 7でデフォルトのPythonバージョンを2に設定します。以前は、 tpaexecはRHEL 7とPython 3のサポートされていない組み合わせでconfig.ymlを生成できました。

  • TPA-210 既存のセキュリティグループを使用してaws展開を修正します。このような展開は、プロビジョニング時に失敗していましたが、予想通りに動作するようになりました。

  • TPA-189 プロビジョニング解除時にgroup_varsディレクトリを削除します。これにより、ダングリングのシンボリックリンクが原因で後続のプロビジョニングが失敗する原因となった問題が修正されます。

  • TPA-175 共有メモリセグメントをそのままにするようにsystemdを正しく構成します。これはソースビルドにのみ影響します。

  • TPA-160 haproxyおよびPEMのバージョン設定を許可します。これは、特定のバージョンが指定された場合でもパッケージの最新バージョンがインストールされるバグを修正します。

  • TPA-172 正しいホストセットにEFMをインストールします。 EFMは、PEMサーバーなどの他の理由でpostgresがインストールされているサーバーではなく、クラスターのメンバーであるpostgresサーバーにのみインストールする必要があります。

  • TPA-113 PEMエージェント登録をシリアル化します。これにより、複数のホストがpemworker –register-agentを同時に実行しようとした場合の競合状態が回避されます。

TPA 23.5#

リリース日2022-08-23

重要な変更#

  • TPA-81 Ubuntu 22.04 Jammyのtpaexecおよびtpaexec-depsパッケージを公開する

  • TPA-26 単一ノードでのharp-proxyおよびharp-managerのインストールをサポートします。 harp-proxyとharp-managerサービスの両方をクラスター内の同じターゲットノードで実行できるようになりました。

TPA 23.4#

リリース日2022-08-03

バグ修正#

  • TPA-152は、AWSホストでのDebianインスタンスの最初のブート中のロケール検出に関する問題を修正します。ホストは最初のブートを完了できず、SSHキーネゴシエーションの問題と、展開中に見つからないディスクのエラーとして現れます。この問題は23.3で導入され、TPA-38に関連しています

TPA 23.3#

リリース日2022-08-03

重要な変更#

  • TPA-118 harp-manager構成の2つの新しいオプションを公開しました。最初の設定はdcs request_timeoutと同様にHARP harp_db_request_timeout を設定しますが、データベース接続用であり、2番目のharp_ssl_password_command は、SSL対応データベース接続のsslキーの復号化に使用されるsslパスワードの難読化を解除するために使用されるコマンドを指定します

マイナー変更#

  • TPA-117 tpaexec config.ymlのpackage_version オプションでのワイルドカードの使用に関するドキュメントの更新を追加します。これにより、deploy 操作中に予期しないパッケージのアップグレードが発生する可能性があるという警告が導入されます。詳細については、 tpaexec-configure.md のドキュメントを参照してください

  • TPA-38 Debianのすべてのバージョン、およびRHEL 8以降のロケールファイルを追加します。 Barmanなどの一部のEDBソフトウェアでは、ユーザーロケールをen_US.UTF-8 に設定する必要があります。一部のユーザーは、ロケール、文字セット、または言語をローカル地域に変更したい場合があります。この変更により、libcが提供するOSファイルが、ユーザーデータスクリプトを使用したファーストブート中にAWSインスタンスにインストールされます。デフォルトロケールはen_US.UTF-8 です。詳細については、 platform_aws.md ドキュメントを参照してください

  • TPA-23 クラスターサービスBarman、 HARP、repmgr、PgBouncer、およびEFMのsyslogのログ構成を追加します。指定されたログサーバーは、これらのサービスの/var/log/hosts ディレクトリで受信したログファイルを保存します

  • TPA-109 BDRの特定のバージョンに基づいて、ロックタイムアウト構文の選択を中心としたpgbenchロールのコードのマイナーリファクタリング

バグ修正#

  • TPA-147 ソースインストール方法を使用するクラスターでは、DebianおよびRocky Linuxの一部の欠落パッケージが観察されました。 Debianは、krb5およびlz4のライブラリヘッダーを受信します。 RedHat派生OSでは、「Development Tools」パッケージグループの必須パッケージとlibcurlヘッダーが追加されました

  • TPA-146 Postgres 9.6をインストールするクラスターのパッケージ選択方法の小さな修正

  • TPA-138 local-repoconfigureオプションを有効にする「ベア」プラットフォームを使用するクラスターでの警告メッセージに対処します。 OSはベアプラットフォームのTPAexecによって管理されないため、local-repo構造を作成するようにユーザーに通知する必要があります。これにより、以前は未処理のエラーが発生し、構成の進行状況が停止しました

  • TPA-135 “docker”プラットフォームおよびRocky Linuxイメージで--use-local-repo-only を使用する場合、ノード上の既存のyumリポジトリ構成の初期削除は、コマンドfind およびxargs が欠落しているため失敗します。この変更により、findutils パッケージがソースリポジトリに存在する場合、最初にインストールされます

  • TPA-111 --enable-pem オプションが指定されている場合、PEMサーバーにエージェントを登録するために使用されるコマンドの冗長な追加引数を削除します。以前は、最初の引数現在削除された引数が2番目の引数によってオーバーライドされるため、問題は発生しませんでした。

  • TPA-108 Postgresがソースからインストールされている場合、ポストマスターシンボリックリンクのSELinuxファイルコンテキストを復元します。以前は、systemdデーモンがPostgresデータbinディレクトリに保存されているシンボリックリンクを読み取ることができないため、ソースからpostgresをインストールしているSELinux対応OSを使用しているクラスターは、Postgresの再起動に失敗していました。これは、AWSで最近採用されたRocky Linuxイメージを使用したテストで発見されました。デフォルトでSELinuxが有効になり、強制モードになっています

TPA 23.2#

リリース日2022-07-13

重要な変更#

  • BarmanおよびPEMで使用するPostgres Backup APIのサポートを追加します。 --enable-pg-backup-api オプションを介してアクセスできます。

  • SSL証明書は、Postgres Backup APIプロキシサービスのサーバー証明書など、サービスごとに作成できるようになりました。証明書は/etc/tpa/<service>/<hostname>.cert に配置されます。これらの証明書は、クラスター用に生成されたCA証明書で署名することもできます。

  • BDRのEtcdの配置 - Always-ONアーキテクチャ ’harp_consensus_protocol: etcd’を使用する場合、次の各インスタンスのロールに’etcd’を明示的に追加します。

  • BDRプライマリ ’bdr’ロール

  • BDR論理スタンバイ ’ bdr’ + ’readonly’roles)

  • Bronzeレイアウトの場合のみBDR Witness ‘bdr’ + ’witness’ロール)

  • GoldレイアウトのみBarman ’barman’ロール クレジット: Gianni Ciolli gianni.ciolli@enterprisedb .com

マイナー変更#

  • 製品ブランドの変更を反映するように、configure引数--2q を--pgextended に置き換えます。既存の構成は、予想される動作を保持します。

  • Debianの古い安定版に付属しているdockerのバージョン18を使用する場合のDockerプラットフォームの互換性チェックのエラーレポートを改善しました。

  • 不足しているコマンドをCLIヘルプドキュメントに追加します。

  • configureコマンドのエラーレポートが改善されました。

  • ソースからBDR 5をビルドするための初期サポートを追加します。クレジット: Florin Irion florin.irion@enterprisedb.com

  • Postgresの古いバージョンからEDB製品への移行の継続的な互換性を確保するための変更。

バグ修正#

  • download-packagesコマンドを使用してローカルリポジトリにデータを入力するときに、etcdのパッケージが欠落することを意味する問題を修正しました。

  • efmフェールオーバーマネージャーの使用とそのパッケージの依存関係の選択に影響を与える問題を修正しました

TPA 23.1#

リリース日2022-06-21

このリリースでは、アップグレード後にtpaexec setup を実行する必要があります、それ以外の場合はエラーで失敗します。

パッケージのインストール動作の変更#

以前のバージョンでは、正確なバージョンが明示的に指定されていない限り、 tpaexec deploy を実行すると、インストールされたパッケージをアップグレードする可能性がありましたpostgres_package_version設定など。ただし、これは決して安全、サポート、または推奨されるアップグレード方法ではありません。特に、展開中のパッケージのアップグレード後に、サービスが安全かつ正しく再起動されていない可能性があります。

このリリース以降、tpaexec deploy は、インストールされたパッケージをアップグレードすることはありません。最初の展開は、必要なパッケージをすべてインストールします特定のバージョンが設定されている場合、または利用可能な最新のパッケージをインストールします。後続の実行では、パッケージがインストールされたことを確認し、それ以上は何も行いません。これは、予測可能で安全な新しいデフォルト動作です。

コンポーネントを更新する必要がある場合は、tpaexec update-postgres を使用します。このリリースでは、コマンドはPostgresおよびBDRまたはpglogicalなどのPostgres関連パッケージ、およびHARP、pgbouncer、etcdなどの特定の他のコンポーネントを更新できます特定のクラスターに該当する場合。将来のリリースでは、より多くのコンポーネントのアップグレードを安全にサポートする予定です。

重要な変更#

  • HARPブートストラップ構成が変更された場合にのみ「harpctl apply」を実行します 警告これにより、tpaexec deploy を実行したときに既存のクラスターで単一のharpサービスがリスタートします。これは、リストが一貫した順序になるようにconfig.ymlが変更され、意図しない変更が回避されるためです将来の展開

  • tpaexec download-packages コマンドを追加して、クラスターに必要なすべてのパッケージをlocal-repoディレクトリにダウンロードして、エアギャップ/切断された環境のクラスターインスタンスにコピーできるようにします。詳細については、 air-gapped.mdおよびlocal-repo.mdを参照してください。

  • 新しいBDRの--harp-consensus-protocol <etcd|bdr> 構成オプションが必要です-Always-ONクラスター コンセンサスプロトコルの選択がデータセンター/場所間のネットワークレイテンシーによっては、フェイルオーバーパフォーマンスに悪影響を与える可能性があるため、TPAexecはここでデフォルト値を提供しなくなり、ユーザーの状態が向上します特定のクラスターに最適なプロトコルを選択します。これは、新しく生成されたクラスターの構成に影響しますが、 harp_consensus_protocolを明示的に設定せずに以前のデフォルトのetcd を使用する既存のクラスターには影響しません。

マイナー変更#

  • 古いバージョンが利用できないディストリビューションにEFM用のopenjdk-8の代わりにopenjdk-11をインストールする

  • harp_log_level 設定たとえば cluster_varsの下を受け入れて、デフォルトのharp-managerおよびharp-proxyログレベルinfoをオーバーライドします

  • 復元力を向上させるために、個々のエンドポイントDSNのリストの代わりに単一のマルチホストBDR DCSエンドポイントDSNを使用するようにharp-proxyを構成します

  • harp-managerのBDR DCSのローカルUnixソケットDSNから余分な接続属性たとえばssl*を省略します

バグ修正#

  • harp-managerとharp-proxyの構成が変更された場合に、harp-managerとharp-proxyが再起動されていることを確認します

  • 読み取り専用のharp_dcs_userに必要な追加の新しい権限を付与することにより、 harpプロキシエラーを修正します

  • CAMOが有効になっているときにBDR4トランザクションストリーミングを無効にする bdr.enable_camoが設定されている場合、 bdr.default_streaming_modeを無効にする必要があります。これは、 BDR4のCAMOで保護されたトランザクションと互換性がありません。これにより、 CAMO対応BDR4クラスターいずれにせよストリーミングが有効になった状態では動作しませんでした。サーバーが再起動します。