Trusted Postgres Architect 23.34 release notes#
リリース日2024年8月22日
Trusted Postgres Architect 23.34の新機能、機能強化、バグ修正、およびその他の変更には次のものが含まれます。
Type |
Description |
|---|---|
Enhancement |
TPAには、efmがインストールされ、構成ディレクトリとユーザーが作成された後、efmが構成される前に実行される`efm-pre-config`フックが追加されました。カスタムefmヘルパースクリプトのインストールに使用できます。 |
Enhancement |
TPAには、タスクごとに1行の情報を表示する独自の出力プラグインがあり、1行でも情報のないタスクを省略します。線は、TPAの制御フローを可視できるようにインデントされており、成功、スキップ、および無視されたホストの色分けされた数が含まれています。 より完全な出力は、ご使用の環境でTPA_USE_DEFAULT_OUTPUT=trueに設定するか、コマンドラインに-vスイッチを追加することにより、オンにできます。 |
Enhancement |
TPAでは、PEMエージェントを登録するときに、`cluster_vars`の`pemagent_registration_opts`の下にリストすることにより追加オプションを指定できるようになりました。 |
Enhancement |
cluster_varsまたはpem-serverインスタンスvars `pem_server_ssl_certificate`および`pem_server_ssl_key`の下の`config.yml`にPEMサーバーで使用する証明書とキーペアの名前を含めることにより、PEMサーバーで使用する独自のWebサーバー証明書を提供できるようになりました。 TPAは、クラスターディレクトリの`ssl/pemserver`ディレクトリからPEMサーバーにそれらをコピーし、それに応じてApache/httpdを構成します。 |
Enhancement |
TPAは、新しいクラスター展開でEFM `upgrade-conf`コマンドを実行して、 `<cluster_name>.properties`ファイルと`<cluster_name>.nodes`ファイルの両方に追加されるコメントとインラインドキュメントを活用するようになりました。 |
Enhancement |
TPAは、 bind.address`値のIPアドレスの代わりにホスト名解決を使用してEFMクラスターをセットアップできるようになりました。 これは、configureコマンドの--efm-bind-by-hostname`オプションまたはconfig.ymlのcluster_varsセクションの`efm_bind_by_hostname: true false`で呼び出すことができます。 |
Enhancement |
TPAは、EFM 4.9で追加されたEFMプロパティ`enable.stop.cluster: boolean, default true`、priority.standbys: default ''、detach.on.agent.failure: boolean, default false、`pid.dir: default ''`の設定をサポートするようになりました。 |
Enhancement |
TPAは、 pgBouncerからPostgresへの接続に`cert`認証を使用するようにpgBouncerを構成できるようになりました。これは、 cluster_varsで`pgbouncer_use_cert_authentication`をtrueに設定することにより有効にします。有効にすると、pgBouncerに接続するユーザーの認証方法も`md5`から`scram-sha-256`に変更されます。 |
Change |
TPAは、AWSでのRAID作成をサポートしなくなりました。 |
Change |
upstream_primaryを解決するためのEFM依存関係を削除しました。以前は、スイッチオーバー後の展開で、現在のプライマリのEFMが照会されていました。 EFMが実行されていない場合、これは失敗します。 Postgresを介して収集されたcluster_factsは、スイッチオーバー後の現在のプライマリを決定するために使用され、EFMへの依存関係を削除します。 |
Change |
EFMクラスターでは、スイッチオーバー後に`upstream_primary`が正しく更新されるようになりました。その結果、レプリカに正しい`auto.reconfigure`設定が設定されます。スタンバイが新しいプライマリに従うようになりました。 |
Bug Fix |
Patroni APIにアクセスするときにTPAがプロキシ設定を誤って適用する問題を修正しました。 Ansibleのデフォルトでは、プロキシが定義されている場合、それを使用します。これは、プロキシもPatroni APIへの呼び出しをインターセプトおよび中断するため、インターネットからパッケージをダウンロードするためにプロキシを必要とするエアギャップ環境のかなり一般的な場合では機能しません。 |
Bug Fix |
TPAがすべてのインスタンスで`pemserver`インスタンスにのみ適切なPEMエージェントパラメータを設定する問題を修正しました。 |
Bug Fix |
クラスターノードのターゲットとしてSLESオペレーティングシステムを使用する場合、pgd-proxyおよびpgdcliのデフォルトパッケージ名に欠落していたエントリを追加しました。 |
Bug Fix |
TPAが既存のノードでpostgresをリロード/再起動して構成変更を再読み取りすることに失敗し、したがって、新しいノードがクラスターに接続できないという問題を修正します。 |
Bug Fix |
レプリカからバックアップを取得する場合、WALファイルの待機がタイムアウトになることにより、初期バックアップの取得時にバーマンが失敗する場合がある問題を修正しました。これは、WALセグメントのスイッチを強制する前に、バーマンがベースバックアップを完了するのを待機することにより修正されます。 |
Bug Fix |
上流_プライマリpostgresにデフォルト以外のpostgresポートを使用する場合でも、`repmgr witness register`コマンドが正しいpostgres_port値で使用されていることを確認します。 |
Bug Fix |
PGDクラスター内のサブスクライバー専用ノードとそのレプリカのインスタンスレベルで設定されている場合、 `repmgr`へのfailover_managerオーバーライドが正しく機能しない問題を修正しました。 |
Bug Fix |
誤ったcgroup検出の2つのケースを修正しました。MacOSXでは、`/proc/mounts`を読み取ろうとしなくなりました。 `/sys/fs/cgroup`が`ro`であるが、その下にマウントが`rw`であるシステムでは、TPAがこれを正しく検出するようになりました。 |
Bug Fix |
pgd-proxyに新しく追加された`read_listen_port`オプションのpgd-proxyノードで実際の構成セットを検証できることを確認します。 |
Bug Fix |
PEM 9.7.0での展開を妨げる問題を修正しました。 PEM 9.7.0はパッケージレベルでApacheに依存しないため、WebサーバーとしてApacheを使用するには、パッケージを明示的にインストールします。 |