Trusted Postgres Architect 23.12 release notes#
リリース日2023年2月21日
Trusted Postgres Architect 23.12の新機能、機能強化、バグ修正、およびその他の変更には次のものが含まれます。
Type |
Description |
|---|---|
Feature |
コミットスコープに基づいたCommit At Most OnceCAMO構成サポートを含む、 EDB Postgres Distributed 5の完全なサポートを導入します。 |
Feature |
EDB Postgres拡張リポジトリとパッケージのサポートを導入します。 |
Enhancement |
<p>マルチリージョンAWSクラスターの構成の予備サポート。</p><p>マルチリージョンクラスターには、VPCとVPCの手動セットアップが必要です。 </p> |
Enhancement |
`--active-locations`のプロキシルーティングおよびそのためサブグループRAFTを自動的に有効にします。 configureオプションを削除して、サブグループRAFTをグローバルに有効にします。 |
Bug fix |
EDB_SUBSCRIPTION_TOKENがログに記録されていないことを確認します。 |
Bug fix |
ユーザーがtpa_2q_repositoriesへのproducts/default/releaseリポジトリの追加を抑制できるようにします。 |
Bug fix |
<p>利用可能な場合、ノードがbdr_child_groupをサブスクライブしていることを確認します。</p><p> 複数のサブグループを持つクラスターでは、TPAはインスタンスがトップグループとサブグループの両方のレプリケーションセットにサブスクライブされることを想定していなかったため、ノードのサブスクライブしたレプリケーションセットから後者を誤って削除します。</p> |
Bug fix |
<p>Postgresが起動しない場合、有用なエラーで確実に失敗します。 </p><p> Ansibleのバグが原因で、Postgresが一部のインスタンスで起動しないが、他のインスタンスで起動した場合、デプロイメントは失敗しませんたとえば、構成の違いのため。展開を続行すると、後で障害が発生したホストのcluster_factsにアクセスしようとすると、エラーが発生しました。 </p> |
Bug fix |
<p> BDR 4.3以降の監視では`bdr.alter_node_replication_sets()`を呼び出さないでください。</p><p>これは、監視ノードがカスタムレプリケーションセット構成で処理されないBDRバージョンの新しい制限に調整します。 </p> |
Bug fix |
ハードコードされた「barman」参照を置き換えて、barman_{user,group}設定を使用してbarmanユーザーとホームディレクトリをカスタマイズできるようにします。 |
Bug fix |
必要に応じて、 postgres_databases[*].extensionsの下で記載されている拡張機能のshared_preload_librariesエントリを追加します。 |
Bug fix |
`pgaudit`がshared_preload_librariesの`bdr`の前に表示されないことを確認します既知のクラッシュを回避するため。 |
Bug fix |
pgd-cli構成ファイルの構文エラーDSN引用符を修正します。 |
Bug fix |
<p> pgd-proxy構成のエンドポイントを並べ替えて、ファイルの書き換えを回避します。 </p> <p>これには、次の展開でpgd-proxyの再起動が必要になる可能性がありますが、その後の展開での不要な将来の書き換え/再起動が回避されます。 </p> |
Bug fix |
RHシステムにローカルリポジトリからrsyncをインストール中のエラーを修正します。 |
Bug fix |
DebianシステムでのPEM 9のApache WSGIモジュール構成のエラーを修正します。 |
Bug fix |
bdr拡張子が意図的に作成された場合、未使用であっても削除しないでください。 |
NA |