Trusted Postgres Architect 23.36.0 release notes#
リリース日2025年2月19日
Trusted Postgres Architect 23.36.0の新機能、機能強化、バグ修正、およびその他の変更には次のものが含まれます。
ハイライト#
Ubuntu 24.04およびSLES 15 SP6のサポート
すべてのクラスターコンポーネントのバージョン指定子
EDB Failover ManagerEFM 5のサポートの向上
機能強化#
Description |
Addresses |
|---|---|
すべてのクラスターコンポーネントのパッケージバージョン指定子のサポートを追加しました。次のソフトウェアパッケージは、 tpaexec configure`コマンドへの--xxx-package-version`オプションを受け入れるようになりました。これは、生成された`config.yml` - barman - pgbouncer - beacon-agent - etcd - patroni - pem-server - pem-agent - pg_backup_api - pgd_proxy - pgdcli - repmgrに`xxx_package_version`を設定します。 |
|
Ubuntu Noble 24.04のサポートを追加しました。 TPAはUbuntu 24.04で実行され、このOSをターゲットホストとしてサポートします。 Ubuntu 24.04のEDBパッケージは、2025年3月末に一般提供されます。その前に、EDBパッケージを必要とする展開は失敗する可能性があります。 |
|
EFM 5の「auto resume」プロパティのサポートを追加しました。 EFM 5.0以降、`auto.resume.period`プロパティは2つのプロパティに分割されています。1つは起動ケース用、もう1つはdb障害ケース用です。この変更により、使用されている`efm_version`に基づいて、正しいプロパティが追加されます。 |
|
EFM 5 'backup.wal'プロパティのサポートを追加しました。 EFM 5.0から、新しいプロパティbackup.walが追加されました。この変更により、EFMのバージョンが5以上の場合、新しいプロパティが追加されます。 |
|
SLES 15 SP6のサポートを追加しました。構成時にSLESが要求されると、TPAはSLES 15 SP6をインストールします。 DockerおよびEC2イメージはSP6になり、systemd-sysvcompatパッケージはSLESにインストールされるため、ローカルブート時スクリプトは引き続き機能します。 |
の変更#
Description |
Addresses |
|---|---|
RHEL同様のシステムでPGDGの最新のBarmanを使用します。 TPAは、壊れたパッケージの回避策として、RHEL同様のシステムにPGDGからインストールする場合、以前はデフォルトのBarman 3.9を使用していました。より新しいbarmanパッケージはOKであるため、yumに最新のパッケージをインストールさせます。 |
|
RedHatおよびDebianのセットアップスクリプトを介してEDBリポジトリをセットアップします。この変更により、TPAノードでのEDBリポジトリのセットアップが簡素化され、dnf、yum、および`apt`パッケージマネージャーの単一のタスクになります。これにより、EDBリポジトリをターゲットホストに追加する際の予期しないHTTPエラーの発生が減少します。 |
|
efm_conf_settings`のドキュメントを修正しました。以前、ドキュメントには*「TPAで認識されるかどうかにかかわらず、efm_conf_settingsを使用してパラメーターを設定できます。必要に応じて、efm.propertiesに表示されるとおりに値を正確に引用する必要があります。ただし、 `efm.properties.j2`テンプレートは次の値を使用します`efm_conf_settings`からAnsible辞書として変換するため、エントリは`key: value`フォームで記述する必要があります。 `yaml cluster_vars: efm_conf_settings: notification.level: WARNING ping.server.ip: <well known address in the network> |
|
Pythonの依存関係をバージョン3.12にバンプします。 TPAではPython 3.12が必要になりました。 EDB Repos 2.0からTPAをインストールすると、適切なPythonインタープリターが自動的にインストールされます。 |
|
PGDのアップグレード中にプロトコルバージョンの更新を待ちます。 PGD3からPGD5へのアップグレード中に、プロトコルバージョンの更新に時間がかかる場合があります。 PGD 5特定の構成変更は、プロトコルバージョンが変更される前に試行されると失敗します。このような障害を回避するために待機を追加しました。 |
|
新しいノードが既存のEFMクラスターに追加されるときに、 <clustername>.nodes`を更新します。 TPAの以前のバージョンでは、新しいEFMノードが`config.yml`に追加されると、クラスター内の既存のEFMノードの`Allowed node host list`にリストされませんでした。 `efm upgrade-conf`を実行し、/raw/<clustername>.properties`および`/raw/<clustername>.nodes`から変更を伝播するタスクは、これらのファイルのいずれかが変更されたときに実行されるようになりました。これにより、新しいEFMノードが`<clustername>.nodes`ファイルに書き込まれ、`efm cluster-status`が`Allowed node host list`に含めます。 |
|
postgresユーザーの`.bashrc`ファイルに`PGPORT`を含めます。 PGPORT`環境変数は、postgresユーザーの.bashrc`ファイルの一部としてエクスポートされます。選択した`postgres_flavour`、または構成ファイルで指定されている場合は`postgres_port`が使用するポート値がデフォルトになります。 |
バグ修正#
Description |
Addresses |
|---|---|
データベースが構成どおりではなくデフォルトのパラメーターで作成される問題を修正しました。 TPAの以前のバージョンでは、それを必要としない拡張機能別名「モジュール」の`CREATE EXTENSION`ステートメントを抑制するために、postgres_databases`ハッシュ全体が変更されました。これは、データベース`name`と`extensions`のリストのみを含む新しいハッシュが作成され、データベースの他のすべての構成設定を無視するためバグが発生しました `owner、template、`encoding`など。これにより、データベースは構成どおりではなくデフォルトのパラメーターで作成されることになりました。これを修正するには、拡張機能のリストからモジュールが削除され、結果のリストがCREATE EXTENSIONを実行するタスクに渡されます。 |
44539 |
Patroniクラスターでの`shared_preload_libraries`の問題を修正しました。 shared_preloadライブラリのエントリがPatroniによって正しく処理されるようになりました。これにより、`config.yml`を介してpglogical拡張機能をPatroniクラスターに追加すると失敗するバグが修正されます。 |
|
拡張機能用の追加のリポジトリセットアップコマンドがないディストリビューションの展開が失敗するバグを修正しました。 TPAの以前のバージョンでは、`postgis`が`postgres_databases`のデータベースの`extra_postgres_extensions`または`extensions`リストに追加されると、`repository_setup_commands`のリストが空であったため、Debian、SLES、およびUbuntuでの展開は失敗していました。RHELのみがrun`crb enable`への追加コマンドを持っています。この空のリストは`command`モジュールに渡され、`no command given`で失敗し、展開が失敗しました。ディストリビューションに実行する追加コマンドがない場合、 `Automatically run additional repository setup commands for recognized extensions`タスクがスキップされるようになりました。 |
|
`repmgr_use_slot`が0に設定されている場合でも、TPAがレプリケーションスロットを作成しようとした問題を修正しました |
41776 |
`pgd_proxy_dsn_attributes`および`pgd_cli_dsn_attributes`のデフォルトとして`bdr_client_dsn_attributes`を設定します。 pgd-proxyおよびpgd-cliはGoで書かれ、Goドライバーを使用するため、libpqがサポートするパラメーターキーワードの完全なセットをサポートしていません。クラスターがpgd-proxyおよび/またはpgd-cliをインストールし、Goドライバーがサポートしていないパラメーターで`bdr_client_dsn_attributes`を構成している場合、2つの新しい構成変数`pgd_proxy_dsn_attributes`および`pgd_cli_dsn_attributes`を含める必要があります。 Goドライバーがサポートしています。逆に、 pgd-proxyおよびpgd-cliがインストールされ、`bdr_client_dsn_attributes`がGo非互換のパラメーターを含まない場合、これらのツールの接続文字列は`bdr_client_dsn_attributes`の属性で構成されます。これにより、ユーザーが`bdr_client_dsn_attributes`のパラメーターが使用されることを想定していても、 `pgd_proxy_dsn_attributes`および`pgd_cli_dsn_attributes`が定義されていない場合に空の文字列がデフォルトであった予期せぬ動作が修正されました。 |
44819 |
etcdのホームディレクトリの標準形式を使用します。 etcdユーザーを作成するときに、TPAは後続のスラッシュなしでホームディレクトリを参照するようになりました、 'useradd'のような他のツールの使用法と一致します。 |
|
cluster_ssh_port`設定がBarmanによって尊重されない問題を修正しました。 Barman構成は、`config.yml`の`cluster_ssh_port`を介して設定されたカスタムsshポートを使用できるようになりました。設定されていない場合はデフォルトの22です。 `-p / --port`フラグは、それぞれ`barman.d.conf`および`barman-wal-restore/`barman-wal-archive'コマンドの`ssh`コマンドに含まれるようになりました。 |