Modifying agent configuration#

多数の構成可能なパラメーターがPEMエージェントの動作を制御します。 Linuxでは、これらは構成ファイルに保存されます。 Windowsでは、これらはレジストリキーとして保存されます。

エージェント構成のほとんどは自動的に管理されます。特に指示されない限り、これらの構成パラメーターを手動で変更しないことをお勧めします。

注釈

パラメーターを追加、削除、または変更した場合、エージェントを再起動して変更を適用する必要があります。

構成ファイルの内容#

Linuxシステムでは、PEM構成オプションは/usr/edb/pem/agent/etc にあるagent.cfg ファイルに保存されます。 agent.cfg ファイルには、次の表に示すエントリが含まれています。

Parameter name

Description

Default value

pem_host

PEMサーバーのIPアドレスまたはホスト名。 Query information を使用している場合、これはIPまたはホスト名のコンマ区切りリストです。構文の詳細については、 libpq documentation を参照してください。

127.0.0.1.

pem_port

エージェントがPEMサーバーと通信するために接続するデータベースサーバポート。 Query information を使用している場合、これはポートのコンマ区切りリストです。構文の詳細については、 libpq documentation を参照してください。

Port 5432.

pem_agent

PEMエージェントに割り当てられる一意の識別子。

The first agent is '1', the second agent is '2', and so on.

agent_ssl_key

PEMエージェントのキーファイルへの完全なパス。

/root/.pem/agent.key

agent_ssl_crt

PEMエージェントの証明書ファイルへの完全なパス。

/root/.pem/agent.crt

agent_flag_dir

HAサポートに使用されます。別のサーバーの監視を引き継ぐ要求についてチェックされるディレクトリパスを指定します。要求は、指定されたフラグディレクトリにファイルの形式で作成されます。

Not set by default.

log_level

PEMログファイルに書き込むイベントのタイプを`debug2`、debug1、info、warning、`error`のいずれか指定します。これらはロギングの詳細度の降順です。 `debug2`は可能なすべてをログに記録し、`error`はエラーのみをログに記録します。

warning

log_location

PEMワーカーログファイルの場所を指定します。

/var/log/pem/worker.log

agent_log_location

PEMエージェントログファイルの場所を指定します。

/var/log/pem/agent.log

long_wait

最初の接続試行が失敗した場合に、PEMサーバーに接続しようとする前にPEMエージェントが待機する最大時間秒単位。

30 seconds

short_wait

キューで次に実行を待機しているプローブを確認するまでにPEMエージェントが待機する最小時間秒単位。

10 seconds

alert_threads

エージェントによって生成されるアラートスレッドの数。詳細については、 アラートスレッドについて を参照してください。

Set to 1 for the agent that resides on the host of the PEM server, 0 for all other agents.

enable_smtp

trueに設定されている場合、このエージェントはPEM Webアプリケーションで構成されたとおりにメール通知を送信しようとします。

true for PEM server host, false for all others.

enable_snmp

trueに設定されている場合、このエージェントはPEM Webアプリケーションで構成されたとおりにSNMP通知を送信しようとします。

true for PEM server host, false for all others.

enable_nagios

trueに設定すると、Nagiosアラートが有効になります。

true for PEM server host, false for all others.

enable_webhook

trueに設定すると、Webhookアラートが有効になります。

true for PEM server host, false for all others.

max_webhook_retries

失敗した場合にPEMエージェントがWebhookへの呼び出しを再試行する最大回数を設定するために使用されます。

Default 3.

connect_timeout

エージェントが接続を待機する秒単位の最大時間10進整数文字列。

Not set by default. Set to 0 to indicate for the agent to wait indefinitely.

allow_server_restart

TRUEに設定されている場合、エージェントは監視対象のデータベースサーバーを再起動できます。このパラメーターの値に応じて、一部のPEM機能が有効/無効になる場合があります。

False

max_connections

接続スロットラーが使用するプローブ接続の最大数。

0 (an unlimited number)

connection_lifetime

ConnectionLifetimeまたはconnection_lifetimeを使用して、開いているがアイドル状態の接続が保持される最小秒数を指定します。 MaxConnectionsで指定された値に到達し、待機中の要求を満たすために別のデータベースへの新しい接続が必要な場合、このパラメーターは無視されます。

By default, set to 0 (a connection is dropped when the connection is idle after the agent's processing loop).

allow_batch_probes

TRUEに設定されている場合、ユーザーはカスタムプローブ機能を使用してバッチプローブを作成できます。

false

heartbeat_connection

TRUEに設定すると、ハートビートの送信に専用接続が使用されます。 TRUEに設定している場合、`max_connections`パラメーターを1より大きい値に設定する必要があります。

false

batch_script_dir

スクリプトファイルアラート用が保存されるパスを提供します。

/tmp

connection_custom_setup

監視対象サーバーとの新しい接続が作成されたときに呼び出されるSQLコードを提供するために使用されます。

Not set by default.

ca_file

Webhookサーバー証明書を検証するためにプラットフォームのデフォルトの代わりに使用するCA証明書へのパス。 Webhookを定義するときに`--webhook_ssl_ca_crt`オプションでこの値をオーバーライドできます。

Not set by default.

batch_script_user

バッチ/シェルスクリプトの実行に使用するユーザーの名前。

None

alert_reconnect_delay

秒単位の時間。アラートスレッドは、PEMサーバーに接続した後、アラートの評価を開始する前にこの時間待機します。これは、サーバーがエージェントからハートビートを受信する機会がある前に評価されるアラートによって発生する誤ったアラームを防ぐのに役立ちます。

30

Webhook parameters

次のオプションは複数回指定できます。毎回、オプションの前に`[WEBHOOK/<name>]`フォームのヘッダーを配置します。`<name>`は、以前に作成したWebhookの名前です。これらの設定は、Webhookの作成時に自動的に追加されます。手動で追加することはお勧めしません。

webhook_ssl_key

WebhookのSSLクライアントキーファイルへの完全なパス。

webhook_ssl_crt

WebhookのSSLクライアント証明書ファイルへの完全なパス。

webhook_ssl_crl

Webhookサーバー証明書を検証するためのCRLファイルの完全なパス。

webhook_ssl_ca_crt

WebhookのSSL ca証明書ファイルへの完全なパス。

allow_insecure_webhooks

trueに設定されている場合、Webhookが安全でないフラグを使用して呼び出すことを許可します。

false

レジストリの内容#

Windowsシステムでは、PEMレジストリエントリは次の場所にあります。

HKEY_LOCAL_MACHINE\Software\EnterpriseDB\PEM\agent

レジストリには、次の表に示すエントリが含まれています。

Parameter name

Description

Default value

PEM_HOST

PEMサーバーのIPアドレスまたはホスト名。

127.0.0.1.

PEM_PORT

エージェントがPEMサーバーと通信するために接続するデータベースサーバポート。

Port 5432.

AgentID

PEMエージェントに割り当てられる一意の識別子。

The first agent is '1', the second agent is '2', and so on.

AgentKeyPath

PEMエージェントのキーファイルへの完全なパス。

%APPDATA%\Roaming\pem\ agent.key.

AgentCrtPath

PEMエージェントの証明書ファイルへの完全なパス。

%APPDATA%\Roaming\pem\ agent.crt

AgentFlagDir

HAサポートに使用されます。別のサーバーの監視を引き継ぐ要求についてチェックされるディレクトリパスを指定します。要求は、指定されたフラグディレクトリにファイルの形式で作成されます。

Not set by default.

LogLevel

PEMログファイルに書き込むイベントの種類を指定します。これらはロギングの詳細度の降順です。 `debug2`は考えられるすべてのログを記録し、 `error`はエラーのみをログに記録します。

warning

LongWait

最初の接続試行が失敗した場合に、PEMサーバーに接続を試行する前にPEMエージェントが待機する最大時間秒単位。

30 seconds

shortWait

どのプローブが次にキューにある実行待機中かを確認するまでにPEMエージェントが待機する秒単位の最小時間。

10 seconds

AlertThreads

エージェントが生成するアラートスレッドの数。詳細については、 アラートスレッドについて を参照してください。

Set to 1 for the agent that resides on the host of the PEM server, 0 for all other agents.

EnableSMTP

trueに設定すると、SMTPメール機能が有効になります。

true for PEM server host, false for all others.

EnableSNMP

trueに設定すると、SNMPトラップ機能が有効になります。

true for PEM server host, false for all others.

EnableWebhook

trueに設定すると、Webhookアラートが有効になります。

true for PEM server host, false for all others.

MaxWebhookRetries

失敗した場合にPEMエージェントがWebhookへの呼び出しを再試行する最大回数を設定します。

Default 3.

ConnectTimeout

エージェントが接続を待機する秒単位の最大時間10進整数文字列。

Not set by default. If set to 0, the agent waits indefinitely.

AllowServerRestart

TRUEに設定されている場合、エージェントは監視対象のデータベースサーバーを再起動できます。このパラメーターの値に応じて、一部のPEM機能が有効/無効になる場合があります。

true

MaxConnections

接続スロットラーが使用するプローブ接続の最大数。

0 (an unlimited number)

ConnectionLifetime

ConnectionLifetimeまたはconnection_lifetimeを使用して、開いているがアイドル状態の接続が保持される最小秒数を指定します。 MaxConnectionsで指定された値に到達し、待機中の要求を満たすために別のデータベースへの新しい接続が必要な場合、このパラメーターは無視されます。

By default, set to 0 (a connection is dropped when the connection is idle after the agent's processing loop).

AllowBatchProbes

TRUEに設定されている場合、ユーザーはカスタムプローブ機能を使用してバッチプローブを作成できます。

false

HeartbeatConnection

TRUEに設定すると、ハートビートの送信に専用接続が使用されます。

false

BatchScriptDir

アラート用のスクリプトファイルを保存するパス。

/tmp

ConnectionCustomSetup

監視対象サーバーとの新しい接続が作成されたときに呼び出されるSQLコードを提供するために使用されます。

Not set by default.

AllowBatchJobSteps

trueに設定されている場合、バッチ/シェルスクリプトが実行されます。スクリプトは、PEMエージェントが実行されているユーザーアカウントによって実行されます。

None

AlertReconnectDelay

秒単位の時間。アラートスレッドは、PEMサーバーに接続した後、アラートの評価を開始する前にこの時間待機します。これは、サーバーがエージェントからハートビートを受信する機会がある前に評価されるアラートによって発生する誤ったアラームを防ぐのに役立ちます。

30

Webhook parameters

次のオプションは複数回指定できます。これらはサブキー`SoftwareEnterpriseDBPEMagentWEBHOOK<name>`に配置する必要があります。`<name>`は、以前に作成したWebhookの名前です。これらの設定は、Webhookの作成時に自動的に追加されます。手動で追加することはお勧めしません。

WebhookSSLKey

WebhookのSSLクライアントキーファイルへの完全なパス。

WebhookSSLCrt

WebhookのSSLクライアント証明書ファイルへの完全なパス。

WebhookSSLCrl

Webhookサーバー証明書を検証するためのCRLファイルの完全なパス。

WebhookSSLCaCrt

WebhookのSSL ca証明書ファイルへの完全なパス。

AllowInsecureWebhooks

trueに設定されている場合、Webhookが安全でないフラグを使用して呼び出すことを許可します。

false

アラートスレッドについて#

エージェントによって生成されたアラートスレッドの数は、 alert_threads またはAlertThreads パラメーターによって決まります。通常、PEMサーバーにあるエージェントではこのパラメーターを1に設定し、他のすべてのエージェントは0に設定することをお勧めします。ただし、非常に多数のアラートを持つPEMサーバーインスタンスでは、多くの監視対象サーバー、多くの有効なアラート、または高いアラート頻度が原因で、構成された頻度でアラートが評価されていない場合、このパラメーターを増やす必要がある場合があります。この状況では、PEMサーバーにあるエージェントでこのパラメーターを約8に設定し、他のすべてのエージェントで0を設定し、それに応じてチューニングアップまたはダウンすることをお勧めします。

このパラメーターを調整するときは、すべてのエージェントが任意のアラートを処理できることに注意してください。一般に、複数のエージェントでゼロ以外の数のアラートスレッドを使用する必要はありません。アラートを処理するPEMインスタンスの容量は、すべてのエージェントのアラートスレッドの合計数によって決まります。特定のエージェントのスレッド数を増やしても、そのエージェントによって監視されているサーバーに関連するアラートのパフォーマンスは追加されません。

各アラートスレッドはPEMサーバーバックエンドへの接続を開くため、必要以上に多くのスレッドを割り当てると、PEMサーバーのメモリとCPUの使用量が追加されます。