Trusted Postgres Architect 23.1 to 23.11 release notes

TPA 23.11

リリース:2023-01-31 ###重要な変更

  • TPA-180 PGD-Always-ONアーキテクチャの実験的なサポートを導入(今年後半にリリース予定)。 PGD-Always-ONアーキテクチャは、今後のBDRバージョン5を使用します。初期サポートは内部目的で追加され、今後のリリースで改善される予定です。 ###マイナーな変更

  • TPA-349依存関係のバージョンをバンプ 暗号化バージョンを38.0.4から39.0.0にバンプ jqバージョンを1.3.0から1.4.0にバンプ

  • TPA-345ドキュメント内のTPAexec参照をTPAに変更。製品を参照する際に、「TPAexec」の代わりに「TPA」を使用するようにドキュメントを更新します。

TPA 23.10

リリース:2023-01-04 ###マイナーな変更

  • TPA-161 harp_manager_restart_on_failure 設定(デフォルトはfalse)を導入して、harp-manager systemdサービスの障害時のプロセス再起動を有効にします ### バグ修正

  • TPA-281 AWSクラスターのプロビジョニングを解除するときにFMSセキュリティグループを削除します 削除されていない依存関係が原因でクラスターのVPCのプロビジョニングを解除できない問題を修正します。

  • TPA-305 Towerの事前生成されたシークレットにenterprisedb_passwordを追加

  • TPA-306 PEM_PYTHON_EXECUTABLEを優先します、存在する場合、/usr/bin/python3 PEM 9.0での展開中のPythonモジュールインポートエラーを修正します。

  • TPA-219 BDRインスタンスでpem-agentがデフォルトでbdr_databaseを監視するようにします

TPA 23.9

リリース:2022-12-12 ### バグ修正

  • TPA-301 Towerクラスターのcluster_dirの自動検出を修正Towerプロジェクトディレクトリに基づいてcluster_dirを設定する場合、デプロイされているインスタンスではなく、コントローラー上のディレクトリの存在を正しくチェックするようになりました。

  • TPA-283 Ansible Towerに必要なpsutilへの依存関係を追加します。

  • TPA-278 rsyslog構成から「umask 0」ディレクティブを削除します。以前は、 rsyslogd.pid などの誰でも読み取り可能なファイルが作成されました。

  • TPA-291 Barmanインスタンスでpg_receivewalを取得するためにPostgresサーバーパッケージをインストールするときにpostgres_package_version設定を尊重します。

TPA 23.8

リリース:2022-11-30 ###主な変更

  • TPA-18サポートAnsible Tower 3.8このリリースは、Ansible Tower 3.8を介してbare クラスター(既存のサーバーを使用)でのdeploy.yml (のみ)の実行をサポートします。 TowerサーバーにTPAexecをインストールし、 tpaexec setup を実行して仮想環境を作成します。Towerテンプレートで使用してTPAexec Playbookを実行できます。 --use-ansible-tower および--tower-git-repository 構成オプションを使用して、Tower互換のクラスター構成を生成します。詳細については、 Ansible Tower を参照してください。 ###マイナーな変更

  • TPA-238クラスターディレクトリをgitリポジトリとして初期化する TPAexecを実行するシステムでgitが利用可能な場合、tpaexec configure はデフォルトでクラスターディレクトリ内のgitリポジトリを初期化します。 gitが利用できない場合、以前と同じように続行されます。リポジトリの作成を回避するには(たとえば、既存のリポジトリ内にクラスターディレクトリを保存する場合)、 --no-git オプションを使用します。

TPA 23.7

リリース:2022-11-09 ###重要な変更

  • TPA-234 Ansible 2.9のコミュニティリリースをサポート TPAexecは、Ansible 2.9の2ndQuadrant / ansibleフォークを必要としていました。このリリースでは、代わりにtpaexec setup --use-community-ansible でAnsibleのコミュニティリリースを使用することを選択できます。今のところ、デフォルトは引き続き 2ndQuadrant/ansible を使用します。これは将来のリリースで変更されます。 2ndQuadrant/ansibleのサポートは終了し、Ansibleが新しいデフォルトになります。 ###マイナーな変更

  • TPA-209 Postgres 15のリリース後、--postgres-version 15 を有効なtpaexec configure オプションとして受け入れます

  • TPA-226 --hostnames-from ファイルでIPアドレスを受け入れます 以前は、 tpaexec configure に渡されるファイルには、1行に1つのホスト名が含まれる必要がありました。各ホスト名の後にオプションのIPアドレスを含めることもできます。存在する場合、このアドレスはconfig.ymlの対応するインスタンスのip_address として設定されます。 (独自の--hostnames-from ファイルを指定すると、ホスト名はデフォルトでランダム化されなくなります。)

  • TPA-231 新しいbdr-pre-group-joinフックを追加します このフックは、各ノードがBDRノードグループに参加する前に実行されます。 TPAexecが提供するデフォルトのレプリケーションセット構成を変更するために使用される場合があります。

  • TPA-130 community.postgresqlのpostgresql_userモジュールを使用します SCRAMパスワードを使用するときにタスクのステータスを正しく報告するには、community.postgresqlコレクションの更新されたモジュールが必要です(デフォルトのモジュールは常にchanged を報告します)。

  • TPA-250さまざまなPython依存関係の最新バージョンへのアップグレード ### バグ修正

  • TPA-220 .bashrcのLD_LIBRARY_PATHが「:」で始まらないことを確認する

  • TPA-82 BDR-internal ${group_name}_extレプリケーションセットの削除を避ける

  • TPA-247 AWSでの「 ‘str object’ has no attribute ‘node_dsn’」エラーを修正しました コードはhostvars[hostname] を中間変数に割り当てなくなり、後で通常のdictのように動作することを想定しています(これは時々のみ動作します)。これにより、PEMが有効になっているAWSクラスターで報告された23.6でのリグレッションが修正されますが、コードベース全体で他の同様のエラーも修正されます。

  • TPA-232「リンク中にエラーが発生しました:[Errno 17]ファイルが存在します」エラーが発生した、インベントリ内の生成されたシークレットへのシンボリックリンクを作成する際の競合状態を解消します

  • TPA-252すべてのBDRノードがwitness-onlyレプリケーションセットにパブリッシュするコードを復元する このコードブロックは、TPA-193のために行われたリファクタリング作業の一部として、v23.6リリースで誤って削除されました。

TPA 23.6

リリース:2022-09-28 ###重要な変更

  • TPA-21 AWSデプロイメントに(メンテナンスされていないboto2の代わりに)boto3 AWSクライアントライブラリを使用します。これにより、SSOログインやその他の便利な機能が有効になります。

  • TPA-202 harp-configフックを追加。この展開時フックは、 HARPがインストールおよび構成された後、 HARPがインストールされているすべてのノードで開始される前に実行されます。 ### バグ修正

  • TPA-181 RHEL 7でデフォルトのpythonバージョンを2に設定します。以前は、tpaexecはRHEL 7とpython 3のサポートされていない組み合わせでconfig.ymlを生成できました。

  • TPA-210既存のセキュリティグループを使用したawsデプロイメントを修正。このようなデプロイは、プロビジョニング時に失敗していましたが、期待どおりに動作するようになりました。

  • TPA-189 デプロビジョニング時にgroup_varsディレクトリを削除します。これにより、ダングリングシンボリックリンクが原因で後続のプロビジョニングが失敗する問題が修正されます。

  • TPA-175共有メモリセグメントをそのままにするようにsystemdを正しく構成します。これはソースビルドにのみ影響します。

  • TPA-160 haproxyとPEMのバージョン設定を許可します。これにより、特定のバージョンが指定されていてもパッケージの最新バージョンがインストールされるバグが修正されます。

  • TPA-172 EFMを正しいホストセットにインストールします。 EFMは、クラスターのメンバーであるpostgresサーバーにのみインストールする必要があります。PEMサーバーなど、他の理由でpostgresがインストールされているサーバーにはインストールしないでください。

  • TPA-113 PEMエージェント登録をシリアル化します。これにより、複数のホストが pemworker –register-agent を同時に実行しようとした場合の競合状態を回避できます。

TPA 23.5

リリース:2022-08-23 ###重要な変更

  • TPA-81 Ubuntu 22.04 Jammy用のtpaexecおよびtpaexec-depsパッケージを公開

  • TPA-26単一ノードでのharp-proxyおよびharp-managerのインストールをサポートします。 harp-proxyとharp-managerサービスの両方をクラスター内の同じターゲットノードで実行できるようになりました。

TPA 23.4

リリース:2022-08-03 ### バグ修正

  • TPA-152は、AWSホストでのDebianインスタンスの最初のブート時のロケール検出の問題を修正します。最初のブートを完了できません。これは、SSHキーネゴシエーションの問題と、デプロイ中にディスクが見つからないエラーとして現れます。この問題は23.3で導入され、TPA-38に関連しています

TPA 23.3

リリース:2022-08-03 ###重要な変更

  • TPA-118 harp-manager構成の2つの新しいオプションを公開しました。最初のものはHARP harp_db_request_timeout をdcs request_timeoutと同様に設定しますが、データベース接続用で、2番目のharp_ssl_password_command は難読化を解除するコマンドを指定します

  • TPA-117 tpaexec config.ymlのpackage_version オプションでのワイルドカードの使用に関するドキュメントの更新を追加します。これにより、 deploy 操作中に予期しないパッケージのアップグレードが発生する可能性があるという警告が導入されました。詳細については、tpaexec-configure.md のドキュメントを参照してください

  • TPA-38 Debianのすべてのバージョン、およびRHEL 8以降のロケールファイルを追加します。 Barmanなどの一部のEDBソフトウェアには、ユーザーロケールを en_US.UTF-8 に設定する要件があります。一部のユーザーは、ロケール、文字セット、または言語をローカル地域に変更することもできます。この変更により、libcが提供するOSファイルが、ユーザーデータスクリプトを使用してファーストブート中にAWSインスタンスにインストールされるようになります。デフォルトのロケールはen_US.UTF-8 です。詳細については、platform_aws.md ドキュメントを参照してください

  • TPA-23 クラスターサービスBarman、 HARP、 repmgr 、 PgBouncer 、およびEFMのsyslogのログ設定を追加します。指定されたログサーバーは、これらのサービスの/var/log/hosts ディレクトリに受信したログファイルを保存します

  • TPA-109 BDRの特定のバージョンに基づいたロックタイムアウト構文の選択に関するpgbenchロールのコードのマイナーリファクタリング ### バグ修正

  • TPA-147ソースインストール方法を使用するクラスターで、DebianおよびRocky Linuxのいくつかの不足しているパッケージが観察されました。 Debianは、krb5およびlz4のライブラリヘッダーを受け取ります。 RedHat派生OSでは、「Development Tools」パッケージグループの必須パッケージとlibcurlヘッダーが追加されました

  • TPA-146 Postgres 9.6をインストールするクラスターのパッケージ選択方法の小さな修正

  • TPA-138 local-repo構成オプションを有効にする「ベア」プラットフォームを使用するクラスター上の警告メッセージに対処します。 OSはベアプラットフォームのTPAexecによって管理されないため、ローカルリポジトリ構造を作成するようにユーザーに通知する必要があります。これにより、以前は未処理のエラーが発生し、構成の進行が停止しました

  • TPA-135 “docker”プラットフォームおよびRocky Linuxイメージで--use-local-repo-only を使用する場合、ノード上の既存のyumリポジトリー構成の初期削除は、コマンドfind およびxargs が欠落しているために失敗しました。この変更により、 findutils パッケージがソースリポジトリに存在する場合、最初にインストールされるようになります

  • TPA-111 --enable-pem オプションが指定されている場合、PEMサーバーにエージェントを登録するために使用されるコマンドの冗長な追加引数を削除します。以前は、これにより問題は発生しませんでした。現在削除されている最初の引数は2番目の引数によってオーバーライドされるためです。

  • TPA-108 Postgresがソースからインストールされている場合、postmasterシンボリックリンクのSELinuxファイルコンテキストを復元します。以前は、ソースからpostgresをインストールしているSELinux対応OSを使用するクラスターは、systemdデーモンがPostgresデータbinディレクトリに保存されているシンボリックリンクを読み取れないため、Postgresの再起動に失敗しました。これは、AWSで最近採用された、SELinuxが有効でデフォルトでenforcingモードのRocky Linuxイメージを使用したテストで発見されました

TPA 23.2

リリース:2022-07-13 ###重要な変更

  • BarmanおよびPEMで使用するPostgres Backup APIのサポートを追加します。 --enable-pg-backup-api オプションを介してアクセス可能。

  • Postgres Backup APIプロキシサービスのサーバー証明書など、サービスごとにSSL証明書を作成できるようになりました。証明書は/etc/tpa/<service>/<hostname>.cert に配置されますこれらの証明書は、クラスター用に生成されたCA証明書で署名することもできます。

BDRのEtcdの配置-Always-ONアーキテクチャ’harp_consensus_protocol:etcd’を使用する場合、次の各インスタンスのロールに’etcd’を明示的に追加します。 BDRプライマリ( ‘bdr’ロール) BDRロジカルスタンバイ(’bdr’+’readonly’ロール) ブロンズレイアウトの場合のみ: BDR Witness( ’bdr’ + ’witness’ロール) *ゴールドレイアウトの場合のみ: Barman ( ’barman’ロール) クレジット: Gianni Ciolli gianni.ciolli@enterprisedb .com ### マイナーな変更

  • configure引数--2q を--pgextended に置き換えて、製品ブランドの変更を反映します。既存の構成は期待される動作を維持します。

  • Debian古い安定版に付属するバージョン18のdockerを使用する場合のDockerプラットフォームの互換性チェックに関するエラー報告を改善します。

  • CLIヘルプドキュメントに欠落しているコマンドをいくつか追加。

  • configureコマンドのエラー報告を改善。

  • BDR 5をソースからビルドするための初期サポートを追加。クレジット: Florin Irion florin.irion@enterprisedb.com

  • Postgresの古いバージョンからEDB製品への移行に関する継続的な互換性を確保するための変更。 ### バグ修正

  • download-packagesコマンドを使用してローカルリポジトリにデータを入力すると、etcdのパッケージが見つからない問題を修正しました。

  • efmフェールオーバーマネージャーの使用とそのパッケージ依存関係の選択に影響を与える問題を修正

TPA 23.1

リリース:2022-06-21

このリリースでは、アップグレード後にtpaexec setup を実行する必要があります(そうしないとエラーで失敗します)

パッケージのインストール動作の変更

以前のバージョンでは、正確なバージョンが明示的に指定されていない限り(たとえば、 postgres_package_versionを設定することにより)、 tpaexec deploy を実行すると、インストールされているパッケージを潜在的にアップグレードできました。ただし、これは安全、サポート、または推奨されるアップグレード方法ではありませんでした。特に、展開中のパッケージのアップグレード後、サービスが安全かつ正しく再起動されていない可能性があります。

このリリース以降、 tpaexec deploy はインストールされたパッケージをアップグレードしません。最初の展開では、必要なすべてのパッケージ(設定されている場合は特定のバージョン、または利用可能な最新のパッケージ)をインストールし、後続の実行ではパッケージがインストールされ、それ以上何も行いません。これは、予測可能で安全な新しいデフォルトの動作です。

コンポーネントを更新する必要がある場合は、 tpaexec update-postgres を使用してください。このリリースでは、コマンドは、 BDRやpglogicalなどのPostgresおよびPostgres関連のパッケージ、およびHARP、 pgbouncer 、 etcd (特定のクラスターに該当する場合)などの他の特定のコンポーネントを更新できます。将来のリリースでは、より多くのコンポーネントのアップグレードを安全にサポートします。

重要な変更

  • HARPブートストラップ構成が変更された場合にのみ「harpctl apply」を実行します将来の展開で

  • tpaexec download-packages コマンドを追加して、クラスターに必要なすべてのパッケージをlocal-repoディレクトリにダウンロードし、エアギャップ/切断環境のクラスターインスタンスにコピーできるようにします。詳細については、 air-gapped.md および local-repo.md を参照してください。

  • 新しいBDRには--harp-consensus-protocol <etcd|bdr> 構成オプションが必要です-Always-ONクラスター TPAexecはここでデフォルト値を提供しなくなりました位置を使用して、特定のクラスターに最適なプロトコルを選択します。これは、新しく生成されたクラスターの構成に影響しますが、 harp_consensus_protocolを明示的に設定せずにetcd の以前のデフォルトを使用する既存のクラスターには影響しません ### マイナーな変更

*古いバージョンが利用できないディストリビューションでEFM用にopenjdk-8の代わりにopenjdk-11をインストールします

  • harp_log_level 設定(例、cluster_varsの下)を受け入れて、デフォルトのharp-managerおよびharp-proxyログレベル(情報)をオーバーライドします

  • 復元力を向上させるために、個々のエンドポイントDSNのリストではなく単一のマルチホストBDR DCSエンドポイントDSNを使用するようにharp-proxyを構成します

BDRのローカル(Unixソケット)DSNから余分な接続属性(例、ssl )を省略 harp-managerのDCS ### バグ修正

*構成が変更された場合、harp-managerとharp-proxyが再起動されることを確認します

  • 読み取り専用のharp_dcs_userに必要な追加の(新しい)権限を付与することにより、harp-proxyエラーを修正します

  • CAMOが有効になっているときにBDR4トランザクションストリーミングを無効にする bdr.enable_camoが設定されている場合、bdr.default_streaming_modeを無効にする必要があります。これは、 BDR4のCAMOで保護されたトランザクションと互換性がありません。これにより、 CAMO対応のBDR4クラスターでサーバーが再起動します(とにかくストリーミングが有効になっていると動作しませんでした)。