Trusted Postgres Architect 23.19 release notes¶
Trusted Postgres Architect 23.19の新機能、機能強化、バグ修正、およびその他の変更には以下が含まれます。
Type |
Description |
|---|---|
New feature |
TPAでは、加入者専用のPGDノードの物理レプリカを作成できるようになりました。 |
New feature |
TPAで、HTTP(S) HARPおよびPGDプロキシ正常性プローブの構成がサポートされるようになりました。 |
New feature |
TPAでは、M1アーキテクチャのフェールオーバーマネージャーとしてPatroniを選択できるようになりました。このサポートは実験的であり、実稼働での使用はまだお勧めできません。 |
Enhancement |
TPAでは、常に最新バージョンを使用するのではなく、 edb-pgd-proxyおよびedb-bdr-utilitiesの特定のバージョンを設定できるようになりました。 |
Change |
Debianライクなシステムでは、パッケージ選択コードが特定のパッケージに-dbgsymではなく-dbgを使用するようになりました。 |
Change |
レプリケーションスロットを構成するときに、TPAは、primary_slot_nameで有効な文字のみが使用されることを保証します。以前は、TPAはハイフンを含む可能性があるデフォルトとしてinventory_hostnameを使用していました。これらは現在、アンダースコアに置き換えられています。 |
Change |
デフォルトのフェールオーバーマネージャーバージョンは現在4.7です。 |
Bug fix |
TPA 23.18でPGD 3.7から4へのアップグレードが失敗する問題を修正しました。 |
Bug fix |
PEMを展開するときにTPAがTLS証明書のコモンネームにアンダースコアを含める問題を修正しました。これは無効であり、一部のプラットフォームでは失敗します。 |
Bug fix |
Debianライクなプラットフォームで誤ったetcdサービス名が使用され、TPAがetcdを起動できない問題を修正しました。 |
Bug fix |
TPAがRHEL 8にetcdパッケージをインストールできない問題を修正しました。 |
Bug fix |
configure中に`Failed to commit files to git: b''`メッセージが表示される問題を修正しました。 |
Bug fix |
`generate_password: false`のときにTPAがPostgresユーザーパスワードを誤って生成して上書きする問題を修正しました。 |
Bug fix |
eu-west-1以外のリージョンを使用している場合、AWSでのボリュームマップ作成がリージョンを考慮せずに失敗する問題を修正しました。 |