Trusted Postgres Architect 23.12 release notes¶
Trusted Postgres Architect 23.12の新機能、機能強化、バグ修正、およびその他の変更には以下が含まれます。
Type |
Description |
|---|---|
Feature |
コミットスコープに基づいたCommit At Most Once (CAMO )構成サポートを含む、 EDB Postgres Distributed 5の完全なサポートを導入します。 |
Feature |
EDB Postgres Extendedリポジトリとパッケージのサポートを紹介します。 |
Enhancement |
<p>マルチリージョンAWSクラスター構成の暫定サポート。</p><p>マルチリージョンクラスターでは、VPCとVPCを手動でセットアップする必要があります。 </p> |
Enhancement |
`--active-locations`のプロキシルーティング(したがって、サブグループRAFT)を自動的に有効にします。サブグループRAFTをグローバルに有効にするconfigureオプションを削除します。 |
Bug fix |
EDB_SUBSCRIPTION_TOKENがログに記録されていないことを確認します。 |
Bug fix |
ユーザーがproducts/default/releaseリポジトリのtpa_2q_repositoriesへの追加を抑制することを許可します。 |
Bug fix |
<p>利用可能な場合、ノードがbdr_child_groupにサブスクライブすることを確認します。</p><p>ノードのサブスクライブしたレプリケーションセットから後者を誤って削除します。</p> |
Bug fix |
<p>Postgresが起動しない場合、有用なエラーで確実に失敗します。 </p><p> Ansibleのバグにより、Postgresが一部のインスタンスで起動せず、他のインスタンスで起動した場合(たとえば、構成の違いにより)、デプロイメントは失敗しませんでした。デプロイを続行すると、後で障害が発生したホストのcluster_factsにアクセスしようとするとエラーが発生しました。 </p> |
Bug fix |
<p> BDR 4.3以降のwitnessで`bdr.alter_node_replication_sets()`を呼び出さないでください。</p><p>これは、witnessノードがカスタムレプリケーションセット構成で処理されないBDRバージョンの新しい制限に調整されます。 </p> |
Bug fix |
ハードコードされた「barman」参照を置き換えて、 barman_{user,group}設定を使用してbarmanユーザーとホームディレクトリをカスタマイズできるようにします。 |
Bug fix |
必要に応じて、 postgres_databases[*].extensionsで言及されている拡張機能のshared_preload_librariesエントリを追加します。 |
Bug fix |
`pgaudit`がshared_preload_librariesの`bdr`の前に表示されないことを確認します(既知のクラッシュを回避するため)。 |
Bug fix |
pgd-cli構成ファイルの構文エラー(DSN引用)を修正します。 |
Bug fix |
<p>ファイルの書き換えを回避するために、pgd-proxy構成のエンドポイントを並べ替えます。 </p> <p>これには、次のデプロイ時にpgd-proxyの再起動が必要になる可能性があります(ただし、後続のデプロイでの将来の不要な書き換え/再起動を回避します)。 </p> |
Bug fix |
RHシステムにローカルリポジトリからrsyncをインストールする際のエラーを修正します。 |
Bug fix |
Debianシステム上のPEM 9のApache WSGIモジュール構成のエラーを修正します。 |
Bug fix |
bdr拡張機能が意図的に作成されている場合は、未使用であっても削除しないでください。 |
該当なし |