Menu Bar¶
pgAdminメニューバーには、オプション、コマンド、およびユーティリティにアクセスするためのドロップダウンメニューがあります。メニューバーには、 ファイル 、 オブジェクト 、ツール 、および ヘルプ の選択が表示されます。選択はグレー表示され、 pgAdmin*ツリーコントロールで現在選択されているオブジェクトで無効になっていることを示します。
ファイルメニュー¶
ファイル メニューを使用して、次のオプションにアクセスします。
オプション |
アクション |
|---|---|
設定 |
クリックして Preferences ダイアログを開き、pgAdmin設定をカスタマイズします。 |
レイアウトをリセット |
ワークスペースを変更した場合は、をクリックしてデフォルトのレイアウトに戻します。 |
ロックレイアウト |
クリックしてサブメニューを開きUIレイアウトをロックするレベルを選択こちらもブラウザ表示から変更可能 preferences |
ランタイム |
クリックして、構成、ログ、およびズーム設定を行うサブメニューを開きます。pgAdmin4がデスクトップモードで実行されている場合にのみ表示されます。ランタイムメニューについてもっと知るには click here |
オブジェクトメニュー¶
Object メニューは状況依存です。 Object メニューを使用して、次のオプションにアクセスします(アルファベット順)。
オプション |
アクション |
|---|---|
パスワードの変更... |
クリックして Change Password... ダイアログを開き、パスワードを変更します。 |
保存されたパスワードをクリアする |
データベースサーバーのパスワードを保存している場合は、クリックして保存したパスワードをクリアします。パスワードが既に保存されている場合にのみ有効にします。 |
SSHトンネルのパスワードをクリアする |
sshトンネルのパスワードを保存している場合は、クリックして保存したパスワードをクリアします。パスワードが既に保存されている場合にのみ有効にします。 |
サーバーに接続 |
クリックして Connect to Server ダイアログを開き、サーバーとの接続を確立します。 |
作成 |
Create をクリックして、状況依存の選択を提供するコンテキストメニューにアクセスします。選択すると、新しいオブジェクトを作成するための Create ダイアログが開きます。 |
削除/ドロップ |
クリックして、現在選択されているオブジェクトをサーバーから削除します。 |
サーバーから切断する |
クリックして、現在選択されているサーバーから切断します。 |
ドロップカスケード |
クリックして、現在選択されているオブジェクトとすべての依存オブジェクトをサーバーから削除します。 |
プロパティ... |
クリックして、現在選択されているオブジェクトのプロパティを確認または変更します。 |
リフレッシュ |
クリックして、現在選択されているオブジェクトを更新します。 |
サーバーを削除 |
クリックして、現在選択されているサーバーを削除します。 |
スクリプト |
クリックして Query tool を開き、フライアウトメニューから選択したスクリプトを編集します。 |
トリガー |
クリックして、現在選択されているテーブルのトリガーを 無効 または 有効 にします。オプションはフライアウトメニューに表示されます。 |
切り捨て |
クリックして、テーブルからすべての行を削除する( Truncate )、テーブルとその子テーブルからすべての行を削除する( TruncateCascade )、またはテーブルからすべての行を削除して列が所有するシーケンスを自動的にリスタートします( アイデンティティ )。オプションはフライアウトメニューに表示されます。 |
データを見る |
クリックして、データを表示するためのいくつかのオプションを提供するコンテキストメニューにアクセスします(以下を参照)。 |
データベースのERD |
クリックして、選択したデータベースの図が自動生成されたERDツールを開きます。このオプションは、データベースが選択されている場合にのみ使用できます。オプションはフライアウトメニューに表示されます。 |
テーブルのERD |
クリックして、選択したテーブルの図が自動生成されたERDツールを開きます。このオプションは、テーブルが選択されている場合にのみ使用できます。オプションはフライアウトメニューに表示されます。 |
ツールメニュー¶
[ツール]メニューを使用して、次のオプションにアクセスします(アルファベット順)。
オプション |
アクション |
|---|---|
ERDツール |
クリックして ERD Tool を開き、データベースの設計を開始します。 |
Grantウィザード... |
クリックして、 Grant Wizard ツールにアクセスします。 |
PSQLツール |
クリックして PSQL Tool を開き、現在のデータベースコンテキストでPSQLを起動します。 |
クエリツール |
クリックして、現在選択されているオブジェクトの Query tool を開きます。 |
スキーマの相違 |
クリックして Schema Diff を開き、2つのデータベースまたは2つのスキーマの比較を開始します。 |
バックアップグローバル... |
クリックして Backup Globals... ダイアログを開き、クラスターオブジェクトをバックアップします。 |
バックアップサーバー... |
クリックして Backup Server... ダイアログを開き、サーバーをバックアップします。 |
バックアップ... |
クリックして Backup... ダイアログを開き、データベースオブジェクトをバックアップします。 |
復元... |
クリックして Restore ダイアログにアクセスし、バックアップからデータベースファイルを復元します。 |
データのインポート/エクスポート... |
クリックして Import/Export data... ダイアログを開き、テーブルからデータをインポートまたはエクスポートします。 |
メンテナンス... |
クリックして、VACUUM、ANALYZE、REINDEX、またはCLUSTERの Maintenance... ダイアログを開きます。 |
オブジェクトを検索... |
クリックして Search Objects... を開き、データベース内の任意の種類のオブジェクトの検索を開始します。 |
名前付けられた復元ポイントを追加 |
クリックして Add named restore point... ダイアログを開き、現在のサーバー状態の特定の時点のスナップショットを撮ります。 |
WALのリプレイを一時停止 |
クリックして、WALログの再生を一時停止します。 |
WALのリプレイを再開 |
クリックして、WALログの再生を再開します。 |
設定をリロード... |
クリックして、サーバーを再起動せずに構成ファイルを更新します。 |
ストレージマネージャー |
クリックして Storage Manager を開き、バックアップファイルをアップロード、削除、またはダウンロードします。 |
ヘルプメニュー¶
[ ヘルプ ]メニューのオプションを使用して、オンラインヘルプドキュメントにアクセスするか、pgAdminインストールに関する情報を確認します(アルファベット順)。
オプション |
アクション |
|---|---|
クイック検索 |
クイック検索フィールドにキーワードを入力します。3文字以上入力すると、一致するすべてのものがメニュー項目に表示され、関連ドキュメントがヘルプ記事に表示されます。メニュー項目の下のオプションをクリックして、特定の機能またはオブジェクトのアクションを実行します。ヘルプ記事をクリックすると、そのトピックのヘルプが別のウィンドウでテキストが強調表示されます。 Note :-メニュー項目の下のオプションのいずれかが無効になっている場合、情報アイコンを介して情報が提供されます。 |
pgAdmin4について |
クリックしてウィンドウを開き、pgAdminに関する情報を確認します。これには、現在のバージョンと現在のユーザーが含まれます。 |
オンラインヘルプ |
クリックして、pgAdminユーティリティ、ツール、ダイアログの使用に関するドキュメントサポートを開きます。左側のブラウザーペインで(新しく開いたタブ内で)ヘルプドキュメントを移動するか、検索バーを使用してトピックを指定します。 |
pgAdminウェブサイト |
クリックして、ブラウザーウィンドウで pgAdmin.org Webサイトを開きます。 |
PostgreSQLウェブサイト |
クリックして、PostgreSQLサイトでホストされているPostgreSQLのコアドキュメントにアクセスします。このサイトでは、ガイド、チュートリアル、リソースも提供しています。 |