View/Edit Data#

データを表示または変更するには、 オブジェクトエクスプローラー でテーブルまたはビューの名前を右クリックします。コンテキストメニューが開いたら、 * View/Edit Data* メニューを使用して、エディターパネルに表示する行数を指定します。

編集グリッドウィンドウ

テーブルのコンテンツを変更するには、テーブル内の各行を一意に識別できる必要があります。テーブル定義にOIDまたは主キーが含まれない場合、表示されるデータは読み取り専用です。ビューは編集できないことに注意してください。更新可能なビュールールを使用はサポートされていません。

エディターには、頻繁に使用するオプションにすばやくアクセスできるツールバーと、2つのパネルに分割された作業環境が特徴です。

  • 上のパネルには、下のパネルに表示されるコンテンツを選択するために使用されたSQLコマンドが表示されます。

  • 下部パネルデータグリッドには、テーブルまたはビューから選択されたデータが表示されます。

データの表示/編集ツールバー#

Query Tool および Query Tool ツールは、実際には同じツールの異なる動作モードです。一部のコントロールはいずれのモードでも無効になります。使用可能なコントロールの説明については、 Query Tool を参照してください。

データグリッド#

データグリッドの一番上の行には、各列の名前、データ型、および該当する場合は許可される文字数が表示されます。主キーの一部である列には、さらに[PK]でマークされます。

表示されたデータを変更するには

  • グリッド内の数値を変更するには、値をダブルクリックしてフィールドを選択します。 表示されている正方形のコンテンツを変更します。

  • グリッド内の数値以外の値を変更するには、コンテンツをダブルクリックして編集バブルにアクセスします。 編集バブルの内容を変更した後、 Ok ボタンをクリックして変更をデータグリッドに表示するか、 Cancel をクリックして保存せずに編集バブルを終了します。

改行文字を入力するには、Ctrl-EnterまたはShift-Enterをクリックします。 改行フォーマットは、編集バブルを介してフィールドのコンテンツにアクセスした場合にのみ表示されます。

テーブルに新しい行を追加するには、テーブルの最後の番号のない行にデータを入力します。データを保存するとすぐに、行には行番号が割り当てられ、新しい空の行がデータグリッドに追加されます。

SQL NULLをテーブルに書き込むには、フィールドを空のままにするだけです。新しい行を保存すると、サーバーはその列のデフォルト値を入力します。既存の行に変更を保存する場合、値NULLが明示的に書き込まれます。

空の文字列をテーブルに書き込むには、フィールドに特殊な文字列'' 2つの一重引用符を入力します。 2つの一重引用符のみを含む文字列をテーブルに書き込む場合は、 /'/'と入力して、これらの引用符をエスケープする必要があります

行を削除するには、 Delete ツールバーボタンを押します。 ポップアップが開き、削除の確認を求めます。

サーバーに変更をコミットするには、[ Save Data ]ツールバーボタンを選択します。

Geometry Data Viewer

PostGISがインストールされている場合は、行を選択し、列の'View Geometry'ボタンをクリックすることにより、マップ内にGISオブジェクトを表示できます。行が選択されていない場合、データセット全体がレンダリングされます。

ジオメトリビューアボタン

パネルのタイトルをドラッグして、レイアウトを調整できます。マップにジオメトリのプロパティを直接表示するには、特定のジオメトリをクリックするだけです。

ジオメトリビューアプロパティテーブル

注釈

  • サポートされているデータタイプ Geometry Viewerは、`Point、LineString、Polygon MultiPoint、MultiLineString、MultiPolygon、GeometryCollection`を含むEWKB形式の2Dおよび3DMジオメトリをサポートしています。

  • SRIDs: If there are geometries with different SRIDs in the same column, the viewer will render geometries with the same SRID in the map. If SRID=4326 the OSM tile layer will be added into the map.

  • データサイズ パフォーマンス上の理由から、ビューアは100000以下のジオメトリ、合計最大20MBまでレンダリングします。

  • インターネットアクセス Geometry Viewerが正常に機能するには、インターネット接続が必要です。

JSON Data Editor

ビルトインのjsonエディターが JSON / JSONBデータ 用に提供されています。データグリッドのjson/jsonbデータタイプのセルをダブルクリックすると、JSONエディターが開きます。エディターは、jsonデータを表示および編集するためのさまざまなモードを提供します。

Jsonエディター

コードモード jsonデータをフォーマットおよび圧縮する方法を提供します。また、引用符とエスケープ文字を修正し、コメントとJSONP表記を削除し、JavaScriptオブジェクトをJSONに変換することにより、jsonデータを修復する機能も提供します。

ツリーモード フィールドと値を変更、追加、移動、削除、および複製できます。データを検索および強調表示する機能を提供します。

フォームモード 編集中にデータ構造を変更しない機能を提供することにより、jsonデータの値を編集することのみができます。

プレビューモード 保存する前にデータを確認する機能を提供し、現在のjsonデータのサイズも表示します。 jsonデータもフォーマットして圧縮します。

エディタツールバー

jsonデータを操作するためのさまざまなオプションが提供されています。

コード/プレビューモード

Jsonエディター コード/プレビューモード ツールバー

ツリー/フォームモード

Jsonエディターツリー/フォームモードツールバー

アイコン

動作

モードで使用可能

フォーマットJson

クリックして Format Json 適切なインデントでjsonデータをフォーマットします。

コード、プレビュー

Compact Json

Compact Json をクリックして、圧縮されたjsonデータを取得します。

コード、プレビュー

ソート

to Sort アイコンをクリックして、ファイル値を使用してデータの並べ替え基準を設定します。

コード、プレビュー、ツリー

トランスフォーム

クリックして 変換 して、JSMEクエリ言語を使用してデータをフィルタリングします。

コード、プレビュー、ツリー

元に戻す

Undo をクリックして、データに対して実行された最後のアクションを元に戻します。

コード、プレビュー、ツリー、From

やり直し

Redo をクリックして、データに対して実行された最後のアクションを繰り返します。

コード、プレビュー、ツリー、From

モード

モード ドロップダウンをクリックして、エディターの表示モードを変更します。使用可能なさまざまなモードは、コード、プレビュー、ツリー、フロムです。

コード、ツリー、フロム、プレビュー

すべて展開

Expand All をクリックして、jsonデータを展開します。

ツリー、フロム

すべて折りたたむ

クリックして やり直し して、jsonデータを折りたたみます。

ツリー、フロム

検索ボックス

データを検索する部分または完全な文字列を入力します。

ツリー、フロム

並べ替え/フィルターオプションダイアログ#

Sort/Filterボタンをクリックして、 並べ替え/フィルターオプションダイアログ にアクセスできます。これにより、 SQLフィルタを指定して表示されるデータと編集グリッドウィンドウでのデータの並べ替えオプションを制限できます。

グリッドフィルタの編集ダイアログウィンドウ
  • Use SQL Filter to provide SQL filtering criteria. These will be added to the "WHERE" clause of the query used to retrieve the data. For example, you might enter:

id > 25 AND created > '2018-01-01'
  • Data Sorting を使用して、出力グリッドのデータを並べ替えます

データ並べ替えグリッドに新しい列を追加するには、[+]アイコンをクリックします。

  • ドロップダウン 列 を使用して、並べ替える列を選択します。

  • ドロップダウン * Order * を使用して、列のソート順を選択します。

  • ドロップダウン NULLs を使用して、列のNULL値の順序を選択します。

グリッドから行を削除するには、ゴミ箱アイコンをクリックします。

  • Save ボタンをクリックして、作業を保存します。

  • Close ボタンをクリックして、現在の変更を破棄し、ダイアログを閉じます。

データの表示/編集をクエリツールに昇格させる#

クエリを編集するだけで、View/Edit Dataタブをクエリツールタブに変換できます。編集を開始すると、本当にView/Editから移動するかどうかを聞いてきます。

[ View/Edit Data ]タブを[ Query Tools ]タブに昇格する警告

/"Don't Ask again/"チェックボックスを選択することにより、ダイアログを無効にできます。確認ダイアログを再開したい場合は、/"Prefences -> Query Tool -> Editor -> Show View/Edit Data Promotion Warning?"から行うことができます。

続行を選択すると、フィルタや並べ替えのオプション、制限などの表示/編集モードの機能は使用できません。これは一方通行の変換です。今ではクエリツールになります。