Skip to main content
Ctrl+K
pgAdmin 4 9.9 ドキュメント - Home
  • Getting Started
    • Deployment
      • The config.py File
      • Desktop Deployment
        • pgAdmin 4デスクトップアプリケーションの自動更新
      • Server Deployment
      • Container Deployment
    • Login Page
    • Enabling two-factor authentication (2FA)
    • User Management
    • Change Ownership Dialog
    • Change User Password Dialog
    • Lock/Restore Account
    • Enabling LDAP Authentication
    • Enabling Kerberos Authentication
    • Enabling OAUTH2 Authentication
    • Enabling Webserver Authentication
    • User Interface
    • Menu Bar
    • Toolbar
    • Tabbed Browser
    • Tree Control
    • Preferences
    • Keyboard Shortcuts
    • Search objects
  • External database for pgAdmin user settings
  • Connecting To A Server
    • Server Group Dialog
    • Server Dialog
      • Clear Saved Passwords
    • PostgreSQL Cloud Deployment
      • Amazon RDS Cloud Deployment
      • EDB BigAnimal Cloud Deployment
      • Azure Database Cloud Deployment
      • Google Cloud SQL Deployment
    • Master Password
    • Connect to Server
    • Connection Error
    • Import/Export Servers
  • Managing Cluster Objects
    • Database Dialog
    • Resource Group Dialog
    • Login/Group Role Dialog
    • Tablespace Dialog
    • Replica Node Dialog
    • PGD Replication Group Node Dialog
      • PGD Replication Server Node Dialog
    • Role Reassign/Drop Own Dialog
    • Directory Dialog
  • Managing Database Objects
    • Cast Dialog
    • Using EDB Job Scheduler
      • DBMS Job
      • DBMS Program
      • DBMS Schedule
    • Collation Dialog
    • Domain Dialog
    • Domain Constraints Dialog
    • Event Trigger Dialog
    • Extension Dialog
    • Foreign Data Wrapper Dialog
    • Foreign Server Dialog
    • Foreign Table Dialog
    • FTS Configuration Dialog
    • FTS Dictionary Dialog
    • FTS Parser Dialog
    • FTS Template Dialog
    • Function Dialog
    • Language Dialog
    • Materialized View Dialog
    • Package Dialog
    • Procedure Dialog
    • Publication Dialog
    • Schema Dialog
    • Sequence Dialog
    • Subscription Dialog
    • Synonym Dialog
    • Trigger Function Dialog
    • Type Dialog
    • User Mapping Dialog
    • View Dialog
  • Creating or Modifying a Table
    • Check Dialog
    • Column Dialog
    • Compound Trigger Dialog
    • Exclusion Constraint Dialog
    • Foreign key Dialog
    • Index Dialog
    • Primary key Dialog
    • RLS Policy Dialog
    • Rule Dialog
    • Table Dialog
    • Trigger Dialog
    • Unique Constraint Dialog
  • Management Basics
    • Add Named Restore Point Dialog
    • Change Password Dialog
    • Grant Wizard
    • Export Data Using Query Dialog
    • Import/Export Data Dialog
    • Maintenance Dialog
    • Storage Manager
  • Backup and Restore
    • Backup Dialog
    • Backup Globals Dialog
    • Backup Server Dialog
    • Restore Dialog
  • Developer Tools
    • Debugger
    • Query Tool
      • Query Tool Toolbar
    • View/Edit Data
      • View/Edit Data Filter
    • Schema Diff
    • ERD Tool
    • PSQL Tool
  • Processes
  • pgAgent
    • Using pgAgent
    • Installing pgAgent
    • Creating a pgAgent Job
  • pgAdmin Project Contributions
    • Submitting Pull Requests
    • Code Overview
    • Coding Standards
    • Code Review Notes
    • Translations
  • リリースノート
    • バージョン9.9
    • バージョン9.8
    • バージョン9.7
    • バージョン9.6
    • バージョン9.5
    • バージョン9.4
    • バージョン9.3
    • バージョン9.2
    • バージョン9.1
    • バージョン9.0
    • バージョン8.14
    • バージョン8.13
    • バージョン8.12
    • バージョン8.11
    • バージョン8.10
    • バージョン8.9
    • バージョン8.8
    • バージョン8.7
    • バージョン8.6
    • バージョン8.5
    • バージョン8.4
    • バージョン8.3
    • バージョン8.2
    • バージョン8.1
    • バージョン8.0
    • バージョン7.8
    • バージョン7.7
    • バージョン7.6
    • バージョン7.5
    • バージョン7.4
    • バージョン7.3
    • バージョン7.2
    • バージョン7.1
    • バージョン7.0
    • バージョン6.21
    • バージョン6.20
    • バージョン6.19
    • バージョン6.18
    • バージョン6.17
    • バージョン6.16
    • バージョン6.15
    • バージョン6.14
    • バージョン6.13
    • バージョン6.12
    • バージョン6.11
    • バージョン6.10
    • バージョン6.9
    • バージョン6.8
    • バージョン6.7
    • バージョン6.6
    • バージョン6.5
    • バージョン6.4
    • バージョン6.3
    • バージョン6.2
    • バージョン6.1
    • バージョン6.0
    • バージョン5.7
    • バージョン5.6
    • バージョン5.5
    • バージョン5.4
    • バージョン5.3
    • バージョン5.2
    • バージョン5.1
    • バージョン5.0
    • バージョン4.30
    • バージョン4.29
    • バージョン4.28
    • バージョン4.27
    • バージョン4.26
    • バージョン4.25
    • バージョン4.24
    • バージョン4.23
    • バージョン4.22
    • バージョン4.21
    • バージョン4.20
    • バージョン4.19
    • バージョン4.18
    • バージョン4.17
    • バージョン4.16
    • バージョン4.15
    • バージョン4.14
    • バージョン4.13
    • バージョン4.12
    • バージョン4.11
    • バージョン4.10
    • バージョン4.9
    • バージョン4.8
    • バージョン4.7
    • バージョン4.6
    • バージョン4.5
    • バージョン4.4
    • バージョン4.3
    • バージョン4.2
    • バージョン4.1
    • バージョン4.0
    • バージョン3.6
    • バージョン3.5
    • バージョン3.4
    • バージョン3.3
    • バージョン3.2
    • バージョン3.1
    • バージョン3.0
    • バージョン2.1
    • バージョン2.0
    • バージョン1.6
    • バージョン1.5
    • バージョン1.4
    • バージョン1.3
    • バージョン1.2
    • バージョン1.1
    • バージョン1.0
  • Licence
  • .rst

Menu Bar

目次

  • ファイルメニュー
  • オブジェクトメニュー
  • ツールメニュー
  • ヘルプメニュー

Menu Bar#

pgAdminメニューバーは、オプション、コマンド、ユーティリティにアクセスするためのドロップダウンメニューを提供します。メニューバーには、 ファイル 、 オブジェクト 、ツール 、および ヘルプ の選択項目が表示されます。選択項目は灰色で表示され、 pgAdmin*ツリーコントロールで現在選択されているオブジェクトに対して無効になっていることを示します。

ファイルメニュー#

pgAdminファイルメニューバー

Use the File menu to access the following options:

オプション

アクション

設定

クリックして Preferences ダイアログを開き、pgAdmin設定をカスタマイズします。

レイアウトをリセット

ワークスペースを変更した場合、クリックしてデフォルトのレイアウトを復元します。

ランタイム

クリックしてサブメニューを開き、[ Configure ]、[ View Log ]、[ Zoom設定 ]を選択します。 pgAdmin4がデスクトップモードで実行されている場合にのみ表示されます。ランタイムメニューの詳細について click here

オブジェクトメニュー#

pgAdminオブジェクトメニューバー

Object メニューは状況依存です。 Object メニューを使用して、次のオプションアルファベット順にアクセスします。

オプション

アクション

登録

  1. サーバー

  2. クラウドインスタンスの展開

クリックして Server ダイアログを開き、サーバーを登録します。

クリックして Cloud Deployment ダイアログを開き、クラウドインスタンスを展開します。

パスワードを変更します...

クリックして Change Password... ダイアログを開き、パスワードを変更します。

保存したパスワードをクリアします

データベースサーバーパスワードを保存している場合、クリックして保存したパスワードをクリアします。パスワードが既に保存されている場合にのみ有効にします。

SSHトンネルパスワードのクリア

sshトンネルパスワードを保存している場合、クリックして保存したパスワードをクリアします。パスワードが既に保存されている場合にのみ有効にします。

Connect Server

クリックして Connect to Server ダイアログを開き、サーバーとの接続を確立します。

コピーサーバー...

クリックして、現在選択しているサーバーをコピーします。

作成

Create をクリックして、状況依存の選択を提供するコンテキストメニューにアクセスします。選択すると、新しいオブジェクトを作成するための Create ダイアログが開きます。

ドロップ

クリックして、現在選択しているオブジェクトをサーバーからドロップします。

ドロップカスケード

クリックして、現在選択しているオブジェクトとすべての依存オブジェクトをサーバーからドロップします。

ドロップフォース

クリックして、forceオプションを使用して現在選択しているデータベースを削除します。

サーバーから切断します

クリックして、現在選択しているサーバーから切断します。

プロパティ...

クリックして、現在選択しているオブジェクトのプロパティを確認または変更します。

リフレッシュ

クリックして、現在選択しているオブジェクトを更新します。

サーバーの削除

クリックして、現在選択しているサーバーを削除します。

スクリプト

Query tool をクリックして開き、フライアウトメニューから選択したスクリプトを編集または表示します。

トリガー

クリックして、現在選択しているテーブルのトリガーを Disable または Enable にします。オプションはフライアウトメニューに表示されます。

Truncate

クリックしてテーブル/外部テーブルからすべての行を削除する Truncate 、テーブル/外部テーブルとその子テーブルからすべての行を削除する Truncate Cascade 、またはテーブル/外部テーブルからすべての行を削除し、自動的に列 Truncate Restart Identity が所有するリスタートシーケンス。オプションはフライアウトメニューに表示されます。

データを表示する

クリックして、データを表示するためのいくつかのオプションを提供するコンテキストメニューにアクセスします。以下を参照してください。

データベースのERD

クリックするとERDツールが開き、選択したデータベースの図が自動生成されます。このオプションは、データベースが選択された場合にのみ使用できます。オプションはフライアウトメニューに表示されます。

テーブルのERD

クリックするとERDツールが開き、選択したテーブルの図が自動生成されます。このオプションは、テーブルが選択されている場合にのみ使用できます。オプションはフライアウトメニューに表示されます。

ツールメニュー#

pgAdminツールのメニューバー

Tools メニューを使用して、次のオプションアルファベット順にアクセスします。

オプション

アクション

ERDツール

クリックして ERD Tool を開き、データベースのデザインを開始します。

Grant Wizard...

クリックして Grant Wizard ツールにアクセスします。

PSQLツール

クリックして PSQL Tool を開き、現在のデータベースコンテキストでPSQLを起動します。

クエリツール

クリックして、現在選択しているオブジェクトの Query tool を開きます。

スキーマ差分

クリックして Schema Diff を開き、2つのデータベースまたは2つのスキーマの比較を開始します。

バックアップグローバル...

クリックして Backup Globals... ダイアログを開き、クラスターオブジェクトをバックアップします。

バックアップサーバー...

クリックして Backup Server... ダイアログを開き、サーバーをバックアップします。

バックアップ...

クリックして Backup... ダイアログを開き、データベースオブジェクトをバックアップします。

リストア...

クリックして Restore ダイアログにアクセスし、バックアップからデータベースファイルを復元します。

クエリーを使用してデータをエクスポート...

クリックして Export Data Using Query... ダイアログを開き、クエリーを使用してテーブルからデータをエクスポートします。

データのインポート/エクスポート...

クリックして Import/Export data... ダイアログを開き、テーブルからデータをインポートまたはエクスポートします。

メンテナンス...

クリックして、 VACUUM、 ANALYZE、REINDEX、またはCLUSTERの Maintenance... ダイアログを開きます。

検索オブジェクト...

クリックして Search Objects... を開き、データベース内の任意の種類のオブジェクトの検索を開始します。

名前付け復元ポイントを追加

クリックして Add named restore point... ダイアログを開き、現在のサーバー状態のポイントインタイムのスナップショットを取得します。

WALの一時停止再生

クリックして、WALログの再生を一時停止します。

WALの再生を再開

クリックして、WALログの再生を再開します。

構成のリロード...

クリックして、サーバーを再起動せずに構成ファイルを更新します。

ストレージマネージャー

Storage Manager をクリックして開き、バックアップファイルをアップロード、削除、またはダウンロードします。

ヘルプメニュー#

pgAdminヘルプメニューバー

Use the options on the Help menu to access online help documents, or to review information about the pgAdmin installation (in alphabetical order):

オプション

アクション

クイック検索

Quick Searchフィールドにキーワードを入力します。少なくとも3文字を入力すると、メニュー項目の下に一致するすべての可能性が表示され、ヘルプ記事の下に関連ドキュメントが表示されます。メニュー項目の下のオプションをクリックして、特定の機能またはオブジェクトのアクションを実行します。ヘルプ記事のいずれかをクリックすると、そのトピックのヘルプが開き、別のウィンドウで強調表示されたテキストが表示されます。

Note メニュー項目の下のオプションのいずれかが無効になっている場合、情報アイコンを介して情報を提供します。

pgAdmin 4について

クリックするとウィンドウが開き、pgAdminに関する情報を提供します。これには、現在のバージョンと現在のユーザーが含まれます。

オンラインヘルプ

クリックすると、pgAdminユーティリティ、ツール、ダイアログを使用するためのドキュメントサポートが開きます。左側のブラウザペインでヘルプドキュメントを新しく開いたタブでナビゲートするか、検索バーを使用してトピックを指定します。

pgAdmin Webサイト

クリックして、ブラウザウィンドウで * pgAdmin.org* Webサイトを開きます。

PostgreSQL Webサイト

クリックして、PostgreSQLサイトでホストされているPostgreSQLコアドキュメントにアクセスします。このサイトでは、ガイド、チュートリアル、リソースも提供しています。

前へ

User Interface

次へ

Toolbar

目次
  • ファイルメニュー
  • オブジェクトメニュー
  • ツールメニュー
  • ヘルプメニュー

著者 The pgAdmin Development Team

© Copyright Copyright (C) 2013 - 2025, The pgAdmin Development Team.